You are not logged in.

#1 2013-10-30 20:06:21

gunjah292
Member
From: Hamburg
Registered: 2011-05-05
Posts: 57

Problems with Laptop-Mode

Hey,

I just installed LMT. I was able to configure cpupower until I reached the section for setting the governor. When I type cpupower frequency-set -g ondemand the system tells me that the governor doesn't exist or isn't loaded. I'd post the output if it wasn't in German. I remember that there is a prefix that forces the console to give out messages in English. Could you help me out?

Now when I boot I get the following message:

 * Starting laptop_mode ...
Laptop mode
enabled, active
/usr/share/laptop-mode-tools/modules/cpufreq: line 11: echo: write error: Invalid argument
SETTING OF KERNEL PARAMETER FAILED: echo ondemand \> /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
/usr/share/laptop-mode-tools/modules/cpufreq: line 11: echo: write error: Invalid argument
SETTING OF KERNEL PARAMETER FAILED: echo ondemand \> /sys/devices/system/cpu/cpu1/cpufreq/scaling_governor
/usr/share/laptop-mode-tools/modules/cpufreq: line 11: echo: write error: Invalid argument
SETTING OF KERNEL PARAMETER FAILED: echo ondemand \> /sys/devices/system/cpu/cpu2/cpufreq/scaling_governor
/usr/share/laptop-mode-tools/modules/cpufreq: line 11: echo: write error: Invalid argument
SETTING OF KERNEL PARAMETER FAILED: echo ondemand \> /sys/devices/system/cpu/cpu3/cpufreq/scaling_governor  
Failed.
Failed.

Last edited by gunjah292 (2013-10-30 20:13:30)

Offline

#2 2013-10-30 21:31:53

skualito
Member
Registered: 2008-11-19
Posts: 186

Re: Problems with Laptop-Mode

If I recall correctly the ondemand governor module is builtin within kernel on arch, thus cannot be loaded.

Also have a look at the wiki: https://wiki.archlinux.org/index.php/CP … ncy_driver

For output in english

LC_ALL=C cpupower frequency-info

Last edited by skualito (2013-10-30 21:36:23)

Offline

#3 2013-11-05 00:11:50

gunjah292
Member
From: Hamburg
Registered: 2011-05-05
Posts: 57

Re: Problems with Laptop-Mode

Yeah I already dropped the CPU governor. The only thing that really bugs me is the HDD-spindown. Sometimes I have to wait about a second for a new tab to open when I click on it. I'll search for another way to configure hdparm, tomorrow! All this shit should be integrated in the kernel anyway. So things are going forward I guess...

Offline

#4 2013-11-05 00:45:53

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: Problems with Laptop-Mode

Unfortunately the hdparm APM value goes back to default after suspend, hibernate, etc.  So what I did when I used rotational disks is put a small script in /usr/lib/systemd/system-sleep that would reimplement that value after it woke.  See the systemd-sleep man page for how this works.  I'm not sure if laptop-mode-tools is supposed to handle that kind of crap for you, but if it isn't (or doesn't for some reason), going the systemd-sleep route is a good workaround until things are fixed.

Also, about the cpupower error, are you by change using an Intel processor?  Namely, and Intel processor that is Sandy Bridge or newer?  If so, the reason you are unable to set the governor is because it is using the intel pstate driver for those processors.  Fear not though because it is actually superior.  Check if this is the case by doing cpupower frequency-info.

Offline

#5 2013-11-05 02:56:54

gunjah292
Member
From: Hamburg
Registered: 2011-05-05
Posts: 57

Re: Problems with Laptop-Mode

Sandy Bridge it is! wink I already removed LMT tools, because I read somewhere that it is outdated anyway. I'll retry installing it when I find some time.

Offline

#6 2013-11-05 03:30:13

gunjah292
Member
From: Hamburg
Registered: 2011-05-05
Posts: 57

Re: Problems with Laptop-Mode

Okay since I can't sleep I just tried it. I configured LMT without cpufreq. I'm still not sure if the hdparm module is loaded, since I can't find a .conf file in /etc/laptop-mode.d/.
When I reboot I get three additional messages saying:

enabled, active.
failed.
failed.

There's no information about which modules failed whatsoever.

Last edited by gunjah292 (2013-11-05 03:30:42)

Offline

#7 2013-11-09 00:58:46

scatterplot
Member
Registered: 2013-10-15
Posts: 17

Re: Problems with Laptop-Mode

To address the spindown issue apply the udev rule presented in the wiki.


Load"*",8,1

Offline

Board footer

Powered by FluxBB