You are not logged in.

#26 2013-11-01 01:57:36

karol
Archivist
Registered: 2009-05-06
Posts: 25,427

Re: Firefox 25 issue?

cfr wrote:

The PKGBUILD includes this

  # Fix tab loading icon (flickers with libpng 1.6)
  # https://bugzilla.mozilla.org/show_bug.cgi?id=841734
  cp "$srcdir/firefox-20.0.1-fixed-loading-icon.png" \
    browser/themes/linux/tabbrowser/loading.png

'Fixed' is ambiguous. Do they mean 'repaired' or do they mean 'unmoving'?

This shouldn't matter, since it used to work and these lines were present in the firefox 24 PKGBUILD too.

Offline

#27 2013-11-01 02:04:25

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 5,153

Re: Firefox 25 issue?

That was removed over a month ago, but this is the first package to be built without it.. but the upstream precompiled binaries wouldn't have that fix applied, would they?

https://projects.archlinux.org/svntogit … 05d459ef62


Sakura:-
Mobo: ASUS P8Z77-V PRO // Processor: Intel Core i7-3770K 3.4GHz // GFX: nVidia GeForce GTX 970 Ti // RAM: 32GB (4x 8GB) Corsair DDR3 (@ 2133MHz) // Storage: 1x 3TB Seagate SATAII 5x 1TB Samsung SATAII, 2x 120GB Corsair SSD

Offline

#28 2013-11-01 02:04:50

karol
Archivist
Registered: 2009-05-06
Posts: 25,427

Re: Firefox 25 issue?

cfr wrote:

The PKGBUILD includes this

  # Fix tab loading icon (flickers with libpng 1.6)
  # https://bugzilla.mozilla.org/show_bug.cgi?id=841734
  cp "$srcdir/firefox-20.0.1-fixed-loading-icon.png" \
    browser/themes/linux/tabbrowser/loading.png

'Fixed' is ambiguous. Do they mean 'repaired' or do they mean 'unmoving'?

Wait wait wait.
Where did you find it?
https://projects.archlinux.org/svntogit … es/firefox doesn't have it.
https://projects.archlinux.org/svntogit … 05d459ef62 removed it.

Offline

#29 2013-11-01 02:18:57

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,661

Re: Firefox 25 issue?

Sorry. I didn't notice it is in the PKGBUILD for version 24.0-1 which is still on my machine because abs only updates once every 24 hours and was last updated just over 23 hours ago. I am guessing the file for 25.0-1 will appear next time it is updated.

Apologies for not double-checking the build version. Sorry for the noise.


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#30 2013-11-01 02:21:17

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 5,153

Re: Firefox 25 issue?

OOM killer killed my firefox build (I only have 16GB of RAM, sorry Mozilla). I think that, since it affects the 32-bit extra/firefox package too, this isn't just a compilation hiccup. Presumably whatever in libpng 1.6.3 that was supposed to have fixed the flicker, has actually broken the animation entirely..

EDIT: I've checked the binaries in the tarballs cfr linked to, and the throbber's working fine in those for me too.

Last edited by WorMzy (2013-11-01 02:25:08)


Sakura:-
Mobo: ASUS P8Z77-V PRO // Processor: Intel Core i7-3770K 3.4GHz // GFX: nVidia GeForce GTX 970 Ti // RAM: 32GB (4x 8GB) Corsair DDR3 (@ 2133MHz) // Storage: 1x 3TB Seagate SATAII 5x 1TB Samsung SATAII, 2x 120GB Corsair SSD

Offline

#31 2013-11-01 02:43:26

karol
Archivist
Registered: 2009-05-06
Posts: 25,427

Re: Firefox 25 issue?

WorMzy wrote:

OOM killer killed my firefox build (I only have 16GB of RAM, sorry Mozilla).

That's why I kept asking if anyone knows if it's upstream or Arch's fault - I can't test it myself either.

WorMzy wrote:

EDIT: I've checked the binaries in the tarballs cfr linked to, and the throbber's working fine in those for me too.

Are we opening a bug report on Arch bugtracke then?

Offline

#32 2013-11-01 05:49:24

x33a
Forum Moderator
Registered: 2009-08-15
Posts: 3,307
Website

Re: Firefox 25 issue?

karol wrote:

Are we opening a bug report on Arch bugtracke then?

done: https://bugs.archlinux.org/task/37576

Offline

#33 2013-11-01 05:51:41

KingYes
Member
From: Israel
Registered: 2011-05-08
Posts: 120
Website

Re: Firefox 25 issue?

Voted :]


Web Developer.

Offline

#34 2013-11-01 12:01:39

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 4,214

Re: Firefox 25 issue?

for reference :

on my fully updated system running lxde/openbox the throbbers are functioning normally with extra/firefox 25.0 .

Maybe this is WM/DE related ?


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#35 2013-11-01 12:15:25

x33a
Forum Moderator
Registered: 2009-08-15
Posts: 3,307
Website

Re: Firefox 25 issue?

Lone_Wolf wrote:

Maybe this is WM/DE related ?

I doubt that. But, in any case, can you post the same on the bug report?

Offline

#36 2013-11-01 12:31:18

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 5,153

Re: Firefox 25 issue?

I'm using openbox too, so I don't think that's a factor.


Sakura:-
Mobo: ASUS P8Z77-V PRO // Processor: Intel Core i7-3770K 3.4GHz // GFX: nVidia GeForce GTX 970 Ti // RAM: 32GB (4x 8GB) Corsair DDR3 (@ 2133MHz) // Storage: 1x 3TB Seagate SATAII 5x 1TB Samsung SATAII, 2x 120GB Corsair SSD

Offline

#37 2013-11-01 12:35:34

karol
Archivist
Registered: 2009-05-06
Posts: 25,427

Re: Firefox 25 issue?

Lone_Wolf wrote:

for reference :

on my fully updated system running lxde/openbox the throbbers are functioning normally with extra/firefox 25.0 .

Maybe this is WM/DE related ?

Can you make sure you're running firefox 25 e.g. click Help -> About firefox.

Offline

#38 2013-11-01 12:42:59

Radioactiveman
Member
From: Germany
Registered: 2010-05-13
Posts: 376

Re: Firefox 25 issue?

I have tried to copy that png file to

/usr/lib/firefox/browser/themes/linux/tabbrowser/loading.png

but the issue persists. Therefore I doubt a rebuild is changing anything.

Offline

#39 2013-11-01 13:31:48

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 4,214

Re: Firefox 25 issue?

$ pacman -Qi firefox | grep Version
Version        : 25.0-1
$

Firefox > Help > about does also show 25.0 as version .

it's prob worth mentioning I do have the addon "tabbrowser preferences 3.0" installed.

Also in about:config , i've set browser.tabs.onTop to false

Edit :
Since we have no idea atm why it wokrs on my system but not on others, i don't think i can contribute much to the bugreport for now.

Has anyone tried running firefox with a clean profile without addons to narrow down possible causes ?

Last edited by Lone_Wolf (2013-11-01 13:35:30)


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#40 2013-11-01 13:55:37

guntram
Member
Registered: 2013-07-02
Posts: 27

Re: Firefox 25 issue?

My firefox (25.0-1, 64-Bit) won't even start up since today (updated yesterday):

$ firefox
Illegal instruction (core dumped)

Offline

#41 2013-11-01 14:28:26

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 5,153

Re: Firefox 25 issue?

Lone_Wolf wrote:
$ pacman -Qi firefox | grep Version
Version        : 25.0-1
$

Firefox > Help > about does also show 25.0 as version .

it's prob worth mentioning I do have the addon "tabbrowser preferences 3.0" installed.

Also in about:config , i've set browser.tabs.onTop to false

Edit :
Since we have no idea atm why it wokrs on my system but not on others, i don't think i can contribute much to the bugreport for now.

Has anyone tried running firefox with a clean profile without addons to narrow down possible causes ?

I tried safe-mode, which didn't help. Recompiling with the 'fixed' png has fixed the issue for me.

I'm assuming it has something to do with libpng. Do you have a patched version installed?


Sakura:-
Mobo: ASUS P8Z77-V PRO // Processor: Intel Core i7-3770K 3.4GHz // GFX: nVidia GeForce GTX 970 Ti // RAM: 32GB (4x 8GB) Corsair DDR3 (@ 2133MHz) // Storage: 1x 3TB Seagate SATAII 5x 1TB Samsung SATAII, 2x 120GB Corsair SSD

Offline

#42 2013-11-01 16:28:48

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 4,214

Re: Firefox 25 issue?

no, just the standard libpng and lib32-libpng, version 1.6.6-1 .

But i'm curious about when firefox uses that icon file .  it's nowhere to be find in any of the packages that used that fix, so it must be hardcoded somewhere.

Could this issue be theme related ?


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#43 2013-11-01 16:36:29

karol
Archivist
Registered: 2009-05-06
Posts: 25,427

Re: Firefox 25 issue?

You can find it here: https://projects.archlinux.org/svntogit … 4a5fef7ba2
It has been removed in https://projects.archlinux.org/svntogit … 05d459ef62

I've noticed that when I clicked on the link to the animated png, the throbber came to life - but only for this tab.

Offline

#44 2013-11-01 16:37:03

x33a
Forum Moderator
Registered: 2009-08-15
Posts: 3,307
Website

Re: Firefox 25 issue?

Lone_Wolf wrote:

Has anyone tried running firefox with a clean profile without addons to narrow down possible causes ?

Yeah, I tried it with a new system user, but the issue persists.

Offline

#45 2013-11-01 16:55:19

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 4,214

Re: Firefox 25 issue?

X33a :  thanks, that indicates the problem is not in firefox user changed setings.

karol :  that's the sourcefile, what i meant is the file can not be found in the binary packages that are installed.

edit : the fixed png looks exactly like what i see when refreshing a tab

Last edited by Lone_Wolf (2013-11-01 16:56:12)


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#46 2013-11-01 17:11:59

karol
Archivist
Registered: 2009-05-06
Posts: 25,427

Re: Firefox 25 issue?

Lone_Wolf wrote:

what i meant is the file can not be found in the binary packages that are installed.

When you run

chrome://browser/skin/tabbrowser/loading.png

in the browser, do you see a moving throbber or a still picture?

Offline

#47 2013-11-01 17:16:31

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 4,214

Re: Firefox 25 issue?

If i run that, i see a still picture . also the icon in the tab bar stays still then.

EDIT :

I've looked at the icon closely and realise now i have the same issue as the others posted in this thread.

My connection/browser tends to respond very fast, so it LOOKED like the tab reload icon was moving.

Last edited by Lone_Wolf (2013-11-01 20:29:39)


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#48 2013-11-01 20:53:26

digirium
Member
Registered: 2012-11-15
Posts: 51

Re: Firefox 25 issue?

Noticed perhaps another issue with FF 25 proxy routing stopped working. Using FoxyProxy plugin through socks for certain web sites pattern matched in FoxyProxy - the FoxyProxy icon changes color (set to red when in use) but not routing through socks. Just me?

Offline

#49 2013-11-01 21:17:15

digirium
Member
Registered: 2012-11-15
Posts: 51

Re: Firefox 25 issue?

Ahh nvm there is a new update for FoxyProxy solves proxy issues (4.2.3).

Offline

#50 2013-11-01 21:47:06

tonk
Member
Registered: 2013-05-15
Posts: 38

Re: Firefox 25 issue?

Lone_Wolf wrote:

Could this issue be theme related ?

Yes, I'm using the native gtk theme and have no problems with the throbber. With the "Default 25.0" theme it's not animated.

Offline

Board footer

Powered by FluxBB