You are not logged in.

#1 2013-11-04 12:45:13

Duxon
Member
Registered: 2010-12-01
Posts: 41

[SOLVED] Question about /etc/fstab, systemd and lvm.

Hi,

something happens which I cannot explain:

At the beginning of my boot process it's taking 10 seconds to wait for a device by UUID, but this very UUID is not listed in my /etc/fstab. Afterwards the boot process succeeds without any errors. Why does this happen? Has systemd its own service for mounting (my old) devices?

I'm running lvm on luks and changed the size of my swap partition a few days back. That resulted in a new UUID and I edited /etc/fstab accordingly.
Maybe I just overlooked something trivial in my setup, but anything besides /etc/fstab in use to mount partitions into the filesystem would be new to me.

duxon@rolfgang:~% lsblk -f
NAME            FSTYPE      LABEL UUID                                   MOUNTPOINT
sda                                                                      
├─sda1          ext4              91d776eb-1cf4-4437-a06e-f6a86ee7d0fb   /boot
└─sda2          crypto_LUKS       60ccab35-5c5c-412f-9acc-0d851ac4970f   
  └─main        LVM2_member       3sVi2y-NRZb-lkce-RM6M-JmqI-qlDn-AiTmdM 
    ├─main-root ext4              457364e5-8d28-4d20-aa7f-befa16d76ae4   /
    ├─main-swap swap              6ccf4f96-a05f-4e71-b864-7652e3684c23   
    └─main-home ext4        home  16f3b434-2e12-418c-84a3-d50c9abdd17d   /home
duxon@rolfgang:~% cat /etc/fstab
# 
# /etc/fstab: static file system information
#
# <file system>	<dir>	<type>	<options>	<dump>	<pass>
# /dev/mapper/main-root
/dev/mapper/main-root     /         	ext4      	rw,relatime,data=ordered	0 1

# /dev/mapper/main-home LABEL=home
/dev/mapper/main-home     /home     	ext4      	rw,relatime,data=ordered	0 2

# /dev/sda1
UUID=91d776eb-1cf4-4437-a06e-f6a86ee7d0fb	/boot     	ext4      	rw,relatime,data=ordered	0 2

#swap
UUID=6ccf4f96-a05f-4e71-b864-7652e3684c23 	none	swap	defaults,discard	0 0

Thank you.

Last edited by Duxon (2013-11-07 09:19:14)

Offline

#2 2013-11-06 01:39:05

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 6,238

Re: [SOLVED] Question about /etc/fstab, systemd and lvm.

Shouldn't you use a /dev/mapper/ entry for swap since it is a logical volume rather than a physical partition?

EDIT: I checked my fstab and that's how I do it - just as I specify /,  /home etc.

Last edited by cfr (2013-11-06 01:39:58)


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | refind | stub loader | systemd | LVM2 on LUKS
Lenovo x270 | Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz | Intel Corporation Wireless 8265 / 8275 | US keyboard with Euro | 512G NVMe INTEL SSDPEKKF512G7L

Offline

#3 2013-11-06 14:33:45

Duxon
Member
Registered: 2010-12-01
Posts: 41

Re: [SOLVED] Question about /etc/fstab, systemd and lvm.

No success using the /dev/mapper entry for swap.

It still waits 10 seconds for a depreciated UUID, even though I have nowhere specified this UUID.

I didn't find much information on systemd on that matter either.

duxon@rolfgang:~% systemctl list-units | grep mount
proc-sys-fs-binfmt_misc.automount                                                         loaded active waiting   Arbitrary Executable File Formats File System Automount Point
-.mount                                                                                   loaded active mounted   /
boot.mount                                                                                loaded active mounted   /boot
dev-hugepages.mount                                                                       loaded active mounted   Huge Pages File System
dev-mqueue.mount                                                                          loaded active mounted   POSIX Message Queue File System
home.mount                                                                                loaded active mounted   /home
run-user-1000-gvfs.mount                                                                  loaded active mounted   /run/user/1000/gvfs
sys-fs-fuse-connections.mount                                                             loaded active mounted   FUSE Control File System
sys-kernel-config.mount                                                                   loaded active mounted   Configuration File System
sys-kernel-debug.mount                                                                    loaded active mounted   Debug File System
tmp.mount                                                                                 loaded active mounted   Temporary Directory
systemd-remount-fs.service                                                                loaded active exited    Remount Root and Kernel File Systems

Systemd doesn't seem to load swap. It loads /home however, whose UUID has changed as well.
Could it be that systemd tries to do so using the initial UUID?

EDIT: No, it doesn't either:

$ cat /run/systemd/generator/home.mount 
# Automatically generated by systemd-fstab-generator

[Unit]
SourcePath=/etc/fstab
Before=local-fs.target

[Mount]
What=/dev/mapper/main-home
Where=/home
Type=ext4
FsckPassNo=2
Options=rw,relatime,data=ordered

Any ideas or a direction?

Last edited by Duxon (2013-11-06 14:37:43)

Offline

#4 2013-11-06 17:02:29

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 10,893
Website

Re: [SOLVED] Question about /etc/fstab, systemd and lvm.

'Waiting x seconds for device' is probably an initcpio message. Your initial ramdisk gets it's parameters from your bootloader. So what bootloader are you using, and how have you configured it? Is your root filesystem on a slow medium? what initcpio hooks are you using?


Sakura:-
Mobo: MSI MAG X570S TORPEDO MAX // Processor: AMD Ryzen 9 5950X @4.9GHz // GFX: AMD Radeon RX 5700 XT // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 6x 1TB SSD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

#5 2013-11-07 09:17:35

Duxon
Member
Registered: 2010-12-01
Posts: 41

Re: [SOLVED] Question about /etc/fstab, systemd and lvm.

WorMzy wrote:

Your initial ramdisk gets it's parameters from your bootloader.

This was the hint I needed.
A glimpse into my bootloader's configuration revealed a resume=UUID=... entry, which is necessary for hibernation and was in an old and forgotten state.

duxon@rolfgang:~% grep -A 5 -m 1 'LABEL arch' /boot/syslinux/syslinux.cfg
LABEL arch
	MENU LABEL Arch Linux
	LINUX ../vmlinuz-linux
	APPEND cryptdevice=/dev/sda2:main:allow-discards root=/dev/mapper/main-root resume=UUID=6ccf4f96-a05f-4e71-b864-7652e3684c23 ro
	INITRD ../initramfs-linux.img

Thanks a lot!

Last edited by Duxon (2013-11-07 09:18:25)

Offline

Board footer

Powered by FluxBB