You are not logged in.

#1 2013-11-07 16:33:04

From: Bristol, UK
Registered: 2003-08-13
Posts: 726

[Solved]Can't get tpfand working on my Lenovo X201

My laptop has recently been having problems with running too hot - even to the point where the auto shutdown has kicked in. It doesn't matter how hot the CPU gets, the fan doesn't seem to increase much in speed at all.

I've tried following the instructions on both … an_control and … an_Control  but I simply cannot get either tpfand or tpfan-admin running.

Both fail with a variation on this error message:

Fatal error: unable to set fanspeed, enable watchdog or read temperature
             Please make sure you are root and a recent
             thinkpad_acpi module is loaded with fan_control=1

I am running as root and the thinkpad_acpi module is loaded with fan_control=1 as evidenced by:

[root@moses misc]# modprobe -c | grep thinkpad_acpi
options thinkpad_acpi fan_control=1
alias acpi*:IBM0068:* thinkpad_acpi
alias acpi*:LEN0068:* thinkpad_acpi
alias dmi:bvnIBM:bvrI[MU]ET??WW* thinkpad_acpi
alias tpacpi thinkpad_acpi

Why isn't this working?

Edit: Nevermind, it seems I simply hadn't rebooted after a kernel upgrade!

Last edited by phunni (2013-11-07 16:35:25)


Board footer

Powered by FluxBB