You are not logged in.

#1 2013-11-08 15:07:59

saronno
Member
Registered: 2009-10-02
Posts: 116

[SOLVED] Last update broke locale setting ...

Probably something is missing.

locale output:

locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=it_IT.utf8
LC_CTYPE="it_IT.utf8"
LC_NUMERIC="it_IT.utf8"
LC_TIME="it_IT.utf8"
LC_COLLATE="it_IT.utf8"
LC_MONETARY="it_IT.utf8"
LC_MESSAGES="it_IT.utf8"
LC_PAPER="it_IT.utf8"
LC_NAME="it_IT.utf8"
LC_ADDRESS="it_IT.utf8"
LC_TELEPHONE="it_IT.utf8"
LC_MEASUREMENT="it_IT.utf8"
LC_IDENTIFICATION="it_IT.utf8"
LC_ALL=
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_COLLATE to default locale: No such file or directory
C
POSIX
en_US.utf8

localectl output

   System Locale: LANG=en_US.UTF-8
       VC Keymap: it
      X11 Layout: n/a

my /etc/locale.conf

LANG="en_US.UTF-8"

it_IT was a fallback ... trying to fix it I removed it from locale.gen but I didn't solve the problem.
Before I removed it the system fallback to italian language everywhere.

Last edited by saronno (2013-11-09 17:13:39)

Offline

#2 2013-11-08 15:39:17

karol
Archivist
Registered: 2009-05-06
Posts: 25,423

Re: [SOLVED] Last update broke locale setting ...

If you want to use Italian, you have to uncomment it in locale.conf and re-run locale.gen.

When posting configs, code or command output, please use [ code ] tags, not [ quote ] tags https://bbs.archlinux.org/help.php#bbcode

like this

Offline

#3 2013-11-08 16:23:14

saronno
Member
Registered: 2009-10-02
Posts: 116

Re: [SOLVED] Last update broke locale setting ...

karol wrote:

If you want to use Italian, you have to uncomment it in locale.conf and re-run locale.gen.

I don't want to use italian, I want to us and I usually use en_US everywhere ... the only thing is italian
os the keyboard layout.
Everthing was fine but after a total update yesterday my locale get messed up.
I used to have en_US as the primary language and it_IT as a fallback (unused).
Everything was in english but the keyboard layout.
After the update system falled back to italian ... I try to reset everything but nothing.
I remove italian ... but nothing.
I think It don't find some files and then it fall back to what it can ..

Offline

#4 2013-11-08 16:28:00

karol
Archivist
Registered: 2009-05-06
Posts: 25,423

Re: [SOLVED] Last update broke locale setting ...

Reboot.

Offline

#5 2013-11-08 16:40:48

saronno
Member
Registered: 2009-10-02
Posts: 116

Re: [SOLVED] Last update broke locale setting ...

done but nothing han changed

Offline

#6 2013-11-08 16:43:25

karol
Archivist
Registered: 2009-05-06
Posts: 25,423

Re: [SOLVED] Last update broke locale setting ...

Are you setting the LANG variable somewhere? In your ~/.bashrc maybe?
https://wiki.archlinux.org/index.php/Lo … ser_locale

Offline

#7 2013-11-08 16:48:16

mojtabazn
Member
Registered: 2013-10-20
Posts: 22

Re: [SOLVED] Last update broke locale setting ...

first uncomment locale you use then do same as below code

# locale-gen
# echo LANG=en_US.UTF-8 > /etc/locale.conf
# export LANG=en_US.UTF-8
reboot 

Offline

#8 2013-11-08 17:23:36

saronno
Member
Registered: 2009-10-02
Posts: 116

Re: [SOLVED] Last update broke locale setting ...

karol wrote:

Are you setting the LANG variable somewhere? In your ~/.bashrc maybe?
https://wiki.archlinux.org/index.php/Lo … ser_locale

No, there is nothing in .bashrc, just an alias for ls.
However, using env you will find that LANG=it_IT.utf8

The problem is I can't understand how or where this is done.
Besides, LANG=it_IT.utf8 is not just for the user X, but for every user, even root.

Offline

#9 2013-11-08 17:39:15

saronno
Member
Registered: 2009-10-02
Posts: 116

Re: [SOLVED] Last update broke locale setting ...

mojtabazn wrote:

first uncomment locale you use then do same as below code

# locale-gen
# echo LANG=en_US.UTF-8 > /etc/locale.conf
# export LANG=en_US.UTF-8
reboot 

Partial success. The XFCE menu change to english, but part of the system is still in italian.
Somewhere, something keep setting this thing in italian. Besides, these messages ..

locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_COLLATE to default locale: No such file or directory

... seem to indicate that en_US locale is partially broken ..

Eventually, how can I reinstall everything?
Which packages need I to reinstall?

Offline

#10 2013-11-08 17:40:54

karol
Archivist
Registered: 2009-05-06
Posts: 25,423

Re: [SOLVED] Last update broke locale setting ...

I think these messages mean they can't find Italian. They can't because you only uncommented

C
POSIX
en_US.utf8

right?

Offline

#11 2013-11-08 17:52:08

saronno
Member
Registered: 2009-10-02
Posts: 116

Re: [SOLVED] Last update broke locale setting ...

karol wrote:

I think these messages mean they can't find Italian. They can't because you only uncommented

C
POSIX
en_US.utf8

right?

At the moment italian was commented in locale.gen,
so I don't even understant why it use italian for some LC_

There has to be somethign else messing up with these setting ...
maybe some XFCE component ...

Offline

#12 2013-11-08 17:55:42

karol
Archivist
Registered: 2009-05-06
Posts: 25,423

Re: [SOLVED] Last update broke locale setting ...

Try booting into tty and not straight to X. If you get the same output from 'locale', I guess it's not XFCE.

You can add

export LANG=en_US.UTF-8

to your ~/.bashrc and see if it fixes things.

Offline

#13 2013-11-08 18:10:10

saronno
Member
Registered: 2009-10-02
Posts: 116

Re: [SOLVED] Last update broke locale setting ...

karol wrote:

Try booting into tty and not straight to X. If you get the same output from 'locale', I guess it's not XFCE.

You can add

export LANG=en_US.UTF-8

to your ~/.bashrc and see if it fixes things.

If I boot in terminal everything is correct.
So there is something in X or XFCE messing up my
locale setting.

Offline

#14 2013-11-08 18:16:49

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [SOLVED] Last update broke locale setting ...

What does localectl tell you about things?

Offline

#15 2013-11-08 18:20:18

saronno
Member
Registered: 2009-10-02
Posts: 116

Re: [SOLVED] Last update broke locale setting ...

WonderWoofy wrote:

What does localectl tell you about things?

It's in the first message I posted.

Offline

#16 2013-11-08 18:42:35

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [SOLVED] Last update broke locale setting ...

Damn, I'm real good at somehow missing chunks of posts.... or forgetting I read them.

How are you starting X, btw?

Offline

#17 2013-11-08 19:07:16

saronno
Member
Registered: 2009-10-02
Posts: 116

Re: [SOLVED] Last update broke locale setting ...

WonderWoofy wrote:

Damn, I'm real good at somehow missing chunks of posts.... or forgetting I read them.

How are you starting X, btw?

It's the default systemd runlevel

Offline

#18 2013-11-08 19:16:34

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 4,782

Re: [SOLVED] Last update broke locale setting ...

No, it's not, default is just multi-user.target. I'm assuming that means you're using some kind of Display Manager?

Online

#19 2013-11-08 19:49:46

saronno
Member
Registered: 2009-10-02
Posts: 116

Re: [SOLVED] Last update broke locale setting ...

Scimmia wrote:

No, it's not, default is just multi-user.target. I'm assuming that means you're using some kind of Display Manager?

Yes, specifically lightdm.

However my target is graphical.target (I put it in the kernel parameters).

Last edited by saronno (2013-11-08 20:01:54)

Offline

#20 2013-11-08 20:00:13

orschiro
Member
Registered: 2009-06-04
Posts: 2,136
Website

Re: [SOLVED] Last update broke locale setting ...

And what if you start xfce-session in .xinitrc?

Offline

#21 2013-11-09 00:02:42

saronno
Member
Registered: 2009-10-02
Posts: 116

Re: [SOLVED] Last update broke locale setting ...

I logged in as root with lightdm and locale was in order.
So it has to be something in the user configuration ...
and it's not in .bashrc

Any idea?

Offline

#22 2013-11-09 12:39:34

saronno
Member
Registered: 2009-10-02
Posts: 116

Re: [SOLVED] Last update broke locale setting ...

is there a way to find out what process access the environment variables?

Offline

#23 2013-11-09 14:04:33

saronno
Member
Registered: 2009-10-02
Posts: 116

Re: [SOLVED] Last update broke locale setting ...

another little hint ...

if I launch a terminale and set LAND as en_US.utf8 I have again everything in order (export LANG=en_US.utf8)
but if I open another terminal and launch again locate I obtain the same mess.
In a window is ok, in the other is a mess.

Offline

#24 2013-11-09 16:30:40

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 12,390

Re: [SOLVED] Last update broke locale setting ...

saronno wrote:

is there a way to find out what process access the environment variables?

Define access.  If it means what reads them, not that I can think of.
If it means set them, You may try a command to find the files that set an individual variable in your home directory with :
find ~ -exec /usr/bin/grep PATH {} \; 2> /dev/null

That would find all of the references to the variable PATH in all of the files in the directory tree under your home directory.


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Like you, I have no idea what you are doing, but I am pretty sure it is wrong...Jasonwryan
----
How to Ask Questions the Smart Way

Offline

#25 2013-11-09 17:08:19

saronno
Member
Registered: 2009-10-02
Posts: 116

Re: [SOLVED] Last update broke locale setting ...

ewaller wrote:
saronno wrote:

is there a way to find out what process access the environment variables?

Define access.  If it means what reads them, not that I can think of.
If it means set them, You may try a command to find the files that set an individual variable in your home directory with :
find ~ -exec /usr/bin/grep PATH {} \; 2> /dev/null

That would find all of the references to the variable PATH in all of the files in the directory tree under your home directory.

Good, but it didn't print the filename so I used

grep -r "it_IT.utf8" ~

and finally I discovered that Language=it_IT.utf8 was in ~/.dmrc

Now I will try to remove that ...

Offline

Board footer

Powered by FluxBB