You are not logged in.

#1 2013-11-09 09:27:02

khajvah
Member
From: Yerevan, Armenia
Registered: 2012-04-23
Posts: 52

[Solved]Unable to upgrade my system. Pacman conflict error

This is what I get when I try to upgrade my system

error: failed to commit transaction (conflicting files)
libdbusmenu-glib: /usr/include/libdbusmenu-glib-0.4/libdbusmenu-glib/client.h exists in filesystem
libdbusmenu-glib: /usr/include/libdbusmenu-glib-0.4/libdbusmenu-glib/dbusmenu-glib.h exists in filesystem
libdbusmenu-glib: /usr/include/libdbusmenu-glib-0.4/libdbusmenu-glib/enum-types.h exists in filesystem
libdbusmenu-glib: /usr/include/libdbusmenu-glib-0.4/libdbusmenu-glib/menuitem-proxy.h exists in filesystem
libdbusmenu-glib: /usr/include/libdbusmenu-glib-0.4/libdbusmenu-glib/menuitem.h exists in filesystem
libdbusmenu-glib: /usr/include/libdbusmenu-glib-0.4/libdbusmenu-glib/server.h exists in filesystem
libdbusmenu-glib: /usr/include/libdbusmenu-glib-0.4/libdbusmenu-glib/types.h exists in filesystem
libdbusmenu-glib: /usr/lib/girepository-1.0/Dbusmenu-0.4.typelib exists in filesystem
libdbusmenu-glib: /usr/lib/libdbusmenu-glib.so exists in filesystem
libdbusmenu-glib: /usr/lib/libdbusmenu-glib.so.4 exists in filesystem
libdbusmenu-glib: /usr/lib/libdbusmenu-glib.so.4.0.12 exists in filesystem
libdbusmenu-glib: /usr/lib/pkgconfig/dbusmenu-glib-0.4.pc exists in filesystem
libdbusmenu-glib: /usr/share/gir-1.0/Dbusmenu-0.4.gir exists in filesystem
libdbusmenu-glib: /usr/share/vala/vapi/Dbusmenu-0.4.vapi exists in filesystem
Errors occurred, no packages were upgraded.

Can you explain what is my problem?

What is libdbusmenu-glib and why do I have these conflicts ?

Last edited by khajvah (2014-11-03 01:12:57)

Offline

#2 2013-11-09 09:33:12

khajvah
Member
From: Yerevan, Armenia
Registered: 2012-04-23
Posts: 52

Re: [Solved]Unable to upgrade my system. Pacman conflict error

Ok I removed that package and it did the trick but still why did I have that problem?

Offline

#3 2013-11-09 17:08:25

skottish
Forum Fellow
From: Here
Registered: 2006-06-16
Posts: 7,932

Re: [Solved]Unable to upgrade my system. Pacman conflict error

The wiki touches on it here.

Offline

Board footer

Powered by FluxBB