You are not logged in.

#1 2013-11-09 16:45:24

jayflo
Member
Registered: 2013-09-06
Posts: 33

System hangs on hibernate boot using uswsusp, s2disk, systemd

I am using systemd to put my computer into hibernation with the following setup using uswsusp/s2disk (these follow the setup on the wiki):

/etc/suspend.conf

snapshot device = /dev/snapshot
resume device = /dev/sda2
#image size = 350000000
#suspend loglevel = 2
#compute checksum = y
#compress = y
#encrypt = y
#early writeout = y
#splash = y

relevant part of /etc/mkinitcpio.conf

HOOKS="base udev autodetect modconf block uresume filesystems keyboard fsck"

/etc/systemd/system/systemd-hibernate.service

[Unit]
Description=Hibernate
Documentation=man:systemd-suspend.service(8)
DefaultDependencies=no
Requires=sleep.target
After=sleep.target

[Service]
Type=oneshot
ExecStart=/bin/sh -c 's2disk && run-parts --regex .\* -a post /usr/lib/systemd/system-sleep'

This setup worked until recently.  One time, going into hibernation, s2disk said that there wasn't enough swap space available (/dev/sda2 is 2gb, but this issue is probably not related to the current issue).  Now, when I use

sudo systemctl hibernate

the computer goes into hibernation as usual and when booting back up again it successfully decompresses the disk image file, but then hangs on an all black screen with a single underscore character in the top left.

I was not diligent enough to connect the breaking of this with the update of a particular package.  Any ideas?

Offline

#2 2013-11-09 19:31:12

firekage
Member
From: Eastern Europe, Poland
Registered: 2013-06-30
Posts: 526

Re: System hangs on hibernate boot using uswsusp, s2disk, systemd

Have you tried to downgarde linux kernel with dependancies (i had the same problem with suspend to ram on 3.11, i had to downgarde to 3.9.8.1 with acpi headers and linux-firmware packages in order to resume from suspend to ram - i had black screen with unblinking cursor on the left).

Offline

Board footer

Powered by FluxBB