You are not logged in.

#1 2013-11-13 23:39:32

SirCmpwn
Member
Registered: 2013-09-18
Posts: 88

[SOLVEDish] No sound in many games with PulseAudio

Until recently, most games have worked fine. However, I now have no audio in many video games. Affected games include Kerbal Space Program and Natural Selection 2. Metro: Last Light and Fez are unaffected. Here's some interesting output from NS2:

Date: 10/31/2013
Time: 01:28:53 AM:
--------------------------------------------------------------
Build 259
Arch Linux x86_64
Steam initialized
Num displays: 2
OpenGL 4.3.0 NVIDIA 325.15 initialized (NVIDIA Corporation GeForce GTX 670/PCIe/SSE2)
GLSL version 4.30 NVIDIA via Cg compiler
ARB_texture_storage extension present
Error: eventSystem->init (Error initializing output device. )
Error: SoundSystem::Initialize - Failed to initialize FMOD event system
Sound disabled
Loading config://ConsoleBindings.json
Error: Couldn't load 'sound/NS2.fev'
Error: Couldn't load 'sound/NS2.fev/alien/infestation/build' (project didn't exist)
Error: CreateDSP:createDSPByType (This command failed because System::init or System::setDriver was not called. )
Error: CreateDSP:createDSPByType (This command failed because System::init or System::setDriver was not called. )
Error: CreateDSP:addDSP (An invalid object handle was used. )
Error: CreateDSP:addDSP (An invalid object handle was used. )
Error: SetDSPFloatParameter(getParameterInfo) (An invalid object handle was used. )
Error: SetDSPFloatParameter(getParameterInfo) (An invalid object handle was used. )
Error: SetDSPFloatParameter(getParameterInfo) (An invalid object handle was used. )
Error: SetDSPFloatParameter(getParameterInfo) (An invalid object handle was used. )
Error: CreateDSP:createDSPByType (This command failed because System::init or System::setDriver was not called. )
Error: CreateDSP:createDSPByType (This command failed because System::init or System::setDriver was not called. )
Error: CreateDSP:addDSP (An invalid object handle was used. )
Error: CreateDSP:addDSP (An invalid object handle was used. )
Error: SetDSPActive:setBypass() (An invalid object handle was used. )
Error: SetDSPFloatParameter(getParameterInfo) (An invalid object handle was used. )
Error: Couldn't load 'sound/NS2.fev'
Error: Couldn't load 'sound/NS2.fev/alien/infestation/build' (project didn't exist)

I'm using a Xonar DX 5.1 surround sound card, and other applications work fine (moc, browser audio, mpv, etc). Only games seem to be affected. Pulseaudio and the rest of my system is up-to-date.

Last edited by SirCmpwn (2013-11-16 18:38:49)

Offline

#2 2013-11-16 18:29:55

HolyGuacamole
Member
Registered: 2012-03-29
Posts: 6

Re: [SOLVEDish] No sound in many games with PulseAudio

Is there also no sound when you start the games from outside of Steam (~/.local/share/Steam/SteamApps/common/<game_folder>/<game_binary>; your Steam games might be in a different place such as /opt if you chose so when installing them)? If so this is a known problem (Bugreport). Unfortunately there doesn't seem to be a solution right now.

As a workaround you could remove PulseAudio and use ALSA for the time being.

Last edited by HolyGuacamole (2013-11-16 18:32:00)

Offline

#3 2013-11-16 18:38:26

SirCmpwn
Member
Registered: 2013-09-18
Posts: 88

Re: [SOLVEDish] No sound in many games with PulseAudio

Aha, you've got it. It was indeed that bug. Circumventing Steam to launch games is an acceptable workaround.

Offline

#4 2013-12-13 02:18:53

h54
Member
Registered: 2011-11-22
Posts: 87

Re: [SOLVEDish] No sound in many games with PulseAudio

SirCmpwn wrote:

Aha, you've got it. It was indeed that bug. Circumventing Steam to launch games is an acceptable workaround.


I wonder if Steam is the problem?

I have the same issue with Megabyte Punch.  If launched from Steam, no audio.  Business as usual if launched outside of Steam.

Offline

Board footer

Powered by FluxBB