You are not logged in.

#1 2013-11-15 23:40:20

Schala
Member
Registered: 2012-02-14
Posts: 66
Website

KDE black screen after Nvidia driver update

I recently updated to the Nvidia 331.20 drivers, but since reboot Arch appears to start up as normal but attempting to login to KDE begins the load screen (where the hard drive icon and stuff phase in from left to right) but instead it pauses after the hard drive icon, then black screens and puts me back at KDE login. I've tried deleting my ~/.nv folder as well as running nvidia-xconfig to regenerate /etc/X11/xorg.conf but both ideas yielded no change in the behavior.

Shortly before this started happening I had installed nvidia-libgl/opencl 331.20 before the drivers because the pacman mirror had not yet updated at the time. I don't know if this may have impacted my problem.

EDIT: No other display managers or desktops work either.

Last edited by Schala (2013-11-16 03:14:25)


Hardware: Gigabyte X58A-UD5, Intel Core i7 950, Nvidia GTX 560, dual 1 TB Western Digital Caviar Green SATA drives (1st: NTFS, 2nd: ext4,ext4), 8 GB DDR3 RAM
External Hardware: 2 TB Western Digital Caviar Black drive (NTFS), Memory Master 32G USB stick (FAT32)
Choice software: Arch Linux 64-bit with KDE desktop / Windows 7 Professional 64-bit

Offline

#2 2013-11-17 03:07:12

llawwehttam
Member
From: United Kingdom
Registered: 2010-01-19
Posts: 181
Website

Re: KDE black screen after Nvidia driver update

I'm also having a lot of issues with 331.20. I run herbstluftwm and use xdm as my log in manager.
I run a dual display with the right hand monitor vertical.

With the new driver the vertical monitor gets the correct resolution: 1080x1920 but is not rotated so everything is sideways and horribly stretched.

I added:

xrandr -o normal

to my ~/.xinitrc and that fixes some of my problems. I have had a few crashes.

I've seen a few other threads on bugs with this driver so I'm presuming it's a known issue.


NERD in Training :: Please be Gentle tongue

Offline

#3 2013-11-17 06:02:29

Schala
Member
Registered: 2012-02-14
Posts: 66
Website

Re: KDE black screen after Nvidia driver update

Yeah. Unfortunately I can't ctrl-alt-F1 out of LXDM so I'm stuck on Winblows until I get my USB stick back from my brother.


Hardware: Gigabyte X58A-UD5, Intel Core i7 950, Nvidia GTX 560, dual 1 TB Western Digital Caviar Green SATA drives (1st: NTFS, 2nd: ext4,ext4), 8 GB DDR3 RAM
External Hardware: 2 TB Western Digital Caviar Black drive (NTFS), Memory Master 32G USB stick (FAT32)
Choice software: Arch Linux 64-bit with KDE desktop / Windows 7 Professional 64-bit

Offline

#4 2013-11-17 17:28:04

cju
Member
Registered: 2013-06-23
Posts: 194

Re: KDE black screen after Nvidia driver update

Got these obviously nvidia-related issues as well; for my part, KDM fails at boot, but I can manually restart it respectively use startx to get X/KDE working… This is pretty annoying since afaik the only thing we can do is to wait for a driver update. mad

Offline

#5 2013-11-17 20:51:17

Schala
Member
Registered: 2012-02-14
Posts: 66
Website

Re: KDE black screen after Nvidia driver update

Does KDM display the login screen, you attempt to login, then it blacks out and sends you back to the login screen?


Hardware: Gigabyte X58A-UD5, Intel Core i7 950, Nvidia GTX 560, dual 1 TB Western Digital Caviar Green SATA drives (1st: NTFS, 2nd: ext4,ext4), 8 GB DDR3 RAM
External Hardware: 2 TB Western Digital Caviar Black drive (NTFS), Memory Master 32G USB stick (FAT32)
Choice software: Arch Linux 64-bit with KDE desktop / Windows 7 Professional 64-bit

Offline

#6 2013-11-18 18:43:12

cju
Member
Registered: 2013-06-23
Posts: 194

Re: KDE black screen after Nvidia driver update

No; actually, I'm directly thrown at the default TTY-login. (Not sure if that matters, but I configured KDM to autologin…)

When checking the kdm status, in the output there's something like:

kdm[2167]: X server died during startup 
kdm[2167]: X server for display :0 cannot be started, session disabled

Offline

#7 2013-11-18 19:08:45

Mamahu
Member
Registered: 2013-11-18
Posts: 1

Re: KDE black screen after Nvidia driver update

I have kind of the same problem here...

I installed the latest 331.20 proprietary Nvidia drivers and since then, kdm refuses to launch...well kinda :

I get to a black screen with a flashing _ (no prompt, just an underscore) on my tty7.

I then go to tty1 and type systemctl status kdm.service => active (WTF ??)

But it reports the same error as cju's : kdm[307]: X server died during startup & kdm[307]: X server for display :0 cannot be started, session disabled

But when I type startx or sudo systemctl restart kdm.service in tty1, kdm starts flawlessly, as if nothing ever happened, and the nvidia driver is correctly used (3D acceleration, VDPAU enabled in vlc, nvidia-settings works, ...)!

I'm starting to lose my marbles here...

PS : no such problems when using nouveau or vesa...

Last edited by Mamahu (2013-11-18 19:11:07)

Offline

#8 2013-11-18 19:48:25

Schala
Member
Registered: 2012-02-14
Posts: 66
Website

Re: KDE black screen after Nvidia driver update

Well for me, no graphical environment works. Period. I even did a fresh system format and install and tried the xorg-twm. No luck.


Hardware: Gigabyte X58A-UD5, Intel Core i7 950, Nvidia GTX 560, dual 1 TB Western Digital Caviar Green SATA drives (1st: NTFS, 2nd: ext4,ext4), 8 GB DDR3 RAM
External Hardware: 2 TB Western Digital Caviar Black drive (NTFS), Memory Master 32G USB stick (FAT32)
Choice software: Arch Linux 64-bit with KDE desktop / Windows 7 Professional 64-bit

Offline

#9 2013-11-18 21:50:05

tmoorman
Member
Registered: 2012-08-07
Posts: 16

Re: KDE black screen after Nvidia driver update

I installed the upgrade from 325 to 331 (nvidia, nvidia-libgl and nvidia-utils).  On reboot I get stuck at tty1.  When I logon and manually startx, I get the x-windows demo.  When I downgrade to 325 my system starts up right away.
This is odd because I have 331 running fine on my other Arch box.  The main difference between them is the video card: GeForce GTS 450 (331 no) and GeForce 210 (331 yes).  The GeForce 210 system has a custom /etc/X11/10-monitor.conf to force load an edid file for a wonky monitor.  So it has a Screen section to load the edid file and a Device section where I load the nvidia driver.  The GeForce GTS 450 system does not have any custom X11 config files.

Offline

#10 2013-11-19 12:16:55

lenk
Member
Registered: 2009-01-27
Posts: 27

Re: KDE black screen after Nvidia driver update

Same problem here. One box works and other doesn't. Both no custom X11 configs. Notable difference is 4 screen setup and a single screen. I can't be bothered to investigate this. I just masked 331 for now, till someone finds a solution. Looks like its not a widespread problem.

Offline

#11 2013-11-19 12:23:15

lenk
Member
Registered: 2009-01-27
Posts: 27

Re: KDE black screen after Nvidia driver update

Notice there is no bugreport on this. Someone care to do it. smile

Offline

#12 2013-11-19 19:20:37

kokoko3k
Member
Registered: 2008-11-14
Posts: 2,018

Re: KDE black screen after Nvidia driver update

From time to time, it happened to me even before this driver upgrade (i didn't even upgraded yet).
As i strongly use hibernation, i never cared about, as long as just restarting kdm fixed the issue.

Offline

#13 2013-11-21 16:17:21

peplin
Member
Registered: 2012-10-16
Posts: 3

Re: KDE black screen after Nvidia driver update

llawwehttam wrote:

With the new driver the vertical monitor gets the correct resolution: 1080x1920 but is not rotated so everything is sideways and horribly stretched.

I added:

xrandr -o normal

to my ~/.xinitrc and that fixes some of my problems. I have had a few crashes.

Thanks, I was having the same problem with 331 and this resolved it. Quickly losing confidence in the binary drivers, though, since they broke Xinerama a few months ago.

Offline

Board footer

Powered by FluxBB