You are not logged in.

#1 2013-11-16 00:51:47

idoit
Member
Registered: 2013-06-15
Posts: 11

[Solved] No microphone after hibernating or suspending Arch Linux

My problem is: Microphone (in the integrated Webcam) and speakers/headphones work on my laptop but after a hibernate or suspending my laptop, microphone stops working. The specs are as below:

Linux 3.11.6-1-ARCH #1 SMP PREEMPT Fri Oct 18 23:22:36 CEST 2013 x86_64 GNU/Linux
Laptop: Toshiba T230-01H

I have installed ALSA and as I said audio devices work awesome and so does the video part of webcam, but after suspend and hibernate I have to reboot if I want to use microphone.

Appreciate if you can help me. I'll provide more info if needed. Thanks.

Last edited by idoit (2013-12-03 03:22:58)

Offline

#2 2013-11-16 15:24:55

nomorewindows
Member
Registered: 2010-04-03
Posts: 3,040

Re: [Solved] No microphone after hibernating or suspending Arch Linux

Does it mute it?


I may have to CONSOLE you about your usage of ridiculously easy graphical interfaces...
Look ma, no mouse.

Offline

#3 2013-11-16 17:51:34

idoit
Member
Registered: 2013-06-15
Posts: 11

Re: [Solved] No microphone after hibernating or suspending Arch Linux

Hmmm, when I go to "alsamixer", everything seems normal. I can mute 'Mic' in alsamixer, but it doesn't make a difference. The way that I test if microphone is working is using Skype. In "Settings > Sound Devices" before hibernate/suspend, it shows my microphone device (Chicony), but after that, it doesn't show. And obviously microphone doesn't work. As mentioned above though, the video of webcam works.

Offline

#4 2013-12-03 02:31:50

idoit
Member
Registered: 2013-06-15
Posts: 11

Re: [Solved] No microphone after hibernating or suspending Arch Linux

I resolved this issue by a tip in this page: http://nwlinux.com/restarting-alsa-soun … ot-ubuntu/

What helped me was to do the following commands:
lsof | grep pcm

This way I could see the processes that were using sound. In my case it was zoiper that was somehow blocking my microphone. I killed it with "killall -9 zoiper" and bingo, my microphone works like a charm without having to restart every time I hibernated or suspended my laptop, which was really annoying.

Hope this helps others.

Last edited by idoit (2013-12-03 03:22:11)

Offline

Board footer

Powered by FluxBB