You are not logged in.

#1 2013-11-18 17:53:33

DrKillPatient
Member
Registered: 2011-07-28
Posts: 85

Smooth scrolling with macbook touchpad

I've noted recently that, when using both the synaptics and mtrack touchpad drivers, two-finger scrolling moves in small increments, as with a mouse wheel, rather than in one continuous motion like in Mac OS X (where page movement follows finger movement more closely). Is it possible to use the latter behavior rather than emulate a physical mouse wheel?

Offline

#2 2013-11-18 18:26:32

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: Smooth scrolling with macbook touchpad

I don't experience this whatsoever... my two finger scroll works just fine.  Does this also happen when you use the edge scroll feature (or the funky circle scroll)?  Also, it would probably be good to indicate what version MacBook you have, as well as whether you have changed anything in your synaptics config (/etc/X11/xorg.conf.d/50-synaptics.conf).

Offline

#3 2013-11-18 22:18:49

DrKillPatient
Member
Registered: 2011-07-28
Posts: 85

Re: Smooth scrolling with macbook touchpad

I have a Macbook 11,1, the new 13" Retina. I'm currently running the mtrack driver, but synaptics experiences the same issue. My 10-mtrack.conf is as follows:

Section "InputClass"
    MatchIsTouchpad "on"
    Identifier "Touchpads"
    Driver "mtrack"
    Option "Sensitivity" "0.6"
    Option "ButtonIntegrated" "true"
    Option "ButtonMoveEmulate" "true"
    Option "Sensitivity" "0.7"
    Option "ClickFinger1" "1"
    Option "ClickFinger2" "2"
    Option "ClickFinger3" "3"
    Option "TapButton1" "1"
    Option "TapButton2" "2"
    Option "TapButton3" "3"
    #Option "TapButton1" "0"
    #Option "TapButton2" "0"
    #Option "TapButton3" "0"
    Option "ThumbSize" "35"
    Option "PalmSize"  "55"
    Option "DisableOnPalm" "true"
    Option "IgnorePalm" "true"
    Option "ClickTime" "25"
    Option "ScrollDistance" "60"
    Option "ScrollUpButton" "5"O
    Option "ScrollDownButton" "4"
    Option "ScrollLeftButton" "7"
    Option "ScrollRightButton" "6"
EndSection

I'll try the edge scroll and see what happens.

EDIT: A fresh synaptics config sort of gives me smooth scrolling. Aha, I can still see the increments if I scroll slowly, but they're much less noticeable. I could work with that. However, synaptics does not (as far as I know) have the capability to ignore my thumb resting on the bottom of the trackpad, causing unwanted clicks. Can I get that functionality in synaptics?

Last edited by DrKillPatient (2013-11-18 22:24:37)

Offline

#4 2013-11-18 23:36:24

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: Smooth scrolling with macbook touchpad

It is the clickpad functionality.  In the default synaptics config, there is an example of how to set that up towards the bottom.

Offline

#5 2013-11-21 01:44:18

hrod
Member
Registered: 2013-10-24
Posts: 57

Re: Smooth scrolling with macbook touchpad

what i don't understand is:

often if i scroll by flicking my two fingers (so lifting them off the touchpad) it will scroll for a bit then the rightclick menu will come up. i find it weird that it decides to bring the menu up after it has decided that my movement was a scroll...

Offline

#6 2013-11-21 01:56:53

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: Smooth scrolling with macbook touchpad

@hrod, that is very odd, but I don't use any kind of tap-to-click so I don't experience this kind of thing.  Tap-to-click drives me absolutely mad because my palms sometimes hit the touchpad, which in turn causes clicks sometimes.  Does it do it all the time?  Maybe you should use xev to see if there is a certain motion that causes this and see if adjustments can be made from there...

Offline

#7 2013-11-21 03:48:57

hrod
Member
Registered: 2013-10-24
Posts: 57

Re: Smooth scrolling with macbook touchpad

@drkillpatient possibly you could lower the increment size and alter scrolling sensitivity to make the  movement smoother?

@wonderwoofy if i do the motion slowly then the right click menu doesn't come up (or if i just don't lift my fingers from the pad - this is what i end up doing), i'll look into xev thanks. its actually quite annoying because in chrome the first option on the menu is back and it clicks that also..

i kinda want to do the opposite: make the physical click do nothing, sometimes i'm in the library or study hall with earphones on and realise i have been making a heap of noise clicking

Last edited by hrod (2013-11-21 03:50:56)

Offline

Board footer

Powered by FluxBB