You are not logged in.

#1 2013-11-19 18:10:24

Registered: 2013-11-19
Posts: 3

[SOLVED] Black screen after grub in Virtualbox guest install

Hi everyone,

I thought I'd give Arch a try and wanted to install it as a guest VM in Virtualbox. I downloaded the 2013.11.01 release ISO (checked md5 sigs) and went to install in my Virtualbox environment. I'm currently running Gentoo as the host (64-bit) and have 64-bit Windows 7, CentOS, and Ubuntu guests that all run without issue.

Upon booting from the ISO, I get a grub prompt and select the x86_64 option. At this point the Virtualbox screen goes black. Zero output and zero disk activity indicated by Virtualbox. VBox.log doesn't indicate any errors that would cause this as far as I can tell. The only error in fact the following (which appears in other guest logs as well):
"00:00:00.550 ERROR [COM]: aRC=VBOX_E_IPRT_ERROR (0x80bb0005) aIID={09eed313-cd56-4d06-bd56-fac0f716b5dd} aComponent={Display} aText={Could not take a screenshot (VERR_NOT_SUPPORTED)}, preserve=false"

The Hardware Detection Tool runs fine and detects all the Vbox devices w/o issue as well.

If you'd like the VBox.log I can certainly post it, but I didn't see anything. I'm hoping this is something people have run across before.

Also choosing the i686 option doesn't work as it's a 64-bit system just in case someone asks. smile

Thanks all!

Ok so after some more testing it occurred to me that maybe I should just try a prior release. Gave the 2013.10.01 release a go, and everything boots up fine. Now sure what it was about my VBox set up that Arch didn't like, but it's working now.

Last edited by sgt_b2002 (2013-11-19 19:34:41)


#2 2014-01-04 21:55:45

Registered: 2014-01-04
Posts: 2

Re: [SOLVED] Black screen after grub in Virtualbox guest install

As for me, I update my VirtualBox to 4.3.6 and it helps me.


Board footer

Powered by FluxBB