You are not logged in.

#1 2013-11-23 10:56:13

xexio
Member
Registered: 2011-03-29
Posts: 14

FreeSpace 2 problem with the instalation

Hi. I bought the FreeSpace 2 at GOG.

I installed the fs2_open package.
But, when I tryed to install the fs2_open-data I recived an error. Where can I place the setup_freespace2_2.0.0.8.exe? In what directory?

Thats the error:

==> ERROR: You must have either setup_freespace2_2.0.0.8.exe or the extracted files from the retail CD present (.exe in main dir or CD files in src).
==> ERROR: Either download the game from your GOG shelf or extract the files from the retail CD and try again.
==> ERROR: A failure occurred in prepare().
    Aborting...
==> ERROR: Makepkg was unable to build fs2_open-data.

Offline

#2 2013-11-23 11:10:42

skualito
Member
Registered: 2008-11-19
Posts: 184

Re: FreeSpace 2 problem with the instalation

I would say in the directory from which you invoke makepkg. If you download the tarball straight from the aur page, then place your "file.exe" in the extracted directory.

Offline

#3 2013-11-23 14:46:18

xexio
Member
Registered: 2011-03-29
Posts: 14

Re: FreeSpace 2 problem with the instalation

skualito wrote:

I would say in the directory from which you invoke makepkg. If you download the tarball straight from the aur page, then place your "file.exe" in the extracted directory.

Solved!

But, when I start the game it crash and show this message.

AL lib: (EE) UpdateDeviceParams: Failed to set 44100hz, got 48000hz instead
ATTENTION: default value of option force_s3tc_enable overridden by environment.
/usr/bin/fs2_open: line 15: 16800 Segmentation fault      (core dumped) /opt/fs2_open/fs2_open_3.7.0 "$@" "$FS2OPTS"

Offline

#4 2013-12-12 21:52:20

el mariachi
Member
Registered: 2007-11-30
Posts: 588

Re: FreeSpace 2 problem with the instalation

The same thing happens to me. Have you found a solution?

Offline

#5 2014-07-28 08:06:55

Theredbaron
Member
Registered: 2011-07-11
Posts: 5

Re: FreeSpace 2 problem with the instalation

If any of you are still having trouble, or if like me someone happens upon this via searching for "freespace2  Segmentation fault   "$@" "$FS2OPTS"", I found out how to get it to work.

It seems newer intel drivers say they support OpenGL Pixel Buffer, without actually supporting them (or at least something to that effect). Thus you simply turn it off either via adding  "-disable_pbo" after the fs2_open command however you launch it, adding "-disable_pbo" to your your option config file, or with wxlauncher checking "Disable OpenGL Pixel Buffer Object", and the game will run fine.

Sad thing is I got it working, but my netbook can't handle it.

Last edited by Theredbaron (2014-07-28 08:18:58)

Offline

Board footer

Powered by FluxBB