You are not logged in.

#1 2013-11-27 19:20:12

exos
Member
From: Buenos Aires, Argentina
Registered: 2009-11-09
Posts: 14
Website

Error with LXC: network is not created for 'lxc.network.link' = 'br0'

Hi!

I'm trying to use LXC , following the wiki, I set the bridges with netctl and I created the br0 interface . The trouble is that when I try to lift the container, I have this error:

[root@hexodica ~]# lxc-start -n test01
lxc-start: network is not created for 'lxc.network.link' = 'br0' option
lxc-start: failed to read configuration file

My settings in /etc/netctl/bridge:

Description="Bridge for LXC"
Interface=br0
Connection=bridge
BindsToInterfaces=(eth0)
IP=static
Address=192.168.1.6/24
Gateway=192.168.1.1
DNS=('8.8.8.8' '8.8.4.4')

And the container config:

rk.type = veth
lxc.network.link=br0
lxc.network.flags = up
lxc.rootfs = /var/lib/lxc/test01/rootfs
lxc.tty = 4
lxc.pts = 1024
lxc.utsname = test01
lxc.mount.entry = sysfs sys sysfs defaults  0 0
lxc.network.ipv4 = 192.168.1.50
lxc.cgroup.memory.limit_in_bytes = 512M
lxc.cgroup.cpuset.cpus = 2
lxc.network.type = veth
lxc.network.hwaddr = 4a:49:43:49:79:bd 

lxc.cgroup.devices.deny = a
lxc.cgroup.devices.allow = c 1:3 rwm
lxc.cgroup.devices.allow = c 1:5 rwm
lxc.cgroup.devices.allow = c 5:1 rwm
lxc.cgroup.devices.allow = c 5:0 rwm
lxc.cgroup.devices.allow = c 4:0 rwm
lxc.cgroup.devices.allow = c 4:1 rwm
lxc.cgroup.devices.allow = c 1:9 rwm
lxc.cgroup.devices.allow = c 1:8 rwm
lxc.cgroup.devices.allow = c 136:* rwm
lxc.cgroup.devices.allow = c 5:2 rwm
lxc.cgroup.devices.allow = c 254:0 rwm

My ifconfig results:

br0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.6  netmask 255.255.255.0  broadcast 192.168.1.255
        inet6 fe80::52e5:49ff:fe3c:abe1  prefixlen 64  scopeid 0x20<link>
        ether 50:e5:49:3c:ab:e1  txqueuelen 0  (Ethernet)
        RX packets 1277912  bytes 826570697 (788.2 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 1741163  bytes 964760146 (920.0 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

eth0: flags=4419<UP,BROADCAST,RUNNING,PROMISC,MULTICAST>  mtu 1500
        inet6 fe80::52e5:49ff:fe3c:abe1  prefixlen 64  scopeid 0x20<link>
        ether 50:e5:49:3c:ab:e1  txqueuelen 1000  (Ethernet)
        RX packets 1278605  bytes 844517308 (805.3 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 1741171  bytes 964787111 (920.0 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 0  (Local Loopback)
        RX packets 41238  bytes 5440654 (5.1 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 41238  bytes 5440654 (5.1 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lvpn: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.9.205  netmask 255.255.255.0  broadcast 192.168.9.255
        inet6 fe80::5817:5bff:fe61:6232  prefixlen 64  scopeid 0x20<link>
        ether 5a:17:5b:61:62:32  txqueuelen 500  (Ethernet)
        RX packets 74010  bytes 10360005 (9.8 MiB)
        RX errors 0  dropped 536  overruns 0  frame 0
        TX packets 77060  bytes 8882703 (8.4 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

Some idea?


exos ~ Exodica's logs - exos@esfriki - PGP 0x8798902F - OTR - yvan eht nioj (¿?)

Offline

#2 2014-01-08 23:17:23

dim32
Member
From: Ukraine, Kyiv
Registered: 2014-01-08
Posts: 1

Re: Error with LXC: network is not created for 'lxc.network.link' = 'br0'

Address=192.168.1.6
or
lxc.network.ipv4 = 192.168.1.50
?

Offline

Board footer

Powered by FluxBB