You are not logged in.

#1 2013-11-28 15:41:12

jarfbarker
Member
Registered: 2013-06-19
Posts: 12

[SOLVED] Wrong "Desktop" icon in nautilus 3.10 sidebar

Recently I noticed that nautilus 3.10 is displaying the default "Desktop" icon in the Places sidebar.  This is instead of the scalable, monochrome icons used for all of the other places (i.e. Downloads, Music, etc).  A picture should clarify:

Screenshot%20from%202013-11-28%2010%3A15%3A35.png

I don't recall exactly what triggered this annoyance, but it was sometime after I removed Desktop from the sidebar by editing ~/.config/user-dirs.dirs as follows:

XDG_DESKTOP_DIR="$HOME/"
XDG_DOWNLOAD_DIR="$HOME/Downloads"
XDG_TEMPLATES_DIR="$HOME/Templates"
XDG_PUBLICSHARE_DIR="$HOME/Public"
XDG_DOCUMENTS_DIR="$HOME/Documents"
XDG_MUSIC_DIR="$HOME/Music"
XDG_PICTURES_DIR="$HOME/Pictures"
XDG_VIDEOS_DIR="$HOME/Videos"

This issue is present for all users, including a fresh one created as a test, and changing the icon theme using gnome tweak tool will change the Desktop icon in the sidebar.  Trying to remove Desktop by editing user-dirs.dirs at this point is ineffective, although it did work originally.  I can delete the actual folder after editing ~/.config/user-dirs.dirs, but Desktop remains in the sidebar with the wrong icon. Selecting it gives no error.

I've tried completely uninstalling and reinstalling nautilus and all of the xdg related packages.  I also tried reinstalling both gnome and gnome-extra groups. Tried toggling nautilus management of desktop in gnome tweak tool. No change.

My goal is ideally to remove the Desktop folder entirely, as it seems pretty useless in Gnome.  I would settle for just having the matching icon back.

Any thoughts?

Last edited by jarfbarker (2013-11-29 05:27:04)

Offline

#2 2013-11-28 16:49:22

hTaver
Member
From: São Paulo, Brasil
Registered: 2012-07-19
Posts: 6

Re: [SOLVED] Wrong "Desktop" icon in nautilus 3.10 sidebar

Hello there!

I too had this problem, and man, was my OCD kicking in! At first, I was playing around with Chromium, so I tought that it was the culprit (maybe it messed with some config file), but after looking around the pacman.log (at /var/log) I noticed something that maybe was to blame: a recent update of gtk3. So I downgraded and solved it. This, of course, is not the best approach, but as far as my skills for patching (or should I say lack of it?) goes, this is the best I can do for now.

If you want to do the same, add this to your pacman.conf (at /etc/pacman.conf) above [extra] and comment out (add # in front) the original one:

[extra]
SigLevel = PackageRequired
Server=http://seblu.net/a/arm/2013/11/26/$repo/os/$arch

Refresh your repositories (pacman -Syy) and install gtk3 again. This will downgrade it and solve the problem.

Afterwards, you can delete what you just added and uncomment the original [extra] again. Add gtk3 to IgnorePkg (don't forget to uncomment it) and wait for a proper solution.

Oh, by the way, this will fix the weird appearance of GNOME Control Center too. Did you notice it is very wide?

If anyone know anything else, I too would like to hear

Offline

#3 2013-11-28 17:49:19

Radioactiveman
Member
From: Germany
Registered: 2010-05-13
Posts: 375

Re: [SOLVED] Wrong "Desktop" icon in nautilus 3.10 sidebar

With GTK+ until 3.10.4 the desktop entry was not shown at all, this was fixed with 3.10.5.

See this bug report for more information.

If you want to disable this setting, insert this line into the themes settings.ini.

gtk-shell-shows-desktop = 0

EDIT: I have filed a bug report here.

Last edited by Radioactiveman (2013-11-28 18:02:24)

Offline

#4 2013-11-29 05:26:35

jarfbarker
Member
Registered: 2013-06-19
Posts: 12

Re: [SOLVED] Wrong "Desktop" icon in nautilus 3.10 sidebar

Downgrading solved my issue.  Thanks for the help and for filing the appropriate bug report.

Offline

#5 2013-11-29 22:04:39

mjb
Member
From: Germany
Registered: 2012-01-28
Posts: 65

Re: [SOLVED] Wrong "Desktop" icon in nautilus 3.10 sidebar

Radioactiveman wrote:

With GTK+ until 3.10.4 the desktop entry was not shown at all, this was fixed with 3.10.5.

See this bug report for more information.

If you want to disable this setting, insert this line into the themes settings.ini.

gtk-shell-shows-desktop = 0

EDIT: I have filed a bug report here.

Thanks for filing the bug report. What I don't understand is your comment "[...] if you are not using Gnome Shell". I do use Gnome Shell and have the same problem.

Should we also file a bug report on the wide control center (as mentioned by hTaver?)

Offline

#6 2013-11-29 23:14:55

Radioactiveman
Member
From: Germany
Registered: 2010-05-13
Posts: 375

Re: [SOLVED] Wrong "Desktop" icon in nautilus 3.10 sidebar

Gnome Shell does not use a desktop so it should not be displayed in the sidebar.

Currently this setting is enabled by default but disabled for Gnome Shell. More information here.
A new stable version of gnome-settings-daemon with this patch was not released yet.
And therefore the desktop entry it is still displayed.

Offline

#7 2013-11-30 07:43:23

mjb
Member
From: Germany
Registered: 2012-01-28
Posts: 65

Re: [SOLVED] Wrong "Desktop" icon in nautilus 3.10 sidebar

Radioactiveman wrote:

Gnome Shell does not use a desktop so it should not be displayed in the sidebar.

And yet it does

Nautilus Screen

Freshly installed Gnome. No relevant changes made.

Currently this setting is enabled by default but disabled for Gnome Shell. More information here.
A new stable version of gnome-settings-daemon with this patch was not released yet.
And therefore the desktop entry it is still displayed.

Thanks!

Offline

#8 2013-12-06 08:21:19

mjb
Member
From: Germany
Registered: 2012-01-28
Posts: 65

Re: [SOLVED] Wrong "Desktop" icon in nautilus 3.10 sidebar

Bug resolved by recent gtk update.

Offline

#9 2013-12-10 02:38:25

jarfbarker
Member
Registered: 2013-06-19
Posts: 12

Re: [SOLVED] Wrong "Desktop" icon in nautilus 3.10 sidebar

Updated to gtk3 3.10.6 and the icon is fixed, but Desktop still shows in the nautilus Places list even when nautilus is not handling the desktop.  Perhaps I am just not understanding the intended behavior (and perhaps this belongs in a new thread?), but I thought that Desktop should not be shown in Places so long as nautilus is not handling the desktop. 

FYI if you want to get rid of the Desktop folder, add gtk-shell-shows-desktop=0 (as suggested by mjb)  to ~/.config/gtk-3.0/settings.ini.  Then edit ~/.config/user-dirs.dirs as in the first post.  Then you can delete the Desktop folder, and it will also no longer appear in the nautilus sidebar.

Offline

Board footer

Powered by FluxBB