You are not logged in.

#1 2013-11-29 07:56:02

Vilius
Member
From: Dushanbe, Tajikistan
Registered: 2012-01-05
Posts: 26
Website

[SOLVED] Unable to print with Canon MF4410 laser printer

So, I bought a printer and tested it on a Windows machine - works just fine. Next I find and install the drivers (packages cndrvcups-lb and just in case also gutenprint) - there were some problems with dependencies, but I managed it. Then in the CUPS web interface I add the printer Canon MF4400 Series (Canon MF4400 Series), when asked to select the driver I use UFRII LT ver.2.7. Here is my log so far:

Nov 29 12:45:39 osmium dbus-daemon[462]: dbus[462]: [system] Activating via systemd: service name='org.freedesktop.Avahi' unit='db...ervice'
Nov 29 12:45:39 osmium dbus[462]: [system] Activating via systemd: service name='org.freedesktop.Avahi' unit='dbus-org.freedeskto...service'
Nov 29 12:45:39 osmium dbus[462]: [system] Activation via systemd failed for unit 'dbus-org.freedesktop.Avahi.service': Unit dbus...rectory.
Nov 29 12:45:39 osmium dbus-daemon[462]: dbus[462]: [system] Activation via systemd failed for unit 'dbus-org.freedesktop.Avahi.se...ectory.
Nov 29 12:45:39 osmium kernel: usblp1: removed
Nov 29 12:45:39 osmium kernel: usb 5-1: ep 0x1 - rounding interval to 128 microframes, ep desc says 255 microframes
Nov 29 12:45:39 osmium kernel: usb 5-1: ep 0x82 - rounding interval to 128 microframes, ep desc says 255 microframes
Nov 29 12:45:39 osmium kernel: usblp 5-1:1.1: usblp1: USB Bidirectional printer dev 2 if 1 alt 0 proto 2 vid 0x04A9 pid 0x2737
Nov 29 12:45:39 osmium hpfax[1865]: [1865]: warning: python-dbus not installed.
Nov 29 12:46:32 osmium colord[508]: Profile added: Canon_MF4400_Series-Gray..
Nov 29 12:46:32 osmium colord[508]: (colord:508): Cd-WARNING **: failed to get session [pid 461]: Unknown error -2
Nov 29 12:46:32 osmium colord[508]: Device added: cups-Canon_MF4400_Series
Nov 29 12:46:38 osmium colord[508]: device removed: cups-Canon_MF4400_Series
Nov 29 12:46:38 osmium colord[508]: (colord:508): Cd-WARNING **: failed to get session [pid 461]: Unknown error -2
Nov 29 12:46:38 osmium colord[508]: Device added: cups-Canon_MF4400_Series
Nov 29 12:46:56 osmium dbus-daemon[462]: dbus[462]: [system] Activating via systemd: service name='org.freedesktop.Avahi' unit='db...ervice'
Nov 29 12:46:56 osmium dbus[462]: [system] Activating via systemd: service name='org.freedesktop.Avahi' unit='dbus-org.freedeskto...service'
Nov 29 12:46:56 osmium dbus[462]: [system] Activation via systemd failed for unit 'dbus-org.freedesktop.Avahi.service': Unit dbus...rectory.
Nov 29 12:46:56 osmium dbus-daemon[462]: dbus[462]: [system] Activation via systemd failed for unit 'dbus-org.freedesktop.Avahi.se...ectory.
Nov 29 12:46:56 osmium kernel: usblp1: removed
Nov 29 12:46:56 osmium kernel: usb 5-1: ep 0x1 - rounding interval to 128 microframes, ep desc says 255 microframes
Nov 29 12:46:56 osmium kernel: usb 5-1: ep 0x82 - rounding interval to 128 microframes, ep desc says 255 microframes
Nov 29 12:46:56 osmium kernel: usblp 5-1:1.1: usblp1: USB Bidirectional printer dev 2 if 1 alt 0 proto 2 vid 0x04A9 pid 0x2737
Nov 29 12:46:56 osmium hpfax[1914]: [1914]: warning: python-dbus not installed.

Then I try to print a test page. Everything goes smoothly, CUPS says the job is "completed". Here is the log:

Nov 29 12:48:28 osmium systemd[1]: Started CUPS Printing Service.
Nov 29 12:48:28 osmium kernel: usblp1: removed
Nov 29 12:48:37 osmium kernel: usb 5-1: ep 0x1 - rounding interval to 128 microframes, ep desc says 255 microframes
Nov 29 12:48:37 osmium kernel: usb 5-1: ep 0x82 - rounding interval to 128 microframes, ep desc says 255 microframes
Nov 29 12:48:37 osmium kernel: usblp 5-1:1.1: usblp1: USB Bidirectional printer dev 2 if 1 alt 0 proto 2 vid 0x04A9 pid 0x2737
Nov 29 12:48:59 osmium systemd[1]: Started CUPS Printing Service.

The only problem is that nothing ever comes out of the printer. Any ideas?
My other printer (HP DeskJet F4180) works fine.

And here is my /var/log/cups/error_log:

E [29/Nov/2013:18:15:43 +0500] [cups-deviced] PID 6214 (dnssd) stopped with status 1!
E [29/Nov/2013:18:15:48 +0500] [cups-deviced] PID 6239 (dnssd) stopped with status 1!
W [29/Nov/2013:18:16:23 +0500] [CGI] Missing Product in /usr/share/cups/model/CNCUPSIRADV4051ZK.ppd!
W [29/Nov/2013:18:16:23 +0500] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/KONICA_MINOLTA/KOC451JX.ppd.gz!
E [29/Nov/2013:18:16:23 +0500] [cups-driverd] Bad driver information file "/usr/share/cups/model/foomatic-db-ppds/Kyocera/ReadMe.htm"!
W [29/Nov/2013:18:16:23 +0500] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/Brother/BR5070DN_GPL.ppd.gz!
W [29/Nov/2013:18:16:23 +0500] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/Epson/eplp980c.ppd.gz!
W [29/Nov/2013:18:16:23 +0500] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/Epson/eplp830c.ppd.gz!
W [29/Nov/2013:18:16:23 +0500] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/Epson/eplp880c.ppd.gz!
W [29/Nov/2013:18:16:23 +0500] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/Epson/eplp9100.ppd.gz!
W [29/Nov/2013:18:16:23 +0500] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/Epson/eplp920c.ppd.gz!
W [29/Nov/2013:18:16:23 +0500] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/Epson/eplp850c.ppd.gz!
W [29/Nov/2013:18:16:23 +0500] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/Epson/eplp960s.ppd.gz!
W [29/Nov/2013:18:16:23 +0500] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/Epson/eplp950c.ppd.gz!
W [29/Nov/2013:18:16:23 +0500] [CGI] Missing Product in /usr/share/ppd/CNCUPSIRADV4051ZK.ppd!
W [29/Nov/2013:18:16:30 +0500] [CGI] Missing Product in /usr/share/cups/model/CNCUPSIRADV4051ZK.ppd!
W [29/Nov/2013:18:16:30 +0500] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/KONICA_MINOLTA/KOC451JX.ppd.gz!
E [29/Nov/2013:18:16:30 +0500] [cups-driverd] Bad driver information file "/usr/share/cups/model/foomatic-db-ppds/Kyocera/ReadMe.htm"!
W [29/Nov/2013:18:16:30 +0500] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/Brother/BR5070DN_GPL.ppd.gz!
W [29/Nov/2013:18:16:30 +0500] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/Epson/eplp980c.ppd.gz!
W [29/Nov/2013:18:16:30 +0500] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/Epson/eplp830c.ppd.gz!
W [29/Nov/2013:18:16:30 +0500] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/Epson/eplp880c.ppd.gz!
W [29/Nov/2013:18:16:30 +0500] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/Epson/eplp9100.ppd.gz!
W [29/Nov/2013:18:16:30 +0500] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/Epson/eplp920c.ppd.gz!
W [29/Nov/2013:18:16:30 +0500] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/Epson/eplp850c.ppd.gz!
W [29/Nov/2013:18:16:30 +0500] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/Epson/eplp960s.ppd.gz!
W [29/Nov/2013:18:16:30 +0500] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/Epson/eplp950c.ppd.gz!
W [29/Nov/2013:18:16:30 +0500] [CGI] Missing Product in /usr/share/ppd/CNCUPSIRADV4051ZK.ppd!
W [29/Nov/2013:18:16:56 +0500] CreateProfile failed: org.freedesktop.ColorManager.AlreadyExists:profile id 'Canon_MF4410-Gray..' already exists
W [29/Nov/2013:18:17:00 +0500] CreateProfile failed: org.freedesktop.ColorManager.AlreadyExists:profile id 'Canon_MF4410-Gray..' already exists

Last edited by Vilius (2014-01-15 04:55:51)

Offline

#2 2013-11-29 17:02:18

Vilius
Member
From: Dushanbe, Tajikistan
Registered: 2012-01-05
Posts: 26
Website

Re: [SOLVED] Unable to print with Canon MF4410 laser printer

Could anyone at least confirm that I'm not missing something obvious in the logs and generally?

Offline

#3 2013-11-29 17:34:25

hydrosIII
Member
Registered: 2013-04-04
Posts: 127

Re: [SOLVED] Unable to print with Canon MF4410 laser printer

Im not an expert, but in your first log you're missing python-dbus. So installing it wont hurt. In the cups error log. dnssd fails, maybe because the dbus missing dependency. It also seems that you re missing *.ppd files, although i think this is unrelated.

So i GUESS  is an issue with avahi, dnssd and dbus. install python-dbus

Offline

#4 2013-11-30 10:11:16

Vilius
Member
From: Dushanbe, Tajikistan
Registered: 2012-01-05
Posts: 26
Website

Re: [SOLVED] Unable to print with Canon MF4410 laser printer

I installed python-dbus, python2-dbus. I also installed and started Avahi. Now the related warnings are gone from the log, but the printer still does not print.

Nov 30 15:06:03 osmium systemd[1]: Started CUPS Printing Service.
Nov 30 15:06:03 osmium kernel: usblp1: removed
Nov 30 15:06:03 osmium kernel: usblp 6-1.6:1.1: usblp1: USB Bidirectional printer dev 4 if 1 alt 0 proto 2 vid 0x04A9 pid 0x2737
Nov 30 15:06:06 osmium systemd[1]: Started CUPS Printing Service.
Nov 30 15:06:12 osmium systemd[1]: Started CUPS Printing Service.
Nov 30 15:06:16 osmium systemd[1]: Started CUPS Printing Service.
Nov 30 15:06:31 osmium systemd[1]: Started CUPS Printing Service.
Nov 30 15:06:31 osmium colord[484]: (colord:484): Cd-WARNING **: failed to get session [pid 439]: Unknown error -2
Nov 30 15:06:31 osmium colord[484]: Device added: cups-Canon_MF4410
Nov 30 15:06:34 osmium systemd[1]: Started CUPS Printing Service.
Nov 30 15:06:34 osmium systemd[1]: Started CUPS Printing Service.
Nov 30 15:06:34 osmium systemd[1]: Started CUPS Printing Service.
Nov 30 15:06:34 osmium colord[484]: device removed: cups-Canon_MF4410
Nov 30 15:06:34 osmium colord[484]: (colord:484): Cd-WARNING **: failed to get session [pid 439]: Unknown error -2
Nov 30 15:06:34 osmium colord[484]: Device added: cups-Canon_MF4410
Nov 30 15:06:44 osmium systemd[1]: Started CUPS Printing Service.
Nov 30 15:06:44 osmium systemd[1]: Started CUPS Printing Service.
Nov 30 15:06:44 osmium systemd[1]: Started CUPS Printing Service.
Nov 30 15:06:44 osmium kernel: usblp1: removed
Nov 30 15:06:54 osmium kernel: usblp 6-1.6:1.1: usblp1: USB Bidirectional printer dev 4 if 1 alt 0 proto 2 vid 0x04A9 pid 0x2737
Nov 30 15:07:01 osmium systemd[1]: Started CUPS Printing Service.

/var/log/cups/error_log

W [30/Nov/2013:15:06:12 +0500] [CGI] Missing Product in /usr/share/cups/model/CNCUPSIRADV4051ZK.ppd!
W [30/Nov/2013:15:06:12 +0500] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/KONICA_MINOLTA/KOC451JX.ppd.gz!
E [30/Nov/2013:15:06:12 +0500] [cups-driverd] Bad driver information file "/usr/share/cups/model/foomatic-db-ppds/Kyocera/ReadMe.htm"!
W [30/Nov/2013:15:06:12 +0500] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/Brother/BR5070DN_GPL.ppd.gz!
W [30/Nov/2013:15:06:12 +0500] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/Epson/eplp980c.ppd.gz!
W [30/Nov/2013:15:06:12 +0500] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/Epson/eplp830c.ppd.gz!
W [30/Nov/2013:15:06:12 +0500] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/Epson/eplp880c.ppd.gz!
W [30/Nov/2013:15:06:12 +0500] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/Epson/eplp9100.ppd.gz!
W [30/Nov/2013:15:06:12 +0500] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/Epson/eplp920c.ppd.gz!
W [30/Nov/2013:15:06:12 +0500] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/Epson/eplp850c.ppd.gz!
W [30/Nov/2013:15:06:12 +0500] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/Epson/eplp960s.ppd.gz!
W [30/Nov/2013:15:06:12 +0500] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/Epson/eplp950c.ppd.gz!
W [30/Nov/2013:15:06:12 +0500] [CGI] Missing Product in /usr/share/ppd/CNCUPSIRADV4051ZK.ppd!
W [30/Nov/2013:15:06:16 +0500] [CGI] Missing Product in /usr/share/cups/model/CNCUPSIRADV4051ZK.ppd!
W [30/Nov/2013:15:06:16 +0500] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/KONICA_MINOLTA/KOC451JX.ppd.gz!
E [30/Nov/2013:15:06:16 +0500] [cups-driverd] Bad driver information file "/usr/share/cups/model/foomatic-db-ppds/Kyocera/ReadMe.htm"!
W [30/Nov/2013:15:06:16 +0500] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/Brother/BR5070DN_GPL.ppd.gz!
W [30/Nov/2013:15:06:16 +0500] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/Epson/eplp980c.ppd.gz!
W [30/Nov/2013:15:06:16 +0500] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/Epson/eplp830c.ppd.gz!
W [30/Nov/2013:15:06:16 +0500] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/Epson/eplp880c.ppd.gz!
W [30/Nov/2013:15:06:16 +0500] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/Epson/eplp9100.ppd.gz!
W [30/Nov/2013:15:06:16 +0500] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/Epson/eplp920c.ppd.gz!
W [30/Nov/2013:15:06:16 +0500] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/Epson/eplp850c.ppd.gz!
W [30/Nov/2013:15:06:16 +0500] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/Epson/eplp960s.ppd.gz!
W [30/Nov/2013:15:06:16 +0500] [CGI] Missing NickName and ModelName in /usr/share/cups/model/foomatic-db-ppds/Epson/eplp950c.ppd.gz!
W [30/Nov/2013:15:06:16 +0500] [CGI] Missing Product in /usr/share/ppd/CNCUPSIRADV4051ZK.ppd!
W [30/Nov/2013:15:06:31 +0500] CreateProfile failed: org.freedesktop.ColorManager.AlreadyExists:profile id 'Canon_MF4410-Gray..' already exists
W [30/Nov/2013:15:06:34 +0500] CreateProfile failed: org.freedesktop.ColorManager.AlreadyExists:profile id 'Canon_MF4410-Gray..' already exists

Offline

#5 2013-11-30 10:21:21

Vilius
Member
From: Dushanbe, Tajikistan
Registered: 2012-01-05
Posts: 26
Website

Re: [SOLVED] Unable to print with Canon MF4410 laser printer

When I try to print from other programs, I also get this

Nov 30 15:17:48 osmium dbus-daemon[440]: dbus[440]: [system] Rejected send message, 2 matched rules; type="method_return", sender=":1.65" (uid=84 pid=3317 comm="avahi-daemon: starting up") interface="(unset)" member="(unset)" error name="(unset)" requested_reply="0" destination=...
Nov 30 15:17:48 osmium dbus[440]: [system] Rejected send message, 2 matched rules; type="method_return", sender=":1.65" (uid=84 pid=3317 comm="avahi-daemon: starting up") interface="(unset)" member="(unset)" error name="(unset)" requested_reply="0" destinat...ktop/357_TR2013.pdf ")
Nov 30 15:17:48 osmium dbus[440]: [system] Rejected send message, 2 matched rules; type="method_return", sender=":1.65" (uid=84 pid=3317 comm="avahi-daemon: starting up") interface="(unset)" member="(unset)" error name="(unset)" requested_reply="0" destinat...ktop/357_TR2013.pdf ")
Nov 30 15:17:48 osmium dbus-daemon[440]: dbus[440]: [system] Rejected send message, 2 matched rules; type="method_return", sender=":1.65" (uid=84 pid=3317 comm="avahi-daemon: starting up") interface="(unset)" member="(unset)" error name="(unset)" requested_reply="0" destination=...
Nov 30 15:17:48 osmium systemd[1]: Started CUPS Printing Service.
Nov 30 15:17:48 osmium systemd[1]: Started CUPS Printing Service.
Nov 30 15:17:48 osmium kernel: usblp1: removed
Nov 30 15:17:57 osmium kernel: usblp 6-1.6:1.1: usblp1: USB Bidirectional printer dev 4 if 1 alt 0 proto 2 vid 0x04A9 pid 0x2737
Nov 30 15:18:19 osmium systemd[1]: Started CUPS Printing Service.

By the way what is the "kernel: usblp1: removed" line saying?

Offline

#6 2013-11-30 12:31:01

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 4,237

Re: [SOLVED] Unable to print with Canon MF4410 laser printer

Might point to a problem with the usb connection.

please post the output of lsusb -t before and after plugging in the canon printer .
Also the contents of /etc/cups/printers.conf with the canon plugged in might help.


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#7 2013-11-30 15:13:01

Vilius
Member
From: Dushanbe, Tajikistan
Registered: 2012-01-05
Posts: 26
Website

Re: [SOLVED] Unable to print with Canon MF4410 laser printer

lsusb -t without printer:

/:  Bus 06.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/2p, 5000M
/:  Bus 05.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/2p, 480M
    |__ Port 2: Dev 2, If 0, Class=Human Interface Device, Driver=usbhid, 1.5M
/:  Bus 04.Port 1: Dev 1, Class=root_hub, Driver=ehci-pci/2p, 480M
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/8p, 480M
        |__ Port 2: Dev 3, If 0, Class=Human Interface Device, Driver=usbhid, 12M
        |__ Port 2: Dev 3, If 1, Class=Human Interface Device, Driver=usbhid, 12M
        |__ Port 2: Dev 3, If 2, Class=Human Interface Device, Driver=usbhid, 12M
/:  Bus 03.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/2p, 5000M
/:  Bus 02.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/2p, 480M
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=ehci-pci/2p, 480M
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/6p, 480M
        |__ Port 5: Dev 3, If 0, Class=Wireless, Driver=btusb, 12M
        |__ Port 5: Dev 3, If 1, Class=Wireless, Driver=btusb, 12M

With printer:

/:  Bus 06.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/2p, 5000M
/:  Bus 05.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/2p, 480M
    |__ Port 2: Dev 2, If 0, Class=Human Interface Device, Driver=usbhid, 1.5M
/:  Bus 04.Port 1: Dev 1, Class=root_hub, Driver=ehci-pci/2p, 480M
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/8p, 480M
        |__ Port 2: Dev 3, If 0, Class=Human Interface Device, Driver=usbhid, 12M
        |__ Port 2: Dev 3, If 1, Class=Human Interface Device, Driver=usbhid, 12M
        |__ Port 2: Dev 3, If 2, Class=Human Interface Device, Driver=usbhid, 12M
        |__ Port 6: Dev 5, If 0, Class=Vendor Specific Class, Driver=, 480M
        |__ Port 6: Dev 5, If 1, Class=Printer, Driver=usblp, 480M
/:  Bus 03.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/2p, 5000M
/:  Bus 02.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/2p, 480M
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=ehci-pci/2p, 480M
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/6p, 480M
        |__ Port 5: Dev 3, If 0, Class=Wireless, Driver=btusb, 12M
        |__ Port 5: Dev 3, If 1, Class=Wireless, Driver=btusb, 12M

/etc/cups/printers.conf:

# Printer configuration file for CUPS v1.7.0
# Written by cupsd on 2013-11-30 15:33
# DO NOT EDIT THIS FILE WHEN CUPSD IS RUNNING
<Printer Canon_MF4410>
UUID urn:uuid:3cf04990-8d9d-3348-4c50-5f598ad658c2
Info Canon MF4410
Location Local Printer
MakeModel Canon MF4400 Series UFRII LT ver.2.7
DeviceURI cnusb:/dev/usb/lp1
State Idle
StateTime 1385807594
Type 8393860
Accepting Yes
Shared No
JobSheets none none
QuotaPeriod 0
PageLimit 0
KLimit 0
OpPolicy default
ErrorPolicy stop-printer
</Printer>
<Printer Deskjet_F4100>
UUID urn:uuid:5cab2a2a-86d1-32e0-63d0-6bd0ca5c3b2a
Info Deskjet_F4100
MakeModel HP Deskjet f4100 Series, hpcups 3.13.10
DeviceURI hp:/usb/Deskjet_F4100_series?serial=CN83H6V1RG04TJ
State Stopped
StateMessage Rendering completed
StateTime 1385731069
Reason paused
Type 36892
Accepting Yes
Shared Yes
JobSheets none none
QuotaPeriod 0
PageLimit 0
KLimit 0
OpPolicy default
ErrorPolicy stop-printer
</Printer>

Offline

#8 2013-11-30 15:17:52

Vilius
Member
From: Dushanbe, Tajikistan
Registered: 2012-01-05
Posts: 26
Website

Re: [SOLVED] Unable to print with Canon MF4410 laser printer

Out of desperation I even tried different (shorter) USB cable - no luck.

Offline

#9 2013-11-30 17:41:03

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 4,237

Re: [SOLVED] Unable to print with Canon MF4410 laser printer

some observations :

bus 01 appears to be used for bluetooth, this is likely an internal connection made on your motherboard
bus 02, 03 and 06 have nothing connected to them
bus 05 is used for a HID device
bus 04 has 2 devices : 1 HID, the printer

Try connecting the printer to bus 02 , 03 or 06
you can use lsusb (without -t) to find out which bus the printer is connected to.
Then post lsusb output, so we can see what those 2 interfaces that are shown for the printer are.


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#10 2013-12-01 08:09:21

Vilius
Member
From: Dushanbe, Tajikistan
Registered: 2012-01-05
Posts: 26
Website

Re: [SOLVED] Unable to print with Canon MF4410 laser printer

I tried all the USB connections, but could only get bus 1, 4 and 5. I took a look at my motherboard, and it seams that some USB connections aren't used at all.
Anyway, this is the output of lsusb after my experiments (in the process I rearranged most other wires, so they probably will not match the previous lsusb output):

$ lsusb
Bus 004 Device 003: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 004 Device 015: ID 04a9:2737 Canon, Inc. MF4410
Bus 004 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 004 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 006 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 005 Device 013: ID 046d:c312 Logitech, Inc. DeLuxe 250 Keyboard
Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 010: ID 0cf3:3005 Atheros Communications, Inc. AR3011 Bluetooth
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

My printer is this one: Bus 004 Device 015: ID 04a9:2737 Canon, Inc. MF4410

Offline

#11 2013-12-01 12:47:59

Vilius
Member
From: Dushanbe, Tajikistan
Registered: 2012-01-05
Posts: 26
Website

Re: [SOLVED] Unable to print with Canon MF4410 laser printer

I also tried setting up the printer in a VirtualBox guest system (Windows 8.1). Windows sees the device but does not recognize it as a printer, event though I have installed the official drivers from Canon. Meanwhile the other laptop (Windows 7) is able to print perfectly.

Offline

#12 2013-12-01 18:23:40

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 12,936

Re: [SOLVED] Unable to print with Canon MF4410 laser printer

I don't have a solution to your problem, but my guess would be that USB issues are not your problem.
I am, however, surprised that the VM cannot drive it.  Perhaps there is a USB problem, perhaps your drivers do not work on 8.1.

My next steps would be to try it in a Windows 7 VM -or- get the printer running under Windows 7 on the other box, then, without powering down, move it to the Arch box and see if you can get it to print (Here, I am wondering if firmware are uploaded by the driver at the time of printer initialization).   Also, what happens if you share the printer on the Windows box and try to print to print to it over a network?


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Like you, I have no idea what you are doing, but I am pretty sure it is wrong...Jasonwryan
----
How to Ask Questions the Smart Way

Offline

#13 2013-12-01 19:31:51

Vilius
Member
From: Dushanbe, Tajikistan
Registered: 2012-01-05
Posts: 26
Website

Re: [SOLVED] Unable to print with Canon MF4410 laser printer

Ok, finally some good news. I tried it on another virtual machine with Windows XP, and it worked. So now I at least do not have to turn on the laptop just to print something.

I double-checked the manual, and it says that I have to install the drivers before connecting the printer for the first time. Could that be the cause of my problems with Windows 8.1 virtual machine and the Linux host machine? Honestly, I do not remember whether I first connected the printer, or installed the drivers (and what change would that make in case of Linux?)

Offline

#14 2013-12-02 12:01:56

Vilius
Member
From: Dushanbe, Tajikistan
Registered: 2012-01-05
Posts: 26
Website

Re: [SOLVED] Unable to print with Canon MF4410 laser printer

Forum Moderator, I tried what you suggested, and it didn't work. Even after successfully printing something from the virtual machine, the host machine was not able to print.

Offline

#15 2013-12-05 07:31:34

hydrosIII
Member
Registered: 2013-04-04
Posts: 127

Re: [SOLVED] Unable to print with Canon MF4410 laser printer

May i suggest reading the guide provided in the package. Maybe it will help :https://aur.archlinux.org/packages/cndrvcups-lb/

"there is an extensive guide from Canon (with troubleshooting tips) in /usr/share/doc/cndrvcups-lb/guide-ufr2-2.7xUK.tar.gz, check it please."

Offline

#16 2013-12-05 13:13:20

robertleleu
Member
Registered: 2013-12-05
Posts: 1

Re: [SOLVED] Unable to print with Canon MF4410 laser printer

I got (and solved a similar problem)

Lubuntu32bits 13.04, printing pdf file from Adobe reader 9 through cups to Canon Pixma iX 6500 USB connected to the LPD modem
The original file, displaying Version 1.3 Acrobat 4.x in the properties could only be printed one per one, and stopped with "rendering completed" for 4 copies.
I printed the file yo the cups-pdf printer, which produced a Version 1.4 Acrobat 5.x.... and this last file allows the printer to print without problem.

Offline

#17 2013-12-06 14:24:22

Vilius
Member
From: Dushanbe, Tajikistan
Registered: 2012-01-05
Posts: 26
Website

Re: [SOLVED] Unable to print with Canon MF4410 laser printer

hydrosIII, thank you. When I try to add the printer with lpadmin (as the documentation says), I get the following error:

E [06/Dec/2013:19:18:29 +0500] [cups-driverd] Unable to open "/usr/share/cups/model/usr/share/cups/model/CNCUPSMF4400ZS.ppd" - No such file or directory
E [06/Dec/2013:19:18:29 +0500] copy_model: empty PPD file
E [06/Dec/2013:19:18:29 +0500] [Client 15] Returning IPP server-error-internal-error for CUPS-Add-Modify-Printer (ipp://localhost:631/printers/Canon_MF4410) from localhost

Although the file exists, and is not empty. And I run everything from su.
That's certainly some progress, I'll give it another try, when time permits.

robertleleu, no I do not think my problem is related yours. I am not able to print anything at all, not just pdf documents.

Offline

#18 2013-12-20 07:17:02

hydrosIII
Member
Registered: 2013-04-04
Posts: 127

Re: [SOLVED] Unable to print with Canon MF4410 laser printer

Is the driver really there?, check it!!, Maybe the driver is bad, I really dont know. As an altenative you could try downloading a ppd file from openprinting http://www.openprinting.org/printers and paste it where it is supposed to be.
Good luck

Offline

#19 2013-12-20 13:20:51

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 4,237

Re: [SOLVED] Unable to print with Canon MF4410 laser printer

E [06/Dec/2013:19:18:29 +0500] [cups-driverd] Unable to open "/usr/share/cups/model/usr/share/cups/model/CNCUPSMF4400ZS.ppd" - No such file or directory

Villius, you used a wrong path when executing the lpadmin command

the ppd file is in /usr/share/cups/model/CNCUPSMF4400ZS.ppd


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#20 2014-01-14 12:51:55

Vilius
Member
From: Dushanbe, Tajikistan
Registered: 2012-01-05
Posts: 26
Website

Re: [SOLVED] Unable to print with Canon MF4410 laser printer

After installing the latest update to canon-ufr (2.70-2) package the printer started working. Must have been some driver-related problem.

Offline

Board footer

Powered by FluxBB