You are not logged in.

#1 2013-12-06 10:40:32

GloW_on_dub
Member
Registered: 2013-03-13
Posts: 383

[SOLVED]could not insert nvidia: invalid argument" with linux 3.12.3-1

Hello

After the last kernel update ( linux 3.12.3-1 ), nvidia module could not load with this error :

modprobe error : could not insert nvidia : invalid argument 

installing nvidia-beta from AUR solve it.

Last edited by GloW_on_dub (2013-12-06 10:46:15)

Offline

#2 2013-12-06 10:42:02

syms
Member
Registered: 2008-12-25
Posts: 296

Re: [SOLVED]could not insert nvidia: invalid argument" with linux 3.12.3-1

I can confirm this, after this kernel update my xserver no longer starts. Downgrading helps

Offline

#3 2013-12-06 11:14:06

willtriv
Member
Registered: 2009-04-18
Posts: 7

Re: [SOLVED]could not insert nvidia: invalid argument" with linux 3.12.3-1

Downgrade the kernel or pull in nvidia-beta without building any of the dependencies for special nvidia-libgl-beta stuff (as those packages also seem to be broken.)


How did the new kernel version get released into stable without the modules for it all being updated?

Offline

#4 2013-12-06 11:18:50

sirocco
Member
Registered: 2008-03-10
Posts: 147

Re: [SOLVED]could not insert nvidia: invalid argument" with linux 3.12.3-1

willtriv wrote:

How did the new kernel version get released into stable without the modules for it all being updated?

Furthemore: https://bugs.archlinux.org/task/38028

Offline

#5 2013-12-06 11:25:02

willtriv
Member
Registered: 2009-04-18
Posts: 7

Re: [SOLVED]could not insert nvidia: invalid argument" with linux 3.12.3-1

^^

Rather than messing around with slightly outdated AUR packages I fixed it by doing and ABS sync and doing my own makepkg for nvidia. Seems cleaner than switching packages for a day and then forgetting that I switched and breaking my system again in a week.

Offline

#6 2013-12-06 13:35:24

developej
Member
Registered: 2011-10-02
Posts: 68

Re: [SOLVED]could not insert nvidia: invalid argument" with linux 3.12.3-1

I installed ABS, created nvidia package with it and installed it with -U option. It fixed the problem, but how? Package created is also 331.20-1, and that same version was present before it, with regular -S nvidia?

Offline

#7 2013-12-06 14:04:36

freestyler7
Member
Registered: 2010-11-02
Posts: 33

Re: [SOLVED]could not insert nvidia: invalid argument" with linux 3.12.3-1

It's the same version but rebuild against the latest kernel / headers.
When it will be released in the official repos the version will be 3.12.3-2. Meaning it's the 2nd iteration of the same version (containing new dependencies, rebuilds etc)
You could have increased the pkgrel yourself in the PKGBUILD. No big deal smile

Offline

#8 2013-12-06 14:10:45

developej
Member
Registered: 2011-10-02
Posts: 68

Re: [SOLVED]could not insert nvidia: invalid argument" with linux 3.12.3-1

Oh, ok. Considering I installed nvidia via ABS now, when it gets updated in extra, will pacman -Syu 'catch up' on it? Or do I have to manually 'switch' from installing it via ABS to extra?

And thanks for clarifying smile

Last edited by developej (2013-12-06 14:32:44)

Offline

#9 2013-12-06 14:14:17

karol
Archivist
Registered: 2009-05-06
Posts: 25,440

Re: [SOLVED]could not insert nvidia: invalid argument" with linux 3.12.3-1

pacman compares version numbers for packages with the same name (or if package foo gets replaced by package bar) so it will 'catch up' automatically.

Offline

#10 2013-12-06 16:17:54

ackalker
Member
Registered: 2012-11-27
Posts: 201

Re: [SOLVED]could not insert nvidia: invalid argument" with linux 3.12.3-1

developej wrote:

Oh, ok. Considering I installed nvidia via ABS now, when it gets updated in extra, will pacman -Syu 'catch up' on it? Or do I have to manually 'switch' from installing it via ABS to extra?

In case you want pacman to catch up, either don't make any changes to pkgver and pkgrel in the PKGBUILD at all, or at least don't bump them beyond what's going to be in the repos.

Last edited by ackalker (2013-12-06 16:20:33)

Offline

#11 2013-12-06 16:19:17

flipper T
Member
Registered: 2012-09-14
Posts: 419

Re: [SOLVED]could not insert nvidia: invalid argument" with linux 3.12.3-1

New nvidia pkg is in repos (331.20-2).

It solved this issue for me.

Last edited by flipper T (2013-12-06 16:21:59)


If I'm curt with you it's because time is a factor. I think fast, I talk fast and I need you guys to act fast if you wanna get out of this. So, pretty please... with sugar on top. Clean the [censored] car. -The Wolf

Offline

#12 2013-12-06 16:26:03

ackalker
Member
Registered: 2012-11-27
Posts: 201

Re: [SOLVED]could not insert nvidia: invalid argument" with linux 3.12.3-1

yippie! Thanks to the devs for pushing it in so quickly wink

Offline

#13 2013-12-06 17:45:48

GloW_on_dub
Member
Registered: 2013-03-13
Posts: 383

Re: [SOLVED]could not insert nvidia: invalid argument" with linux 3.12.3-1

Thanks, in the meantime i've learned about abs, so it's all good.

Offline

#14 2013-12-06 18:48:39

Kilzool
Member
From: Ireland
Registered: 2010-08-04
Posts: 232

Re: [SOLVED]could not insert nvidia: invalid argument" with linux 3.12.3-1

Please see this https://bbs.archlinux.org/viewtopic.php?id=173024

(*towards the bottom of that thread, my post)

Offline

Board footer

Powered by FluxBB