You are not logged in.

#1 2013-12-07 07:41:21

tattsan
Member
Registered: 2013-08-26
Posts: 37
Website

[SOLVED] Grub says "symbol 'grub_real_boot_time' not found."

After 'pacman -Syu', grub was upgraded from  2.00.5086-1 to 1:2.00.1282.g5ae5c54-1.
Rebooting my system, grub says

error: symbol 'grub_real_boot_time' not found. 

and it goes to rescue mode.

On the rescue mode,  I tried to insmod normal.mod. But grub says the same message as above, and fails to load the module. How can I boot my Arch?

Last edited by tattsan (2013-12-08 11:08:34)

Offline

#2 2013-12-07 07:47:58

fettouhi
Member
Registered: 2007-05-07
Posts: 736

Re: [SOLVED] Grub says "symbol 'grub_real_boot_time' not found."

Yesterday there was an update of grub2 in the Arch repos. I installed it on my 64 bit machine. Then I decided I wanted update grub in the GPT partition I've made originally so I simply did as I have done several time before when grub2 has been updated:

grub-install --directory=/usr/lib/grub/i386-pc --target=i386-pc --boot-directory=/boot --recheck --debug /dev/sda

but it through an error saying gpt.mod is missing, so I did

grub-mkconfig -o /boot/grub/grub.cfg

which also fails for some reason, complaining about a syntax error. Now grub is busted and I can't boot into my installation. Grub loads but throws an error stating "symbol 'grub_real_boot_time' not found" and throws me into grub rescue. What did I do wrong? My setup consists 2 500 MB drives with 4 partitions on it boot, swap, root and home. I'm using software RAID where boot is RAID 1 and home and root are RAID 0. How can I get the machine just to boot once so that i can back up my stuff because I want to reinstall anyway. The installation is now 4 years old almost and has carried over from an older machine.

Offline

#3 2013-12-07 07:50:40

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 28,147
Website

Re: [SOLVED] Grub says "symbol 'grub_real_boot_time' not found."

Merging with the earlier thread...


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

#4 2013-12-07 14:04:30

fettouhi
Member
Registered: 2007-05-07
Posts: 736

Re: [SOLVED] Grub says "symbol 'grub_real_boot_time' not found."

@tattsan: Have you tried downgrading grub back to the previous version?

Offline

#5 2013-12-07 14:45:35

tattsan
Member
Registered: 2013-08-26
Posts: 37
Website

Re: [SOLVED] Grub says "symbol 'grub_real_boot_time' not found."

@fettouhi: Yes. I downgraded grub to the previous version (2.00.5086-1), and I could repair the boot loader.

As for new version,
/usr/lib/grub/i386-pc/normal.mod  contains the symbol  grub_real_boot_time, but
/boot/grub/i386-pc/normal.mod  does not.
On rescue mode, I could not load the modules eather.

Not all modules are broken.  For example: mmap.mod,  relocator.mod,  reboot.mod
are loadable, so I could reboot the boot loader smile

Last edited by tattsan (2013-12-07 14:48:04)

Offline

#6 2013-12-07 16:56:29

fettouhi
Member
Registered: 2007-05-07
Posts: 736

Re: [SOLVED] Grub says "symbol 'grub_real_boot_time' not found."

tattsan wrote:

@fettouhi: Yes. I downgraded grub to the previous version (2.00.5086-1), and I could repair the boot loader.

As for new version,
/usr/lib/grub/i386-pc/normal.mod  contains the symbol  grub_real_boot_time, but
/boot/grub/i386-pc/normal.mod  does not.
On rescue mode, I could not load the modules eather.

Not all modules are broken.  For example: mmap.mod,  relocator.mod,  reboot.mod
are loadable, so I could reboot the boot loader smile

So you typed simply

insmod (hdX,Y)/grub/i386-pc/reboot.mod

instead normal.mod? How did you load the kernel, e.g. what you type after that?

Offline

#7 2013-12-07 18:06:09

tattsan
Member
Registered: 2013-08-26
Posts: 37
Website

Re: [SOLVED] Grub says "symbol 'grub_real_boot_time' not found."

I did not load linux kernel from that broken grub.  'reboot' command works,
and PC restarts, but you'll faced with rescue mode of grub again smile

(workaround)
So I boot up my PC using installation CD, mount HDD, chroot, downgrade
grub package, and repair the loader installed on /dev/sda.

Can this be said as solved?

Offline

#8 2013-12-07 20:41:12

fettouhi
Member
Registered: 2007-05-07
Posts: 736

Re: [SOLVED] Grub says "symbol 'grub_real_boot_time' not found."

Did the same thing and I'm up and running again. But it seems like this package is broken or has a bug at least have you filed a bug report?

Offline

#9 2013-12-08 03:42:38

tattsan
Member
Registered: 2013-08-26
Posts: 37
Website

Re: [SOLVED] Grub says "symbol 'grub_real_boot_time' not found."

For a bug report, I want to check its reproducibility, but I have no time for it yet.

Offline

#10 2013-12-08 09:07:04

aatoma
Member
Registered: 2013-01-22
Posts: 29

Re: [SOLVED] Grub says "symbol 'grub_real_boot_time' not found."

Hi All,

I'm having troubles with this upgrade too (I'm on x86_64 dual booting Arch and Windows).
If I upgrade from 2.00.5086-1 to 1:2.00.1282.g5ae5c54-1 I get a crazy (32GB RAM here)

out of memory error

when running

grub-mkconfig -o /boot/grub/grub.cfg

downgrading solves the issue.

My /etc/default/grub is rather normal

GRUB_DEFAULT=saved
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR="Arch"
GRUB_CMDLINE_LINUX_DEFAULT="quiet"
GRUB_CMDLINE_LINUX="resume=/dev/sda3"

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable Hidden Menu, and optionally hide the timeout count
#GRUB_HIDDEN_TIMEOUT=5
#GRUB_HIDDEN_TIMEOUT_QUIET=true

# Uncomment to use basic console
GRUB_TERMINAL_INPUT=console

# Uncomment to disable graphical terminal
#GRUB_TERMINAL_OUTPUT=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE=auto

# Uncomment to allow the kernel use the same resolution used by grub
GRUB_GFXPAYLOAD_LINUX=keep

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter 
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx" 
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY=true

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper 
# modes only.  Entries specified as foreground/background.
#GRUB_COLOR_NORMAL="light-blue/black"
#GRUB_COLOR_HIGHLIGHT="light-cyan/blue"

# Uncomment one of them for the gfx desired, a image background or a gfxtheme
GRUB_BACKGROUND="/usr/share/wallpapers/Elarun/contents/images/2560x1600.png"
#GRUB_THEME="/path/to/gfxtheme"

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

GRUB_SAVEDEFAULT="true"

Should we keep the two issues in the same thread?

Regards.
Antonio.

Offline

#11 2013-12-08 09:13:46

progandy
Member
Registered: 2012-05-17
Posts: 3,594

Re: [SOLVED] Grub says "symbol 'grub_real_boot_time' not found."

tattsan wrote:

As for new version,
/usr/lib/grub/i386-pc/normal.mod  contains the symbol  grub_real_boot_time, but
/boot/grub/i386-pc/normal.mod  does not.
On rescue mode, I could not load the modules eather.

It could be that the update path is broken, but grub itself works. Maybe try to move /boot/grub to /boot/grub-backup, then reinstall the grub package and call grub-install. If the boot works delete the backup.

Last edited by progandy (2013-12-08 09:17:14)


| alias CUTF='LANG=en_XX.UTF-8@POSIX ' |

Offline

#12 2013-12-08 11:07:54

tattsan
Member
Registered: 2013-08-26
Posts: 37
Website

Re: [SOLVED] Grub says "symbol 'grub_real_boot_time' not found."

[SOLUTION]

progandy wrote:

It could be that the update path is broken, but grub itself works. Maybe try to move /boot/grub to /boot/grub-backup, then reinstall the grub package and call grub-install. If the boot works delete the backup.

You are right! Thank you progandy!!
I moved old /boot/grub to /boot/grub-backup, and remake /boot/grub/grub.cfg,  and called grub-install. Then right modules are installed in /boot/grub/i386-pc, and grub could load the module normal.mod when boot.

When I met this trouble, grub-install failed to update modules for some reason. I couln't reproduce the situation, so I don't know what caused that failure.

Last edited by tattsan (2013-12-08 11:23:45)

Offline

#13 2013-12-08 11:18:11

tattsan
Member
Registered: 2013-08-26
Posts: 37
Website

Re: [SOLVED] Grub says "symbol 'grub_real_boot_time' not found."

aatoma wrote:

Should we keep the two issues in the same thread?

Your problem is discussed in https://bugs.archlinux.org/task/37904.
It's a bug, and there is a workaround for it.

Last edited by tattsan (2013-12-08 15:33:32)

Offline

#14 2013-12-08 14:57:01

fettouhi
Member
Registered: 2007-05-07
Posts: 736

Re: [SOLVED] Grub says "symbol 'grub_real_boot_time' not found."

progandy wrote:
tattsan wrote:

As for new version,
/usr/lib/grub/i386-pc/normal.mod  contains the symbol  grub_real_boot_time, but
/boot/grub/i386-pc/normal.mod  does not.
On rescue mode, I could not load the modules eather.

It could be that the update path is broken, but grub itself works. Maybe try to move /boot/grub to /boot/grub-backup, then reinstall the grub package and call grub-install. If the boot works delete the backup.

I'm not sure what you mean. If I update grub from 2.00.5086-1 to 1:2.00.1282.g5ae5c54-1 and do

grub-mkconfig -o /boot/grub/grub.cfg

I get the error

error: out of memory.
error: syntax error.
error: Incorrect command.
error: syntax error.
Syntax error at line 190
Syntax errors are detected in generated GRUB config file.
Ensure that there are no errors in /etc/default/grub
and /etc/grub.d/* files or please file a bug report with
/boot/grub/grub.cfg.new file attached.done

and running

grub-install --directory=/usr/lib/grub/i386-pc --target=i386-pc --boot-directory=/boot --recheck --debug /dev/sda
grub-install --directory=/usr/lib/grub/i386-pc --target=i386-pc --boot-directory=/boot --recheck --debug /dev/sdb

gives me an error saying gpt.mod is missing.

So how do I update grub without braking it?

Offline

#15 2013-12-08 15:08:28

karol
Archivist
Registered: 2009-05-06
Posts: 25,440

Re: [SOLVED] Grub says "symbol 'grub_real_boot_time' not found."

Did you try to disable submenu by adding "GRUB_DISABLE_SUBMENU=y" to /etc/default/grub and regenerate grub.cfg?
https://bugs.archlinux.org/task/37904

Offline

#16 2013-12-08 16:01:55

fettouhi
Member
Registered: 2007-05-07
Posts: 736

Re: [SOLVED] Grub says "symbol 'grub_real_boot_time' not found."

karol wrote:

Did you try to disable submenu by adding "GRUB_DISABLE_SUBMENU=y" to /etc/default/grub and regenerate grub.cfg?
https://bugs.archlinux.org/task/37904

Yes I tried that now

grub-mkconfig -o /boot/grub/grub.cfg

runs correctly but

grub-install --directory=/usr/lib/grub/i386-pc --target=i386-pc --boot-directory=/boot --recheck --debug /dev/sda
grub-install --directory=/usr/lib/grub/i386-pc --target=i386-pc --boot-directory=/boot --recheck --debug /dev/sdb

both fail with the error that gpt.mod is missing.

Offline

#17 2013-12-08 17:12:04

tattsan
Member
Registered: 2013-08-26
Posts: 37
Website

Re: [SOLVED] Grub says "symbol 'grub_real_boot_time' not found."

Try

mv /boot/grub  /boot/grub-backup
mkdir /boot/grub

and

fettouhi wrote:

grub-mkconfig -o /boot/grub/grub.cfg
grub-install --directory=/usr/lib/grub/i386-pc --target=i386-pc --boot-directory=/boot --recheck --debug /dev/sda

and so on.

Offline

#18 2013-12-08 17:31:04

fettouhi
Member
Registered: 2007-05-07
Posts: 736

Re: [SOLVED] Grub says "symbol 'grub_real_boot_time' not found."

tattsan wrote:

Try

mv /boot/grub  /boot/grub-backup
mkdir /boot/grub

and

fettouhi wrote:

grub-mkconfig -o /boot/grub/grub.cfg
grub-install --directory=/usr/lib/grub/i386-pc --target=i386-pc --boot-directory=/boot --recheck --debug /dev/sda

and so on.

I did all that and with the new grub grub-install fails with gpt.mod missing.

Offline

#19 2013-12-08 19:07:16

tattsan
Member
Registered: 2013-08-26
Posts: 37
Website

Re: [SOLVED] Grub says "symbol 'grub_real_boot_time' not found."

fettouhi wrote:

I did all that and with the new grub grub-install fails with gpt.mod missing.

That problem is discussed in https://bugs.archlinux.org/task/38053 .

So many bugs in this version!

Last edited by tattsan (2013-12-09 01:24:51)

Offline

#20 2013-12-09 04:41:03

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 6,104

Re: [SOLVED] Grub says "symbol 'grub_real_boot_time' not found."

By the way, if you have a backup of your old config file, you can just replace the config file and it will work.


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | refind | stub loader | systemd | LVM2 on LUKS
Lenovo x270 | Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz | Intel Corporation Wireless 8265 / 8275 | US keyboard with Euro | 512G NVMe INTEL SSDPEKKF512G7L

Offline

#21 2013-12-09 07:07:53

fettouhi
Member
Registered: 2007-05-07
Posts: 736

Re: [SOLVED] Grub says "symbol 'grub_real_boot_time' not found."

cfr wrote:

By the way, if you have a backup of your old config file, you can just replace the config file and it will work.

I've tried also with my old grub.cfg and it still fails.

Offline

#22 2013-12-09 07:46:24

tattsan
Member
Registered: 2013-08-26
Posts: 37
Website

Re: [SOLVED] Grub says "symbol 'grub_real_boot_time' not found."

fettouhi wrote:

I did all that and with the new grub grub-install fails with gpt.mod missing.

What is the result of  'grep  -r  gpt  /boot/grub/* | grep -v ^Binary'  ? Mine is as bellow.

# grep -r gpt /boot/grub/* | grep -v ^Binary
/boot/grub/grub.cfg:insmod part_gpt
/boot/grub/grub.cfg.example:insmod part_gpt
/boot/grub/i386-pc/command.lst:gptsync: gptsync
/boot/grub/i386-pc/moddep.lst:part_gpt:
/boot/grub/i386-pc/moddep.lst:ldm: part_gpt diskfilter part_msdos
/boot/grub/i386-pc/moddep.lst:gptsync: disk
/boot/grub/i386-pc/partmap.lst:part_gpt

There's  'insmod part_gpt'  in grub.cfg,  but no   'insmod gpt' .

Offline

#23 2013-12-09 09:28:58

tattsan
Member
Registered: 2013-08-26
Posts: 37
Website

Re: [SOLVED] Grub says "symbol 'grub_real_boot_time' not found."

And in /etc/default/grub , there's a line bellow:

GRUB_PRELOAD_MODULES="part_gpt  part_msdos"

This line is inserted to grub.cfg by /etc/grub.d/00_header script as 'insmod gpt_part' and so on.

Last edited by tattsan (2013-12-09 09:41:32)

Offline

#24 2013-12-09 10:32:33

fettouhi
Member
Registered: 2007-05-07
Posts: 736

Re: [SOLVED] Grub says "symbol 'grub_real_boot_time' not found."

tattsan wrote:
fettouhi wrote:

I did all that and with the new grub grub-install fails with gpt.mod missing.

What is the result of  'grep  -r  gpt  /boot/grub/* | grep -v ^Binary'  ? Mine is as bellow.

# grep -r gpt /boot/grub/* | grep -v ^Binary
/boot/grub/grub.cfg:insmod part_gpt
/boot/grub/grub.cfg.example:insmod part_gpt
/boot/grub/i386-pc/command.lst:gptsync: gptsync
/boot/grub/i386-pc/moddep.lst:part_gpt:
/boot/grub/i386-pc/moddep.lst:ldm: part_gpt diskfilter part_msdos
/boot/grub/i386-pc/moddep.lst:gptsync: disk
/boot/grub/i386-pc/partmap.lst:part_gpt

There's  'insmod part_gpt'  in grub.cfg,  but no   'insmod gpt' .

Here is my output.

[root@andre ~]# grep  -r  gpt  /boot/grub/* | grep -v ^Binary
/boot/grub/grub.cfg:insmod part_gpt
/boot/grub/grub.cfg:insmod part_gpt
/boot/grub/grub.cfg:insmod part_gpt
/boot/grub/grub.cfg:insmod part_gpt
/boot/grub/grub.cfg:insmod part_gpt
/boot/grub/grub.cfg:    insmod part_gpt
/boot/grub/grub.cfg:    insmod part_gpt
/boot/grub/grub.cfg:    insmod part_gpt
/boot/grub/grub.cfg:    insmod part_gpt
/boot/grub/grub.cfg.backup:insmod part_gpt
/boot/grub/grub.cfg.backup:insmod part_gpt
/boot/grub/grub.cfg.backup:insmod part_gpt
/boot/grub/grub.cfg.backup:insmod part_gpt
/boot/grub/grub.cfg.backup:insmod part_gpt
/boot/grub/grub.cfg.backup:     insmod part_gpt
/boot/grub/grub.cfg.backup:     insmod part_gpt
/boot/grub/grub.cfg.backup:     insmod part_gpt
/boot/grub/grub.cfg.backup:     insmod part_gpt
Binær fil /boot/grub/i386-pc/part_gpt.mod stemmer
/boot/grub/i386-pc/partmap.lst:part_gpt
/boot/grub/i386-pc/moddep.lst:part_gpt:
/boot/grub/i386-pc/moddep.lst:ldm: part_gpt diskfilter part_msdos
/boot/grub/i386-pc/moddep.lst:gptsync:
Binær fil /boot/grub/i386-pc/ldm.mod stemmer
/boot/grub/i386-pc/command.lst:gptsync: gptsync
Binær fil /boot/grub/i386-pc/gptsync.mod stemmer
Binær fil /boot/grub/themes/starfield/starfield.png stemmer

Offline

#25 2013-12-09 15:32:43

tattsan
Member
Registered: 2013-08-26
Posts: 37
Website

Re: [SOLVED] Grub says "symbol 'grub_real_boot_time' not found."

Hmm...
And with what options is grub-mkimage called ( from grub-install ) ?

grub-install --directory=/usr/lib/grub/i386-pc --target=i386-pc --boot-directory=/boot --recheck --debug /dev/sda   |& grep mkimage

Offline

Board footer

Powered by FluxBB