You are not logged in.

#1 2013-12-08 17:54:43

brizou
Member
Registered: 2013-04-13
Posts: 16

[solved]steam not launching

Hello,
I decided today to play with steam ( it has been about 6 month since the last time)

It doesn't want to connect to the internet.

clement-desktop% TEAM_RUNTIME=0 steam
Running Steam on arch  64-bit
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(1363394289_client)
Installing breakpad exception handler for appid(steam)/version(1363394289_client)
unlinked 0 orphaned pipes
Installing breakpad exception handler for appid(steam)/version(1363394289_client)
Fontconfig error: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 70: non-double matrix element
Fontconfig error: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 70: non-double matrix element
Fontconfig warning: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 78: saw unknown, expected number
[1208/185400:ERROR:object_proxy.cc(239)] Failed to call method: org.freedesktop.systemd1.LoadFailed: Unit dbus-org.freedesktop.NetworkManager.service failed to load: No such file or directory.
[1208/185400:WARNING:proxy_service.cc(646)] PAC support disabled because there is no system implementation
Installing breakpad exception handler for appid(steam)/version(1363394289_client)
Installing breakpad exception handler for appid(steam)/version(1363394289_client)
Installing breakpad exception handler for appid(steam)/version(1363394289_client)
Generating new string page texture 2: 48x256, total string texture memory is 49,15 KB
Generating new string page texture 3: 256x256, total string texture memory is 311,30 KB
Installing breakpad exception handler for appid(steam)/version(1363394289_client)
Installing breakpad exception handler for appid(steam)/version(1363394289_client)
Installing breakpad exception handler for appid(steam)/version(1363394289_client)
roaming config store loaded successfully - 386 bytes.
migrating temporary roaming config store
Adding license for package 0
Adding license for package 13408
Adding license for package 16589
Adding license for package 35562
Adding license for package 35569
Generating new string page texture 4: 128x256, total string texture memory is 442,37 KB
Generating new string page texture 5: 512x256, total string texture memory is 966,66 KB
Generating new string page texture 6: 24x256, total string texture memory is 991,23 KB

(steam:3179): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.

(steam:3179): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.

(steam:3179): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.

(steam:3179): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.

(steam:3179): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.

(steam:3179): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.

(steam:3179): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.

(steam:3179): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.

(steam:3179): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.

(steam:3179): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.

(steam:3179): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.

(steam:3179): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.

(steam:3179): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.

(steam:3179): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.
unlinked 2 orphaned pipes
CAsyncIOManager: 0 threads terminating.  0 reads, 0 writes, 0 deferrals.
CAsyncIOManager: 139492 single object sleeps, 0 multi object sleeps
CAsyncIOManager: 0 single object alertable sleeps, 1 multi object alertable sleeps
[2013-12-08 18:54:00] Startup
[2013-12-08 18:54:00] Verifying installation...
[2013-12-08 18:54:00] Verification complete
Shutting down. . .
[2013-12-08 18:54:20] Shutdown

Anybody have any idea what's going on ?

Thank you

Last edited by brizou (2013-12-10 17:36:15)

Offline

#2 2013-12-08 19:15:32

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 5,126

Re: [solved]steam not launching

Yeah, "TEAM_RUNTIME=0" doesn't do anything.

Offline

#3 2013-12-08 20:08:58

brizou
Member
Registered: 2013-04-13
Posts: 16

Re: [solved]steam not launching

ok what an idiot.

I still had a problem and needed to do a steam --reset
I now have that

[2013-12-08 21:13:17] BVerifyInstalledFiles: ubuntu12_32/steam-runtime.tar.xz.part0 is -1 bytes, expected 52428800
[2013-12-08 21:13:17] BVerifyInstalledFiles: ubuntu12_32/steam-runtime.tar.xz.part1 is -1 bytes, expected 45119140
[2013-12-08 21:13:17] BVerifyInstalledFiles: ubuntu12_32/steamclient.so is -1 bytes, expected 16429950
[2013-12-08 21:13:17] BVerifyInstalleInstalling breakpad exception handler for appid(steam)/version(1386125885_client)
Installing breakpad exception handler for appid(steam)/version(1386125885_client)
dFiles: ubuntu12_32/steamservice.so is -1 bytes, expected 3813653
[2013-12-08 21:13:17] BVerifyInstalledFiles: ubuntu12_32/steamui.so is -1 bytes, expected 22240769
[2013-12-08 21:13:17] BVerifyInstalledFiles: ubuntu12_32/vgui2_s.so is -1 bytes, expected 922680
[2013-12-08 21:13:17] BVerifyInstalledFiles: bad directory ubuntu12_64/
[2013-12-08 21:13:17] BVerifyInstalledFiles: ubuntu12_64/gameoverlayrenderer.so is -1 bytes, expected 202365
[2013-12-08 21:13:17] Verification complete
[2013-12-08 21:13:17] Downloading Update...
[2013-12-08 21:13:17] Checking for available update...
[2013-12-08 21:13:18] Download Complete.
[2013-12-08 21:13:18] uninstalled manifest found in /home/clement/.local/share/Steam/package/steam_client_ubuntu12 (1).
[2013-12-08 21:13:18] Extracting package...
[2013-12-08 21:13:21] Installing update...
[2013-12-08 21:13:22] Cleaning up...
[2013-12-08 21:13:22] Update complete, launching...
[2013-12-08 21:13:22] Shutdown
Restarting Steam by request...
Running Steam on arch  64-bit
STEAM_RUNTIME is disabled by the user
Installing breakpad exception handler for appid(steam)/version(1386125885_client)
Installing breakpad exception handler for appid(steam)/version(1386125885_client)
unlinked 0 orphaned pipes
Gtk-Message: Failed to load module "canberra-gtk-module"
Installing breakpad exception handler for appid(steam)/version(1386125885_client)
[1208/211322:ERROR:object_proxy.cc(239)] Failed to call method: org.freedesktop.systemd1.LoadFailed: Unit dbus-org.freedesktop.NetworkManager.service failed to load: No such file or directory.
[1208/211322:WARNING:proxy_service.cc(958)] PAC support disabled because there is no system implementation
/home/buildbot/buildslave_steam/steam_rel_client_ubuntu12_linux/build/src/steamUI/../common/steam/client_api.cpp (298) : Assertion Failed: ClientAPI_InitGlobalInstance: InternalAPI_Init_Internal failed, most likely because you are missing a 32-bit dependency of steamclient.so (the Steam client is a 32-bit app).

Assert( Assertion Failed: ClientAPI_InitGlobalInstance: InternalAPI_Init_Internal failed, most likely because you are missing a 32-bit dependency of steamclient.so (the Steam client is a 32-bit app).
 ):/home/buildbot/buildslave_steam/steam_rel_client_ubuntu12_linux/build/src/steamUI/../common/steam/client_api.cpp:298

Installing breakpad exception handler for appid(steam)/version(1386125885_client)
Uploading dump (out-of-process) [proxy '']
/tmp/dumps/assert_20131208211322_5.dmp
/home/buildbot/buildslave_steam/steam_rel_client_ubuntu12_linux/build/src/steamUI/SteamStartup.cpp (687) : Assertion Failed: ! "There was a problem with your Steam installation.\n" "Please reinstall steam.\n"
unlinked 2 orphaned pipes
CAsyncIOManager: 0 threads terminating.  0 reads, 0 writes, 0 deferrals.
CAsyncIOManager: 51 single object sleeps, 0 multi object sleeps
CAsyncIOManager: 0 single object alertable sleeps, 1 multi object alertable sleeps
[2013-12-08 21:13:22] Startup - updater built Dec  3 2013 18:36:06
[2013-12-08 21:13:22] Verifying installation...
[2013-12-08 21:13:22] Verification complete
Shutting down. . .
[2013-12-08 21:13:22] Shutdown

The thing is, I don't use networkmanager, I use netctl (networkmanager delay my nfs mount)
Thank you very much,

Last edited by brizou (2013-12-08 20:09:25)

Offline

#4 2013-12-08 20:56:49

haagch
Member
Registered: 2013-08-17
Posts: 207

Re: [solved]steam not launching

Well, just guessing, but this looks like an error:

Assert( Assertion Failed: ClientAPI_InitGlobalInstance: InternalAPI_Init_Internal failed, most likely because you are missing a 32-bit dependency of steamclient.so (the Steam client is a 32-bit app).
):/home/buildbot/buildslave_steam/steam_rel_client_ubuntu12_linux/build/src/steamUI/../common/steam/client_api.cpp:298

steamclient.so is for me
~/.local/share/Steam/linux32/steamclient.so
~/.local/share/Steam/linux64/steamclient.so
~/.local/share/Steam/ubuntu12_32/steamclient.so

Try "ldd ~/.local/share/Steam/linux32/steamclient.so" to see whether there is a library missing steam is linked against.

Offline

#5 2013-12-08 21:06:50

brizou
Member
Registered: 2013-04-13
Posts: 16

Re: [solved]steam not launching

thank you for your reply, that return that

ldd ~/.local/share/Steam/linux32/steamclient.so 
	linux-gate.so.1 (0xf76fd000)
	librt.so.1 => /usr/lib32/librt.so.1 (0xf66e1000)
	libm.so.6 => /usr/lib32/libm.so.6 (0xf669b000)
	libdl.so.2 => /usr/lib32/libdl.so.2 (0xf6696000)
	libstdc++.so.6 => /usr/lib32/libstdc++.so.6 (0xf65ad000)
	libpthread.so.0 => /usr/lib32/libpthread.so.0 (0xf6590000)
	/usr/lib/ld-linux.so.2 (0xf76fe000)
	libc.so.6 => /usr/lib32/libc.so.6 (0xf63e1000)
	libgcc_s.so.1 => /usr/lib32/libgcc_s.so.1 (0xf63c7000)

problem with ld-linux.so ?

Last edited by brizou (2013-12-08 21:07:44)

Offline

#6 2013-12-09 07:40:19

haagch
Member
Registered: 2013-08-17
Posts: 207

Re: [solved]steam not launching

No, that's fine. It'll literally say "not found" if one is not found. That doesn't seem to be a problem.

Have you tried just removing (or moving somewhere else) the whole ~/local/share/Steam directory and starting new?

Offline

#7 2013-12-09 07:56:03

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 5,126

Re: [solved]steam not launching

brizou, run that on ~/.local/share/Steam/ubuntu12_32/steamclient.so, I'll bet it's 32-bit NetworkManager libs that are missing.

Offline

#8 2013-12-09 12:26:57

brizou
Member
Registered: 2013-04-13
Posts: 16

Re: [solved]steam not launching

so i did

clement-desktop% ldd ~/.local/share/Steam/ubuntu12_32/steamclient.so
	linux-gate.so.1 (0xf7754000)
	libtier0_s.so => not found
	libvstdlib_s.so => not found
	librt.so.1 => /usr/lib32/librt.so.1 (0xf6768000)
	libX11.so.6 => /usr/lib32/libX11.so.6 (0xf6631000)
	libusb-1.0.so.0 => /usr/lib32/libusb-1.0.so.0 (0xf6618000)
	libopenal.so.1 => /usr/lib32/libopenal.so.1 (0xf65c4000)
	libpulse.so.0 => /usr/lib32/libpulse.so.0 (0xf6573000)
	libgobject-2.0.so.0 => /usr/lib32/libgobject-2.0.so.0 (0xf6522000)
	libglib-2.0.so.0 => /usr/lib32/libglib-2.0.so.0 (0xf641e000)
	libdbus-glib-1.so.2 => /usr/lib32/libdbus-glib-1.so.2 (0xf63f7000)
	libnm-glib.so.4 => not found
	libnm-util.so.2 => not found
	libudev.so.0 => not found
	libm.so.6 => /usr/lib32/libm.so.6 (0xf63b1000)
	libdl.so.2 => /usr/lib32/libdl.so.2 (0xf63ab000)
	libstdc++.so.6 => /usr/lib32/libstdc++.so.6 (0xf62c2000)
	libpthread.so.0 => /usr/lib32/libpthread.so.0 (0xf62a6000)
	/usr/lib/ld-linux.so.2 (0xf7755000)
	libc.so.6 => /usr/lib32/libc.so.6 (0xf60f7000)
	libxcb.so.1 => /usr/lib32/libxcb.so.1 (0xf60d5000)
	libudev.so.1 => /usr/lib32/libudev.so.1 (0xf60c1000)
	libjson-c.so.2 => /usr/lib32/libjson-c.so.2 (0xf60b6000)
	libpulsecommon-4.0.so => /usr/lib32/pulseaudio/libpulsecommon-4.0.so (0xf6042000)
	libdbus-1.so.3 => /usr/lib32/libdbus-1.so.3 (0xf5ff6000)
	libpcre.so.1 => /usr/lib32/libpcre.so.1 (0xf5f89000)
	libffi.so.6 => /usr/lib32/libffi.so.6 (0xf5f80000)
	libgio-2.0.so.0 => /usr/lib32/libgio-2.0.so.0 (0xf5e11000)
	libgcc_s.so.1 => /usr/lib32/libgcc_s.so.1 (0xf5df7000)
	libXau.so.6 => /usr/lib32/libXau.so.6 (0xf5df3000)
	libXdmcp.so.6 => /usr/lib32/libXdmcp.so.6 (0xf5dec000)
	libsndfile.so.1 => /usr/lib32/libsndfile.so.1 (0xf5d77000)
	libasyncns.so.0 => /usr/lib32/libasyncns.so.0 (0xf5d70000)
	libgmodule-2.0.so.0 => /usr/lib32/libgmodule-2.0.so.0 (0xf5d6b000)
	libz.so.1 => /usr/lib32/libz.so.1 (0xf5d54000)
	libresolv.so.2 => /usr/lib32/libresolv.so.2 (0xf5d3c000)
	libFLAC.so.8 => /usr/lib32/libFLAC.so.8 (0xf5d06000)
	libvorbisenc.so.2 => /usr/lib32/libvorbisenc.so.2 (0xf5b8f000)
	libvorbis.so.0 => /usr/lib32/libvorbis.so.0 (0xf5b62000)
	libogg.so.0 => /usr/lib32/libogg.so.0 (0xf5b5a000)
	libnsl.so.1 => /usr/lib32/libnsl.so.1 (0xf5b40000)

Offline

#9 2013-12-09 16:50:47

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 5,126

Re: [solved]steam not launching

yep, libnm-glib.so.4 and libnm-util.so.2 are 32 bit NetworkManager libs. libudev.so.0 is more of a problem, but the common (and very bad) solution is to symlink it to libudev.so.1.

Offline

#10 2013-12-09 19:59:25

brizou
Member
Registered: 2013-04-13
Posts: 16

Re: [solved]steam not launching

and how how should I do that, I'm not very at ease with ln -s commands

Offline

#11 2013-12-10 11:59:23

POINTS
Member
Registered: 2013-11-29
Posts: 15

Re: [solved]steam not launching

brizou wrote:

and how how should I do that, I'm not very at ease with ln -s commands

You can install the package: https://aur.archlinux.org/packages/lib32-libudev.so.0/. It basically creates this symlink for you. smile

Take a look at https://wiki.archlinux.org/index.php/St … ve_runtime if you haven't already. A good way to find any missing runtimes is with:

cd ~/.local/share/Steam/ubuntu12_32
LD_LIBRARY_PATH=".:${LD_LIBRARY_PATH}" ldd $(file *|sed '/ELF/!d;s/:.*//g')|grep 'not found'|sort|uniq

Offline

#12 2013-12-10 14:10:34

brizou
Member
Registered: 2013-04-13
Posts: 16

Re: [solved]steam not launching

ok so I did the last command
clement-desktop% LD_LIBRARY_PATH=".:${LD_LIBRARY_PATH}" ldd $(file *|sed '/ELF/!d;s/:.*//g')|grep 'not found'|sort|uniq
    libnm-glib.so.4 => not found
    libnm-util.so.2 => not found

The thing is I don't find those on aur

Offline

#13 2013-12-10 17:17:06

POINTS
Member
Registered: 2013-11-29
Posts: 15

Re: [solved]steam not launching

The could be the 32-bit version of network mananager. Do you have https://aur.archlinux.org/packages/lib3 … rkmanager/ installed? You'll also need to start in system startup to us it in Steam with this command 'systemctl enable NetworkManager'.

I know Scimmia mentioned this as well and you may not want to install it since you said it slows your startup. Steam might run without it though. I think it will just make the "Network Settings" blank in Steam.

Offline

#14 2013-12-10 17:25:25

brizou
Member
Registered: 2013-04-13
Posts: 16

Re: [solved]steam not launching

The thing is if I do a "systemctl enable networkmanager" it will takeover netctl. Networkmanager only bootup after I log in and my nfs share don't mount instantly, that does mess up a lot of my config

Nevermind, I will forget steam. That's too bad you have to use networkmanager for it to work...

Last edited by brizou (2013-12-10 17:26:33)

Offline

#15 2013-12-10 17:35:57

brizou
Member
Registered: 2013-04-13
Posts: 16

Re: [solved]steam not launching

Ok I didn't do a systemctl enable networkmanager and it apparently works, I see the steam store.

thank you very much

Offline

#16 2013-12-10 18:18:44

brizou
Member
Registered: 2013-04-13
Posts: 16

Re: [solved]steam not launching

itś weird some games work,
I have one however which doesn't
in my console it says that
./gamedevtycoon-bin: error while loading shared libraries: libudev.so.0: wrong ELF class: ELFCLASS32
Game removed: AppID 239820 "Game Dev Tycoon", ProcID 2758
Focused window is now 0, 0

lib32-libudev.so.0 is installed, weird...

Offline

#17 2013-12-10 18:38:31

POINTS
Member
Registered: 2013-11-29
Posts: 15

Re: [solved]steam not launching

It looks like Game Dev Tycoon is looking for the 64-bit version of libudev. Like the 32-bit version symbol link fix, the Steam wiki https://wiki.archlinux.org/index.php/St … Dev_Tycoon suggests creating this symbolic link:

 ln -s /lib/libudev.so /lib/libudev.so.0

Offline

#18 2013-12-10 19:39:14

brizou
Member
Registered: 2013-04-13
Posts: 16

Re: [solved]steam not launching

Perfect, thank you VERY much. all is good

Offline

Board footer

Powered by FluxBB