You are not logged in.

#1 2005-12-28 23:11:32

From: Ann Arbor
Registered: 2005-12-28
Posts: 125

Udev, usb & palm

Hi everyone. Thanx very much for listening in to my first post on the board! I hesitated between newbie corner or hardware issues... After much time spent reading and playing with this I decided to draw upon the collective pool of knowledge. 

I want to use udev to sync my palm pilot zire 71.  The docs for Jpilot and Kpilot were no help.

I am running a 2 days old arch install (I really am a newbie) and I'm having a go at this for the first time.  It's from the 0.7 cd and I did a pacman -Syu on it and now it tells me I run the 0.7.1 noodle.

If I can get that to work I'll put together a little how-to for the wiki

Here is what I have done thus far:

1- Plug Palm Pilot + press sync button

2- as root: lsusb -v | more
This is the part of the output that interested me:

idProduct          0x0060 Palm Tungsten T / Zire 71
  bcdDevice            1.00
  iManufacturer           1 Palm, Inc.
  iProduct                2 Palm Handheld
  iSerial                 5 PalmSN12345678

Serial is: PalmSN12345678  (sounds a bit goofy but hey! what can I say?)

3- Create group "pilot" and add user "hotsauce" to it. (I used groupadd and then edited the file /etc/group to add hotsauce to it. Is there an easier/better way to do it?)

4- edit /etc/udev/rules.d/udev.rules and add the following:


5- udevstart (I know none about udev, does it start on boot-up or do I need to add it to daemons in rc.conf or something? I'm not sure I get that part...)

6- Open Kpilot, Jpilot or whatever pilot app

7- Hit sync button on palm pilot or crate

8- Hit sync button in the program (the apps are looking for /dev/pilot so I think my udev will have created the device already called pilot. It should be alright...)

9- Ta-Dam! Well not really 'cause it didn't work for me!

Here's where you people come in. What am I doing wrong?

Thanx very much for your time, I appreciate


Device /dev/pilot is actually being created automatically when I press the hotsync button, so the udev mod must not all be wrong. Here are the error messages I still get:

 pi_bind Invalid argument
Check your serial port and settings
Exiting with status SYNC_ERROR_BIND

I noticed that the /dev/pilot is actually a link to /dev/tts/USB1 when KPilot told me it couldn't read/write it, I changed permissions on both the link and the target but it still gave me that error:

17:36:34 Starting the KPilot daemon ...
17:36:35 Daemon status is `not running'
17:36:36 Trying to open device /dev/pilot...
17:36:36 Could not open device: /dev/pilot (will retry)

I have also tried what another user here did and it didn't work either...:

BUS="usb", SYSFS{serial}="PalmSN12345678", NAME="pilot", MODE="0666", GROUP="pilot", OWNER="hotsauce"

here's where I took some of my info (I have not linked the docs for the programs as they weren't helpfull with udev): … with-udev/ … =palm+udev


#2 2005-12-29 19:00:03

From: Oxford, UK
Registered: 2005-11-03
Posts: 674

Re: Udev, usb & palm

hotsauce wrote:

3- Create group "pilot" and add user "hotsauce" to it. (I used groupadd and then edited the file /etc/group to add hotsauce to it. Is there an easier/better way to do it?)

gpasswd -a [user] [group]

As for the rest of your problem... sadly I can't be of much use, since I'm not very familiar with udev's workings yet.

This section of the udev page in the wiki may be of some use... or possibly not! Worth a look just in case (I don't know if you're aware of our fairly comprehensive wiki yet...)

Don't lose heart if you don't get many replies to this thread; udev's pretty new for a lot of us, and not everyone has a pda. But if you wait, I'm sure one of our more experienced members will help you out.

Welcome to Arch smile


.oO Komodo Dave Oo.


Board footer

Powered by FluxBB