You are not logged in.

#1 2013-12-27 07:54:48

gnusouth
Member
From: Sydney, Australia
Registered: 2013-12-27
Posts: 4
Website

[SOLVED] Curl 7.34.0-1 seems to break [haskell-core]

I suspect that the new version of curl (7.34.0-1) has broken pacman's ability to communicate with unofficial repos (at least on my system).

I was getting very strange errors related to the [haskell-core] repo.

$ sudo pacman -Syu
:: Synchronising package databases...
 core is up to date
error: failed retrieving file 'haskell-core.db' from xsounds.org : Failed to connect to xsounds.org port 80: Network is unreachable
error: failed to update haskell-core (download library error)
 extra is up to date
 community is up to date
:: Starting full system upgrade...
 there is nothing to do

I traced the problem to the new version of curl (7.34.0-1) and was able to get [haskell-core] working by downgrading curl to version 7.33.0-3

$ sudo pacman -Syu
:: Synchronising package databases...
 core is up to date
 haskell-core is up to date
 extra is up to date
 community is up to date
:: Starting full system upgrade...
warning: curl: ignoring package upgrade (7.33.0-3 => 7.34.0-1)
 there is nothing to do

Additional info:

  • I've temporarily added curl to the IgnorePkg variable in /etc/pacman.conf

  • I'm using this mirror: http://xsounds.org/~haskell/core/$arch (the other one seems to be really dead?)

  • I use aura to manage AUR packages

Has anybody else had the same problem? Any ideas as to what's going on? Should I file a bug report against the curl package?

Last edited by gnusouth (2014-01-19 01:13:15)

Offline

#2 2013-12-27 13:43:28

falconindy
Developer
From: New York, USA
Registered: 2009-10-22
Posts: 4,092
Website

Re: [SOLVED] Curl 7.34.0-1 seems to break [haskell-core]

Seems similar to http://sourceforge.net/p/curl/bugs/1315/

Your preferred resolver is ipv6, but you don't have any ipv6 connectivity.

Offline

#3 2014-01-05 02:02:38

gnusouth
Member
From: Sydney, Australia
Registered: 2013-12-27
Posts: 4
Website

Re: [SOLVED] Curl 7.34.0-1 seems to break [haskell-core]

Yep, preventing the kernel from loading the IPv6 module fixes it.

For anyone else having this problem, add "ipv6.disable=1" to your kernel options. I use GRUB, so I modified /etc/default/grub

GRUB_CMDLINE_LINUX_DEFAULT="[other stuff] ipv6.disable=1"

NB:
* Ignoring IPv6 in Network Manager didn't help
* I also recompiled pacman and forced IPv4. This worked great, and I'm tempted to submit a patch which adds a "PreferredRoute" to pacman.conf
   Or maybe noobs like me should just learn to disable IPv6 when they're not using it? tongue

Offline

#4 2014-05-24 11:03:15

fluxboxer
Member
Registered: 2012-12-02
Posts: 42

Re: [SOLVED] Curl 7.34.0-1 seems to break [haskell-core]

Thanks for the instruction, but after editing grub with

GRUB_CMDLINE_LINUX_DEFAULT="[other stuff] ipv6.disable=1"

This one is needed also:

# grub-mkconfig -o /boot/grub/grub.cfg

PS. No, that doesn't work either.

Last edited by fluxboxer (2014-05-24 15:58:35)

Offline

#5 2014-05-25 00:55:34

gnusouth
Member
From: Sydney, Australia
Registered: 2013-12-27
Posts: 4
Website

Re: [SOLVED] Curl 7.34.0-1 seems to break [haskell-core]

Hi fluxboxer,

I also ran into connection troubles again recently. I managed to fix them by blacklisting my network card in /etc/sysctl.d/40-ipv6.conf as described here:

https://wiki.archlinux.org/index.php/IPv6#Disable_IPv6

Offline

#6 2014-05-25 11:04:11

fluxboxer
Member
Registered: 2012-12-02
Posts: 42

Re: [SOLVED] Curl 7.34.0-1 seems to break [haskell-core]

Thank you gnusouth, but since following your previous step and disabling the whole IPv6 stack doesn't work, it seems the issue is somewhere else in my system. Strangely sometimes it updates and other times it doesn't. I'll go back to the other methods to install pandoc. Thanks anyway.

Offline

Board footer

Powered by FluxBB