You are not logged in.

#1 2013-12-29 12:22:35

Harey
Member
From: Bavaria, Germany
Registered: 2007-03-24
Posts: 292

[Solved]Xorg-server and nvidia binary driver don't work

See topic. When updating to xf86-input-evdev-2.8.2-2  xf86-input-joystick-1.6.2-3  xf86-input-keyboard-1.8.0-2  xf86-input-mouse-1.9.0-2 and xorg-server-1.15.0-1 X won't start and 'systemctl status kdm.service' states that the X server has died. According to Phoronix this should not happen.

Harvey

Last edited by Harey (2014-01-14 11:06:53)


Linux is like a wigwam: No Gates, no Windows and an Apache inside

Offline

#2 2013-12-29 12:27:40

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 13,699
Website

Re: [Solved]Xorg-server and nvidia binary driver don't work

... error messages?  logs?  something?


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

#3 2013-12-29 12:55:38

cju
Member
Registered: 2013-06-23
Posts: 194

Re: [Solved]Xorg-server and nvidia binary driver don't work

Including `nvidia` in your initramfs could do the trick… – perhaps.

Offline

#4 2013-12-29 13:10:43

Gusar
Member
Registered: 2009-08-25
Posts: 3,431

Re: [Solved]Xorg-server and nvidia binary driver don't work

The latest nvidia driver (331.20) does not support xorg-server-1.15. Version 319.76 does: x86, x86_64. The 304xx and 173xx legacy releases support xorg-server-1.15 too.

Offline

#5 2013-12-29 13:15:37

Harey
Member
From: Bavaria, Germany
Registered: 2007-03-24
Posts: 292

Re: [Solved]Xorg-server and nvidia binary driver don't work

Well, Xorg.0.log states there is an ABI mismatch:

[    37.122] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[    37.151] (II) Module nvidia: vendor="NVIDIA Corporation"
[    37.151]    compiled for 4.0.2, module version = 1.0.0
[    37.151]    Module class: X.Org Video Driver
[    37.151] ================ WARNING WARNING WARNING WARNING ================
[    37.151] This server has a video driver ABI version of 15.0 that is not
supported by this NVIDIA driver.  Please check
http://www.nvidia.com/ for driver updates or downgrade to an X
server with a supported driver ABI.
[    37.151] =================================================================
[    37.151] (EE) NVIDIA: Use the -ignoreABI option to override this check.
[    37.151] (II) UnloadModule: "nvidia"
[    37.151] (II) Unloading nvidia
[    37.151] (EE) Failed to load module "nvidia" (module requirement mismatch, 0)

But the phoronix guys tell us this should not happen. Unfortunately they do not mention the driver version number...

Harvey


Linux is like a wigwam: No Gates, no Windows and an Apache inside

Offline

#6 2013-12-29 15:30:47

bubbathevtog
Member
Registered: 2013-04-12
Posts: 25

Re: [Solved]Xorg-server and nvidia binary driver don't work

I know that there is a switch that you can add to nvidia to "-ignoreABI" where it won't do the check for working with specific xorg versions, but damnit I'm forget where to append it.

edit: oh, hey look at Harey's org log, it says it right there. Does anyone know where to append this?

Offline

#7 2013-12-29 15:38:02

karol
Archivist
Registered: 2009-05-06
Posts: 25,427

Re: [Solved]Xorg-server and nvidia binary driver don't work

Offline

#8 2013-12-29 15:55:21

Harey
Member
From: Bavaria, Germany
Registered: 2007-03-24
Posts: 292

Re: [Solved]Xorg-server and nvidia binary driver don't work

The ABI check is there for a purpose:

[    38.018] Loading extension NV-GLX
[    38.027] (EE) 
[    38.027] (EE) Backtrace:
[    38.029] (EE) 0: /usr/bin/X (xorg_backtrace+0x48) [0x5834c8]
[    38.029] (EE) 1: /usr/bin/X (0x400000+0x1871a9) [0x5871a9]
[    38.029] (EE) 2: /usr/lib/libpthread.so.0 (0x7ff70edbf000+0xf870) [0x7ff70edce870]
[    38.029] (EE) 3: /usr/lib/xorg/modules/drivers/nvidia_drv.so (0x7ff708c51000+0x4e427f) [0x7ff70913527f]
[    38.029] (EE) 4: /usr/lib/xorg/modules/drivers/nvidia_drv.so (0x7ff708c51000+0x4eb501) [0x7ff70913c501]
[    38.029] (EE) 5: /usr/bin/X (AddScreen+0x71) [0x435c81]
[    38.029] (EE) 6: /usr/bin/X (InitOutput+0x3df) [0x4769df]
[    38.029] (EE) 7: /usr/bin/X (0x400000+0x3961b) [0x43961b]
[    38.029] (EE) 8: /usr/lib/libc.so.6 (__libc_start_main+0xf5) [0x7ff70dc35b05]
[    38.029] (EE) 9: /usr/bin/X (0x400000+0x24dae) [0x424dae]
[    38.029] (EE) 
[    38.029] (EE) Segmentation fault at address 0x18
[    38.029] (EE) 
Fatal server error:
[    38.029] (EE) Caught signal 11 (Segmentation fault). Server aborting

Seems we have to wait for nvidia to include xorg-server 1.15 into their driver sad

Harvey


Linux is like a wigwam: No Gates, no Windows and an Apache inside

Offline

#9 2013-12-29 15:56:40

karol
Archivist
Registered: 2009-05-06
Posts: 25,427

Re: [Solved]Xorg-server and nvidia binary driver don't work

Downgrade nvidia or try nouveau.

Offline

#10 2013-12-29 16:33:10

cju
Member
Registered: 2013-06-23
Posts: 194

Re: [Solved]Xorg-server and nvidia binary driver don't work

Does that mean that xorg 1.15 won't hit extra until nvidia finally supports it or how does Arch deal w/ situations like these? hmm

Offline

#11 2013-12-29 16:40:13

karol
Archivist
Registered: 2009-05-06
Posts: 25,427

Re: [Solved]Xorg-server and nvidia binary driver don't work

Often Arch follows upstream and goes ahead with e.g. the new X server, because devs say it's not their problem if a closed source package can't keep up.

Offline

#12 2013-12-29 16:52:57

cju
Member
Registered: 2013-06-23
Posts: 194

Re: [Solved]Xorg-server and nvidia binary driver don't work

I totally get your point, but in this case, I guess this would affect at least a quarter(?) of all users; so is there some sort of written policy for issues like this or is it just up to the dev's assessments (which would mean in your described case no X for a large number of users for an unknown period of time)?

Of course, you can say "then switch over to nouveau", but it isn't a secret that many NVIDIA cards simply don't run or at least run quite poorly w/ nouveau… sad

Edit: I'm not even sure if opening a bug report then would be the right measure for this case.

Last edited by cju (2013-12-29 16:58:12)

Offline

#13 2013-12-29 16:55:05

Harey
Member
From: Bavaria, Germany
Registered: 2007-03-24
Posts: 292

Re: [Solved]Xorg-server and nvidia binary driver don't work

karol wrote:

Downgrade nvidia or try nouveau.

downgrading is no option as the driver mentioned by Gusar (319.76) is not available for Arch Linux. As a workaround I am using nouveau for now, but 3D performance is poor and my favourite game is not running anymore through wine although I installed lib32-nouveau-dri sad

Harvey


Linux is like a wigwam: No Gates, no Windows and an Apache inside

Offline

#14 2013-12-29 17:27:10

Gusar
Member
Registered: 2009-08-25
Posts: 3,431

Re: [Solved]Xorg-server and nvidia binary driver don't work

Unless your card is really really new, it's supported by the 304xx branch (the point of this branch is Geforce 6/7 support, but it can handle all cards that were available when the branch was created). And Arch does package 304xx. So it can serve as a simple workaround for many users.

Then there's the not quite so simple but still not hard method of rolling your own 319.76 packages.

Offline

#15 2013-12-29 17:29:46

cju
Member
Registered: 2013-06-23
Posts: 194

Re: [Solved]Xorg-server and nvidia binary driver don't work

Got exactly the same error (ABI doesn't match etc.) on a vbox(!), so perhaps this isn't just nvidias fault? Or is it even NVIDIA's and Oracle's fault?

Btw.: Anyone testet yet on an ATI w/ fglrx?

Offline

#16 2013-12-29 17:39:04

karol
Archivist
Registered: 2009-05-06
Posts: 25,427

Re: [Solved]Xorg-server and nvidia binary driver don't work

Harey wrote:
karol wrote:

Downgrade nvidia or try nouveau.

downgrading is no option as the driver mentioned by Gusar (319.76) is not available for Arch Linux.

https://aur.archlinux.org/packages.php?K=319

Maybe you can use A.R.M. to downgrade to previous X server version and wait. This may mean downgrading some other packages that depend on X server, but, if everything else fails, it is worth a try.

Offline

#17 2013-12-29 17:56:55

Harey
Member
From: Bavaria, Germany
Registered: 2007-03-24
Posts: 292

Re: [Solved]Xorg-server and nvidia binary driver don't work

This is 319.32, not 319.76. NVidia seems to have incorporated the xorg-server 1.15 support into a new incarnation of an older driver.

karol wrote:

Maybe you can use A.R.M. to downgrade to previous X server version and wait.

I'll stay with nouveau for now and hope for a fast solution from NVidia yikes Just kidding...

Harvey


Linux is like a wigwam: No Gates, no Windows and an Apache inside

Offline

#18 2013-12-29 18:05:04

karol
Archivist
Registered: 2009-05-06
Posts: 25,427

Re: [Solved]Xorg-server and nvidia binary driver don't work

Harey wrote:

This is 319.32, not 319.76.

I know.
Have you tried bumping the package version? That's another thing you can try.

Offline

#19 2013-12-30 11:49:46

Harey
Member
From: Bavaria, Germany
Registered: 2007-03-24
Posts: 292

Re: [Solved]Xorg-server and nvidia binary driver don't work

karol wrote:

Have you tried bumping the package version?

319.76 is not on the ftp server, so bumping the package version does not work. Sigh.
And with nouveau suspend does not work yikes

Harvey


Linux is like a wigwam: No Gates, no Windows and an Apache inside

Offline

#20 2013-12-30 12:04:28

Gusar
Member
Registered: 2009-08-25
Posts: 3,431

Re: [Solved]Xorg-server and nvidia binary driver don't work

Download it manually then. I gave you the links.

Offline

#21 2013-12-30 12:13:27

Harey
Member
From: Bavaria, Germany
Registered: 2007-03-24
Posts: 292

Re: [Solved]Xorg-server and nvidia binary driver don't work

Gusar wrote:

Download it manually then. I gave you the links.

Of course I tried this as well. But since I am on X86_64 and there is no no-compat version guess where this led me... I downgraded to the 304xx-branch for now after verifying that my card is supported there. Nouveau is not working well with my card (A 8600GT, by the way). I'll stay there for the time being.

Thanks for all your help

Harvey


Linux is like a wigwam: No Gates, no Windows and an Apache inside

Offline

#22 2013-12-30 17:43:48

botika
Member
Registered: 2013-07-12
Posts: 34

Re: [Solved]Xorg-server and nvidia binary driver don't work

I downgrade to nvidia-304.17 and run perfect. My card is 560ti and use ck kernel.

Last edited by botika (2013-12-30 17:45:28)

Offline

#23 2013-12-30 19:28:10

infiniphunk
Member
Registered: 2012-08-06
Posts: 30

Re: [Solved]Xorg-server and nvidia binary driver don't work

Same problem here... after a couple of failed attempts at downgrading xorg-server (to many conflicting interdependancies) I gave up and removed the nvidia driver I had in there in favour of the nouveau driver. Now fan-control for my GPU doesn't work and my pc sounds like it's ready for take-off LOL
I might try later just going back to a previous version of the nividia driver that does support xorg-server 1.15 as stated above.

Offline

#24 2014-01-02 20:09:38

botika
Member
Registered: 2013-07-12
Posts: 34

Re: [Solved]Xorg-server and nvidia binary driver don't work

The nvidia driver 304 support xorg-server 1.15. Nvidia driver and do not give problems with fans, etc.

I don't understand your problem.  If works me with xorg-server 1.15 and nvidia 304.17.

Please if your problem has solved edit post to [solved].

Last edited by botika (2014-01-02 20:15:19)

Offline

#25 2014-01-02 21:46:05

clfarron4
Member
From: London, UK
Registered: 2013-06-28
Posts: 2,162
Website

Re: [Solved]Xorg-server and nvidia binary driver don't work

cju wrote:

Btw.: Anyone testet yet on an ATI w/ fglrx?

Dream on, we don't even have 1.14 support in the [stable] branch of AMD Catalyst. It's probably going to be another month before 1.15 support hits the AMD beta.


Claire is fine.
Problems? I have dysgraphia, so clear and concise please.
My public GPG key for package signing
My x86_64 package repository

Offline

Board footer

Powered by FluxBB