You are not logged in.

#1 2014-01-02 13:35:38

Registered: 2013-09-28
Posts: 36

[SOLVED] ALSA can't detect Intel ICH7 soundcard

I know that this issue is common in these days but I can't find any solution to my problem.
And the problem is:

$aplay -l
  aplay: device_list:268: no soundcards found...

Additional information:
Sound card: Intel 82801GB ICH7 - High Definition Audio Controller

$lsmod | grep snd
  snd_hda_intel          36904  1 
  snd_hda_codec         150305  1 snd_hda_intel
  snd_hwdep               6340  1 snd_hda_codec
  snd_pcm                77709  2 snd_hda_codec,snd_hda_intel
  snd_page_alloc          7242  2 snd_pcm,snd_hda_intel
  snd_timer              18726  1 snd_pcm
  snd                    59141  5 snd_hwdep,snd_timer,snd_pcm,snd_hda_codec,snd_hda_intel
  soundcore               5450  1 snd

$lspci -v | grep -A7 -i "audio"
  00:1b.0 Audio device: Intel Corporation NM10/ICH7 Family High Definition Audio Controller (rev 01)
        Subsystem: IBM Device 0345
        Flags: bus master, fast devsel, latency 0, IRQ 11
        Memory at d2400000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: <access denied>
        Kernel modules: snd_hda_intel

  00:1c.0 PCI bridge: Intel Corporation NM10/ICH7 Family PCI Express Port 1 (rev 01) (prog-if 00 [Normal decode])

$cat /proc/asound/cards 
  --- no soundcards ---

$groups user
  video audio users

$pacman -Q |egrep  'alsa|pulse'
 lib32-libpulse 4.0-6
 libcanberra-pulse 0.30-4
 libpulse 4.0-6 
 pulseaudio 4.0-6

$sudo systemctl status alsa-store -l
 alsa-store.service - Store Sound Card State
    Loaded: loaded (/usr/lib/systemd/system/alsa-store.service; static)
    Active: failed (Result: exit-code) since Thu 2014-01-02 14:31:04 CET; 2min 4s ago
   Process: 1103 ExecStart=/usr/bin/alsactl store (code=exited, status=19)
  Main PID: 1103 (code=exited, status=19)

 Jan 02 14:31:04 studio alsactl[1103]: /usr/bin/alsactl: save_state:1590: No soundcards found...
 Jan 02 14:31:04 studio systemd[1]: alsa-store.service: main process exited, code=exited, status=19/n/a
 Jan 02 14:31:04 studio systemd[1]: Failed to start Store Sound Card State.
 Jan 02 14:31:04 studio systemd[1]: Unit alsa-store.service entered failed state.

Solved by:

blacklist i82975x_edac

to /etc/modprobe.d/modprobe.conf

Last edited by Skitter (2014-01-03 09:09:08)


Board footer

Powered by FluxBB