You are not logged in.

#1 2014-01-03 11:21:16

Registered: 2014-01-03
Posts: 7

[SOLVED]vmware gallium renderer being used instead of intel

I switched from ubuntu to arch and noticed that firefox and chromium no longer rendered webgl content and instead of using mesa intel renderer its using some VMware gallium stuff.

I've downloaded all the mesa and intel packages and messed around a bit with setting a 20-intel.conf file in /etc/X11/xorg.conf.d but it doesnt seem to have an effect.

ubuntu chromium/firefox gpu page:

GL version 	3.0
GL_VENDOR 	Intel Open Source Technology Center
GL_RENDERER 	Mesa DRI Intel(R) Sandybridge Mobile
GL_VERSION 	3.0 Mesa 9.2.1

on arch:

GL version	2.1
GL_VENDOR	VMware, Inc.
GL_RENDERER	Gallium 0.4 on llvmpipe (LLVM 3.3, 128 bits)
GL_VERSION	2.1 Mesa 10.0.1

looking at /Xorg.0.log it seems like xorg is using the intel stuff

[  1803.773]    X.Org Video Driver: 14.1
[  1803.808] (II) Loading /usr/lib/xorg/modules/drivers/
[  1803.808]    Module class: X.Org Video Driver
[  1803.808]    ABI class: X.Org Video Driver, version 14.1
[  1803.808] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
[  1803.816] (II) intel(0): [DRI2]   DRI driver: i965

output of lshw -c video

       description: VGA compatible controller
       product: 2nd Generation Core Processor Family Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 09
       width: 64 bits
       clock: 33MHz
       capabilities: vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:48 memory:f5000000-f53fffff memory:e0000000-efffffff ioport:e000(size=64)

Last edited by ktfh (2014-01-03 12:07:32)


#2 2014-01-03 12:02:47

David Batson
Registered: 2011-10-13
Posts: 640

Re: [SOLVED]vmware gallium renderer being used instead of intel

Seems to be using the Mesa drivers here, but not acceleration (not sure if running Compiz [which I am] would be an issue).  Tried the following webGL content with success:

Adapter Description	Intel Open Source Technology Center -- Mesa DRI Intel(R) Sandybridge Mobile
Device ID	Mesa DRI Intel(R) Sandybridge Mobile
Driver Version	3.0 Mesa 10.0.1
GPU Accelerated Windows	0/1 Basic
Vendor ID	Intel Open Source Technology Center
WebGL Renderer	Intel Open Source Technology Center -- Mesa DRI Intel(R) Sandybridge Mobile
windowLayerManagerRemote	false
AzureCanvasBackend	cairo
AzureContentBackend	none
AzureFallbackCanvasBackend	none
AzureSkiaAccelerated	0
$ vainfo
libva info: VA-API version 0.34.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/dri/
libva info: Found init function __vaDriverInit_0_34
libva info: va_openDriver() returns 0
vainfo: VA-API version: 0.34 (libva 1.2.1)
vainfo: Driver version: Intel i965 driver - 1.2.2
vainfo: Supported profile and entrypoints
      VAProfileNone                   :	VAEntrypointVideoProc
      VAProfileMPEG2Simple            :	VAEntrypointVLD
      VAProfileMPEG2Main              :	VAEntrypointVLD
      VAProfileH264Main               :	VAEntrypointVLD
      VAProfileH264Main               :	VAEntrypointEncSlice
      VAProfileH264High               :	VAEntrypointVLD
      VAProfileH264High               :	VAEntrypointEncSlice
      VAProfileVC1Simple              :	VAEntrypointVLD
      VAProfileVC1Main                :	VAEntrypointVLD
      VAProfileVC1Advanced            :	VAEntrypointVLD
      VAProfileH264ConstrainedBaseline:	VAEntrypointVLD
      VAProfileH264ConstrainedBaseline:	VAEntrypointEncSlice
$ glxinfo
name of display: :0.0
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.4
client glx vendor string: Mesa Project and SGI
client glx version string: 1.4
GLX version: 1.4
GLX extensions:
    GLX_ARB_create_context, GLX_ARB_create_context_profile, 
    GLX_ARB_get_proc_address, GLX_ARB_multisample, 
    GLX_EXT_create_context_es2_profile, GLX_EXT_import_context, 
    GLX_EXT_texture_from_pixmap, GLX_EXT_visual_info, GLX_EXT_visual_rating, 
    GLX_INTEL_swap_event, GLX_MESA_copy_sub_buffer, 
    GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer, 
    GLX_MESA_swap_control, GLX_OML_swap_method, GLX_OML_sync_control, 
    GLX_SGIS_multisample, GLX_SGIX_fbconfig, GLX_SGIX_pbuffer, 
    GLX_SGIX_visual_select_group, GLX_SGI_make_current_read, 
    GLX_SGI_swap_control, GLX_SGI_video_sync
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Sandybridge Mobile 
OpenGL core profile version string: 3.1 (Core Profile) Mesa 10.0.1
OpenGL core profile shading language version string: 1.40
OpenGL core profile context flags: (none)
OpenGL version string: 3.0 Mesa 10.0.1
OpenGL shading language version string: 1.30
OpenGL context flags: (none)

EDIT: More info.

$ pacman -Ss intel | grep installed
extra/intel-dri 10.0.1-1 [installed]
extra/libva-intel-driver 1.2.2-1 [installed]
extra/xf86-video-intel 2.21.15-1 (xorg-drivers xorg) [installed]
$ pacman -Ss mesa | grep installed
extra/glu 9.0.0-2 [installed]
extra/intel-dri 10.0.1-1 [installed]
extra/mesa 10.0.1-1 [installed]
extra/mesa-demos 8.1.0-1 [installed]
extra/mesa-libgl 10.0.1-1 [installed]
multilib/lib32-mesa 10.0.1-1 [installed]
multilib/lib32-mesa-libgl 10.0.1-1 [installed]

Last edited by David Batson (2014-01-03 12:06:14)


#3 2014-01-03 12:06:55

Registered: 2014-01-03
Posts: 7

Re: [SOLVED]vmware gallium renderer being used instead of intel

i resolved this by adding my user to the video group and restarting x it was just a permission problem

usermod -a -G video sillyme


Board footer

Powered by FluxBB