You are not logged in.

#1 2014-01-04 03:50:41

Registered: 2012-08-30
Posts: 17

Eclipse-CDT Breakpoints.

I know this is a common problem. I've looked it up. I just can't get it to work. I will list off what I've done so far.

1) pacman -S eclipse eclipse-cdt
2)Built a Hello World C/C++ project. Program wouldn't build. It complained about make.
3)pacman -S make
4)pacman -S gdb
5)program would build and run now. Now I wanted to test breakpoints but they didn't work.
6) I tried rebooting and reinstalling eclipse
7) pacman -R eclipse eclipse-cdt
8) pacman -S eclipse eclipse-cdt
9) reboot
10) look online for solutions.
11) checked project properties for flags -O0 and -g3
12) checked windows->preferences for various stuff listed. The only thing noticeable is that under C/C++->Debug->Breakpoint Actions it's completely blank.
13) run->breakpoint types->C/C++ Breakpoints is selected
14) window->custom perspective->command groups availability->C/C++ tracepoints checked.

I don't know I tried quite a few things. Unlike other people I've read about with this problem I can't get any form of debugging working. It doesn't allow line-by-line, breakpoints or anything. I've tried a few other things but this is what I remember. Any suggestions? Thank you.


#2 2014-02-07 12:35:44

Registered: 2012-12-06
Posts: 38

Re: Eclipse-CDT Breakpoints.

What do you mean "get it to work"?
May be you should better to download zip from


Board footer

Powered by FluxBB