You are not logged in.

#1 2014-01-07 08:13:18

tsdh
Member
From: Germany
Registered: 2014-01-07
Posts: 42

[SOLVED] Disable Alt-Tab window switching in GNOME 3.10

Hi all,

I'm an emacs user, and so I reserve all Control and Alt bindings for that and use the Super key exclusively for window management.  So I've reworked the default GNOME3 keybindings in the gnome-control-center > Keyboard > Shortcuts.  Indeed, there was Alt-tab assigned, but I've disabled it.  It's definitively not there anymore.

However, Alt-Tab still switches windows!

I can recall that I had this issue some time ago (on Gentoo).  The problem is that this binding is defined elsewhere (for I think, the GNOME fallback mode/metacity???), too.  But I cannot remember where (it might be some xml file, or maybe some gconf setting,...).

Does anyone know where to look?

Last edited by tsdh (2014-01-07 10:07:35)

Offline

#2 2014-01-07 10:07:21

tsdh
Member
From: Germany
Registered: 2014-01-07
Posts: 42

Re: [SOLVED] Disable Alt-Tab window switching in GNOME 3.10

Ah, I've found it again.  You have to disable the alternate keybindings which are not exposed via the settings tool using the dconf-editor in org.gnome.desktop.wm.keybindings.

Offline

Board footer

Powered by FluxBB