You are not logged in.

#26 2014-01-28 11:36:50

honda
Member
Registered: 2014-01-27
Posts: 1

Re: XBMC Tearing since Nvidia update to 331.38

adr3nal1n wrote:

No need to downgrade packages,

Simply add the following to your /etc/X11/xorg.conf to prevent screen tearing with nvidia cards.

Section "Extensions"
   Option         "Composite" "Disable"
EndSection

Hope this helps.


Thanks! I've just re-upgraded my packages and am fully up to date. I then switched off Composite as you suggest and now it's all smooth and non teary again.

Offline

#27 2014-01-28 23:56:11

odin89
Member
Registered: 2011-09-23
Posts: 32

Re: XBMC Tearing since Nvidia update to 331.38

well i tried it too and i cant use cinnamon anymore when i disable composite. The Cinnamon Panel doesnt start with this option. Someone know how i can fix that?

Offline

#28 2014-01-29 02:03:41

marko2010
Member
Registered: 2010-04-17
Posts: 68

Re: XBMC Tearing since Nvidia update to 331.38

odin89 wrote:

well i tried it too and i cant use cinnamon anymore when i disable composite. The Cinnamon Panel doesnt start with this option.

I have a similar issue with Gnome Shell. Once the "Option  "Composite" "Disable"" fix applied and GDM restarted Gnome Shell will no longer start up.

I like the simplicity of the fix, but think it disables some popular desktop environments.

Offline

#29 2014-01-29 07:58:04

odin89
Member
Registered: 2011-09-23
Posts: 32

Re: XBMC Tearing since Nvidia update to 331.38

ok so i dont need to test it with gnome when i come home. Cinnamon with software rendering doesnt work too.
The problem is the repo i posted got updated so i cant downgrade again sad

Offline

#30 2014-01-29 10:17:58

pho
Member
From: Germany
Registered: 2010-07-23
Posts: 12

Re: XBMC Tearing since Nvidia update to 331.38

It's stated in the XBMC-Wiki very clearly:
http://wiki.xbmc.org/index.php?title=XB … _with_XBMC - Compiz is not compatible with XBMC

To downgrade your Packages manually you can do (if you still have the files)
pacman -U /var/cache/pacman/pkg/[package].pkg.tar.xz

Last edited by pho (2014-01-29 10:30:02)

Offline

#31 2014-01-29 10:49:23

brebs
Member
Registered: 2007-04-03
Posts: 3,742

Re: XBMC Tearing since Nvidia update to 331.38

This Nvidia thread seems relevant.

Offline

#32 2014-01-29 11:35:32

Tetsumaki
Member
Registered: 2010-11-17
Posts: 6

Re: XBMC Tearing since Nvidia update to 331.38

Thanks for the solution with composite on disabled.
Work's with AMD CARD.

Offline

#33 2014-01-30 22:36:28

odin89
Member
Registered: 2011-09-23
Posts: 32

Re: XBMC Tearing since Nvidia update to 331.38

How can i disable the BackingStore Option. Like in the Nvidia Thread said the option in the xorg.conf doesnt work. How can i passing the -bs argument to the X Server? I´ve the awful tearing again.

Offline

#34 2014-01-30 23:29:48

brebs
Member
Registered: 2007-04-03
Posts: 3,742

Re: XBMC Tearing since Nvidia update to 331.38

Probably like this:

startx -- -bs

Note all those dashes wink

But I think the point is that 331.38 is broken regarding tearing, so downgrade - 304.119 seems OK.

Offline

#35 2014-02-02 18:00:52

blahbla77
Member
Registered: 2008-12-18
Posts: 10

Re: XBMC Tearing since Nvidia update to 331.38

adr3nal1n wrote:

No need to downgrade packages,

Simply add the following to your /etc/X11/xorg.conf to prevent screen tearing with nvidia cards.

Section "Extensions"
   Option         "Composite" "Disable"
EndSection

Hope this helps.

I tried adding it to /etc/X11/xorg.conf.d/20-nvidia.conf
which should be the same right? It didn't work for me though.
I'm also using gdm, does it need composite?

this is from my Xorg.0.log:

(EE) NVIDIA(GPU-0): EVO Push buffer channel allocation failed
[   145.128] (EE) NVIDIA(GPU-0): Failed to allocate EVO core DMA push buffer
[   145.129] (EE) NVIDIA(0): Failing initialization of X screen 0
[   145.129] (II) UnloadModule: "nvidia"
[   145.129] (II) UnloadSubModule: "wfb"
[   145.129] (II) UnloadSubModule: "fb"
[   145.129] (EE) Screen(s) found, but none have a usable configuration.
[   145.129] (EE) Fatal server error:
[   145.129] (EE) no screens found(EE)

Offline

#36 2014-02-02 22:36:25

odin89
Member
Registered: 2011-09-23
Posts: 32

Re: XBMC Tearing since Nvidia update to 331.38

I just installed lightdm, edit the /etc/lightdm/lightdm.conf and add "xserver-command=X -bs"
Tearing is gone and im happy smile

Offline

#37 2014-02-03 10:28:13

kokoko3k
Member
Registered: 2008-11-14
Posts: 1,798

Re: XBMC Tearing since Nvidia update to 331.38

You people may prefer this (less drastic) solution instead:
https://bbs.archlinux.org/viewtopic.php?id=176651

Offline

#38 2014-02-03 19:30:32

yodaz
Member
Registered: 2011-03-08
Posts: 41

Re: XBMC Tearing since Nvidia update to 331.38

For those using kdm like me, you can edit /usr/share/config/kdm/kdmrc and add

-bs

option to

ServerArgsLocal

And there's no need to disable Composite extension.

Last edited by yodaz (2014-02-03 19:31:07)

Offline

#39 2014-02-04 15:50:43

kokoko3k
Member
Registered: 2008-11-14
Posts: 1,798

Re: XBMC Tearing since Nvidia update to 331.38

"-bs" is supposed to disable backing store, but without removing the composite extension, it has been reported that "-bs" has no effect in new Xorg servers, that's the point.

Offline

#40 2014-02-04 21:44:39

yodaz
Member
Registered: 2011-03-08
Posts: 41

Re: XBMC Tearing since Nvidia update to 331.38

I'm sorry if I've missed something, but according to https://bugs.freedesktop.org/show_bug.cgi?id=74158 it seems the problem is only with the option

Option "BackingStore" "off"

in xorg.conf that has no effect, whereas adding -bs as a command line option did the trick.

Changing Xorg startup option to disable backing store, without disabling Composite extension worked for me.

Offline

#41 2014-02-05 15:31:17

kokoko3k
Member
Registered: 2008-11-14
Posts: 1,798

Re: XBMC Tearing since Nvidia update to 331.38

I'm sorry too, maybe (edit: well, probably) it is just me to have misunderstood.

Last edited by kokoko3k (2014-02-05 15:32:33)

Offline

#42 2014-02-06 17:36:44

minasmax
Member
Registered: 2014-02-06
Posts: 2

Re: XBMC Tearing since Nvidia update to 331.38

kokoko3k wrote:

You people may prefer this (less drastic) solution instead:
https://bbs.archlinux.org/viewtopic.php?id=176651

This worked for me like a charm!

Offline

#43 2014-02-09 10:44:49

wolfydRg
Member
Registered: 2012-02-28
Posts: 2

Re: XBMC Tearing since Nvidia update to 331.38

adr3nal1n wrote:

No need to downgrade packages,

Simply add the following to your /etc/X11/xorg.conf to prevent screen tearing with nvidia cards.

Section "Extensions"
   Option         "Composite" "Disable"
EndSection

Hope this helps.

Thanks. That was the solution for me.

Offline

#44 2014-02-10 21:24:44

pl
Member
Registered: 2014-02-10
Posts: 31

Re: XBMC Tearing since Nvidia update to 331.38

adr3nal1n wrote:

No need to downgrade packages,

Simply add the following to your /etc/X11/xorg.conf to prevent screen tearing with nvidia cards.

Section "Extensions"
   Option         "Composite" "Disable"
EndSection

Hope this helps.

Ah, dammit. I set up a Mac Mini (it uses Intel integrated graphics) as a media center some weeks ago and just could not get video playback to work properly. UXA, SNA, everything had a constant tear with XBMC. SNA TearFree caused stutter twice a minute. XBMC Standalone teared and using a wm along with compton caused some odd jitter. The only thing that worked was mplayer-vaapi in fullscreen but it had audio sync issues and when using vaapi the audio couldn't be delayed for some reason, not even with PulseAudio. Wasted days trying different things.

I ended up building a new HTPC since I need the Mini for porting some software at the office. The new build had no real problems with TearFree enabled but I was interested in why the tearing problem remained without it and finally found this thread. I don't know why I didn't stumble upon this weeks ago with a million different "xbmc intel tearing" google searches. Probably because most threads mention nVidia as the reason.

Disabling composite in xorg.conf.d helped, thanks! I had just happened to change our media center computer the week this problem seems to have appeared and never thought it might be related to changes like this.

Hope this get's some Intel user to click through from a search engine tongue

Offline

#45 2014-02-12 07:27:12

Awebb
Member
Registered: 2010-05-06
Posts: 5,245

Re: XBMC Tearing since Nvidia update to 331.38

odin89 wrote:

I just installed lightdm, edit the /etc/lightdm/lightdm.conf and add "xserver-command=X -bs"
Tearing is gone and im happy smile

And we all know what -bs usually stands for.

I really hope XBMC and Wayland will be a default thing soon, I'm tired of the old problems, I could use new ones.

Offline

#46 2014-02-16 01:52:28

ryanvade
Member
Registered: 2013-01-23
Posts: 73

Re: XBMC Tearing since Nvidia update to 331.38

Another reason to switch to Wayland I suppose. smile

Offline

#47 2014-02-17 18:20:25

sirdeiu
Member
Registered: 2013-03-11
Posts: 10

Re: XBMC Tearing since Nvidia update to 331.38

Adding Option "TripleBuffer" "1" To Device section in xorg.conf fixed tearing for me. 331.38 GTX570 KDE.

Offline

#48 2014-02-22 10:46:20

marco44
Member
Registered: 2010-12-11
Posts: 15

Re: XBMC Tearing since Nvidia update to 331.38

Triple Buffering didn't change a thing for me. Downgrading these packages: xf86-input-evdev-2.8.2-1-x86_64.pkg.tar.xz  xorg-server-1.14.5-2-x86_64.pkg.tar.xz works (GeForce GT 240), giving -bs to X too.

Offline

#49 2014-03-17 20:54:01

jtheoof
Member
Registered: 2014-01-30
Posts: 17

Re: XBMC Tearing since Nvidia update to 331.38

For those with xf86-video-intel driver, the tip in Arch wiki Intel Graphics did the trick.

#cat /etc/X11/xorg.conf.d/20-intel.conf
Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "TearFree"    "true"
EndSection

Offline

#50 2015-05-09 11:14:46

Janusz11
Member
Registered: 2007-05-16
Posts: 80

Re: XBMC Tearing since Nvidia update to 331.38

brebs wrote:

Probably like this:

startx -- -bs

Note all those dashes wink

But I think the point is that 331.38 is broken regarding tearing, so downgrade - 304.119 seems OK.

This works!
Thanks a bunch, now I can enjoy gaming without tearing.

Offline

Board footer

Powered by FluxBB