You are not logged in.

#1 2014-01-18 22:02:41

mrenaud92
Member
Registered: 2011-02-03
Posts: 6

[SOLVED] No Audio Output on ThinkPad T440s

Hey, I have just finished configuring my new T440s and everything is working except audio. I have unmuted and raised the volume on all output channels in alsamixer but still no output. There appears to be 2 sound cards as visible from alsamixer:

Card 1:
Card: HDA Intel MID
Chip: Intel Haswell HDMI

Card 2:
Card: HDA Intel PCH
Chip: Realtek ALC292

The following is the result of "cat /proc/asound/modules"

 0 snd_hda_intel
 1 snd_hda_intel
 4 thinkpad_acpi

And here is "lsmod | grep snd"

snd_hda_codec_hdmi     30162  1 
snd_hda_codec_realtek    41295  1 
snd_hda_intel          37000  2 
snd_hda_codec         150305  3 snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_intel
snd_hwdep               6340  1 snd_hda_codec
snd_pcm                77645  3 snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel
snd_page_alloc          7242  2 snd_pcm,snd_hda_intel
snd_timer              18726  1 snd_pcm
snd                    59109  12 snd_hda_codec_realtek,snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_pcm,snd_hda_codec,snd_hda_intel,thinkpad_acpi
soundcore               5450  1 snd

Am I missing something simple? I don't know if this is relevant but the annoying speaker beep works, but that's the only sound I can get it to make. Does anyone have any idea what it might be?

Last edited by mrenaud92 (2014-01-20 03:58:58)

Offline

#2 2014-01-19 21:55:12

mrenaud92
Member
Registered: 2011-02-03
Posts: 6

Re: [SOLVED] No Audio Output on ThinkPad T440s

It appears that this bug surfaced quite a while ago (https://bugs.launchpad.net/ubuntu/+sour … ug/1081466). Is there any reason why this patch was not applied to the kernel that archlinux uses? If not, how would I go about getting that patch included? Thanks.

Offline

#3 2014-01-19 22:00:53

headkase
Member
Registered: 2011-12-06
Posts: 1,840

Re: [SOLVED] No Audio Output on ThinkPad T440s

Arch tends to package upstream with as few modifications as possible.  Your first troubleshooting step should be to compile a custom kernel with the relevant patch and confirm that corrects the issue.  Then open a bug-report on Arch's bug tracker if so and be prepared to be told to then open a bug on the upstream kernel.

Offline

#4 2014-01-19 22:45:36

mrenaud92
Member
Registered: 2011-02-03
Posts: 6

Re: [SOLVED] No Audio Output on ThinkPad T440s

Hmm, I just downloaded the kernel source and the patch has already been applied, so I guess that isn't the issue. Any other ideas why audio wouldn't be working? I also noticed that the results of "cat /proc/asound/modules" has the "snd_hda_intel" module listed twice in index 0 as well as 1. When running alsamixer, the default card has no output channels but the second card does. On the ALSA page, it says that you can change the default card by setting the index of the card you want to use to 0 as follows:

options snd_hda_intel index=0

The only issue is both cards have the same name. Any ideas on how I can set the second one to be the default? Thanks in advance for any suggestions.

Edit: I feel quite silly now, the solution was to use the "Alternative Method".

Last edited by mrenaud92 (2014-01-19 23:35:22)

Offline

#5 2014-01-19 23:10:48

headkase
Member
Registered: 2011-12-06
Posts: 1,840

Re: [SOLVED] No Audio Output on ThinkPad T440s

You can try to disable one of the outputs at the kernel level.  Put the following configuration in "/etc/modprobe.d/alsa.conf"  You may call the file an *.conf if "alsa" doesn't suit you:

options snd_hda_intel enable=1,0
options snd slots=snd_hda_intel
options snd_hda_intel index=0

The line you will be most interested in is the first one.  Where it says "1,0" that means enable first device disable second.  So if you want to reverse it then say "0,1" there.  For your third device create another line: "options thinkpad_acpi enable=0" since it has a different name.  What you probably want to disable with the first line is the HDMI output.  So, list your devices after you've made the configuration and reboot and see which one it disabled.

If this fails you might also have better luck installing PulseAudio.  Some people will tell you it eats small children but in my experience it works better with "odd" outputs like HDMI.

Edit: you edited while I was typing this.  The above is how you deal with soundcards with the same driver: comma separated values on the options line.

Last edited by headkase (2014-01-19 23:12:16)

Offline

#6 2014-01-19 23:16:44

headkase
Member
Registered: 2011-12-06
Posts: 1,840

Re: [SOLVED] No Audio Output on ThinkPad T440s

Also, you may not want to disable "thinkpad_acpi" I just listed it there as it is an output of your sound device listing.

Offline

#7 2014-01-20 03:56:38

mrenaud92
Member
Registered: 2011-02-03
Posts: 6

Re: [SOLVED] No Audio Output on ThinkPad T440s

Hey, thanks a lot for the help, the sound is working now! smile

Solution

Just in case anyone else encounters this same problem, the solution as headkase pointed out is to create the following file "/etc/modprobe.d/alsa.conf" with the contents:

options snd_hda_intel enable=0,1
options snd slots=snd_hda_intel, thinkpad_acpi
options snd_hda_intel index=0
options thinkpad_acpi index=1

Offline

#8 2014-01-20 04:21:33

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,413

Re: [SOLVED] No Audio Output on ThinkPad T440s

I don't think that there should be a space between "snd_hda_intel," and "thinkpad_acpi" in the second line.  A space would be telling modprobe that "thinkpad_acpi" would be a whole new option.

Though maybe that is just a typo...

Offline

#9 2014-01-20 14:59:00

headkase
Member
Registered: 2011-12-06
Posts: 1,840

Re: [SOLVED] No Audio Output on ThinkPad T440s

mrenaud92 wrote:

Hey, thanks a lot for the help, the sound is working now! smile

Solution

Just in case anyone else encounters this same problem, the solution as headkase pointed out is to create the following file "/etc/modprobe.d/alsa.conf" with the contents:

options snd_hda_intel enable=0,1
options snd slots=snd_hda_intel, thinkpad_acpi
options snd_hda_intel index=0
options thinkpad_acpi index=1

Right on, you're welcome! smile

Offline

#10 2015-05-24 18:18:09

wasutton3
Member
Registered: 2011-03-19
Posts: 27

Re: [SOLVED] No Audio Output on ThinkPad T440s

Not to bring back an old thread,

But this was verified to work with both headphone and internal speakers? Because this config doesn't enable the speakers for me on a T440P

Offline

#11 2015-05-25 00:24:51

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 8,867
Website

Re: [SOLVED] No Audio Output on ThinkPad T440s

wasutton3, as this topic is marked as solved, please open a new topic and link back to this one if you feel that it is still relevant.

https://wiki.archlinux.org/index.php/Fo … bumping.22

Closing.


Sakura:-
Mobo: MSI X299 TOMAHAWK ARCTIC // Processor: Intel Core i7-7820X 3.6GHz // GFX: nVidia GeForce GTX 970 // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 5x 1TB HDD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

Board footer

Powered by FluxBB