You are not logged in.

#1 2006-01-03 12:41:06

honzor
Member
Registered: 2005-12-18
Posts: 42

Enabling ATAPI on 2.6.15-2

Hi,

i was just wondering how i should enable ATAPI with the new Kernel... With 2.6.14 my atapi dvdrw wasnt even recognized, now it is recognized but i get

ata2(0): WARNING: ATAPI is disabled, device ignored.

so i think its just a config problem somewhere...

Any help is appreciated

Offline

#2 2006-01-03 12:53:38

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,262

Re: Enabling ATAPI on 2.6.15-2

try to add
options libata atapi_enabled=1
to /etc/modprobe.conf
and rebuild mkinitrd with mkinitrd auto

Offline

#3 2006-01-03 13:08:38

honzor
Member
Registered: 2005-12-18
Posts: 42

Re: Enabling ATAPI on 2.6.15-2

Nope, already tried that, dmesg continues to state ATAPI is disabled

Offline

#4 2006-01-03 13:10:26

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,262

Re: Enabling ATAPI on 2.6.15-2

try to boot libata.atapi_enable=1

Offline

#5 2006-01-03 13:18:49

honzor
Member
Registered: 2005-12-18
Posts: 42

Re: Enabling ATAPI on 2.6.15-2

libata.atapi_enable=1 is not recognized as a boot parameter according to dmesg. The same happens with libata.atapi_enabled=1 ... Any other suggestion?

Offline

#6 2006-01-03 13:20:56

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,262

Re: Enabling ATAPI on 2.6.15-2

i think now i know where the error is..
initrd loads only libata with insmod
i need to change imkinitrd, have a bit patience i point you to a fix later.

Offline

#7 2006-01-03 13:25:11

honzor
Member
Registered: 2005-12-18
Posts: 42

Re: Enabling ATAPI on 2.6.15-2

aaa i understand so you are stating the option in modprobe.conf isnt even evaluated while loading the module from initrd?

Offline

#8 2006-01-03 13:50:27

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,262

Re: Enabling ATAPI on 2.6.15-2

http://bugs.archlinux.org/?getfile=495
run as root:
./mkinitrd auto and then try again, thanks

Offline

#9 2006-01-03 14:12:51

honzor
Member
Registered: 2005-12-18
Posts: 42

Re: Enabling ATAPI on 2.6.15-2

Thanx! Dvdrw is now correctly recognized. Thank you

Offline

#10 2006-01-03 14:14:44

tpowa
Developer
From: Lauingen , Germany
Registered: 2004-04-05
Posts: 2,262

Re: Enabling ATAPI on 2.6.15-2

yes kicked that damn bug smile

Offline

#11 2006-01-04 20:17:56

Moo-Crumpus
Member
From: Hessen / Germany
Registered: 2003-12-01
Posts: 1,444

Re: Enabling ATAPI on 2.6.15-2

I was in Berlin for some days, while you asked me for a test and then closed the bug. Finally, your last changes in mkinitrd killed that fly. I take a bow, tpowa!


Frumpus addict
[mu'.krum.pus], [frum.pus]

Offline

Board footer

Powered by FluxBB