You are not logged in.

#1 2014-01-20 13:46:20

saultdon
Member
From: Treaty 08
Registered: 2013-06-25
Posts: 41

[SOLVED] Why does wxpython2.8 depend on wxpython?

I was doing some package cleaning today and tried to remove wxpython only to find that wxpython2.8 depended on this package and had to be removed as well.

I'm curious why the same package relies on itself and not only that, but a higher version?

Last edited by saultdon (2014-01-30 01:42:14)


"We don't inherit the land from our ancestors - we borrow it from our children."

Offline

#2 2014-01-20 16:24:22

drcouzelis
Member
From: Connecticut, USA
Registered: 2009-11-09
Posts: 4,035
Website

Re: [SOLVED] Why does wxpython2.8 depend on wxpython?

I did some quick research. Here's my guess:

"wxpython" and "wxpython2.8" both have a file called "/usr/lib/python2.7/site-packages/wxversion.py". Two packages cannot share ownership of a file, so the packager put it in "wxpython" (which is the latest version of wxpython, makes sense). Therefore, in order to have access to that file (and possibly a few other shared files) "wxpython2.8" depends on "wxpython".

...but that's just my guess. You're welcome to ask the package maintainer. smile

Last edited by drcouzelis (2014-01-23 13:44:42)

Offline

#3 2014-01-23 06:20:03

saultdon
Member
From: Treaty 08
Registered: 2013-06-25
Posts: 41

Re: [SOLVED] Why does wxpython2.8 depend on wxpython?

Thanks drcouzelis. That makes sense.


"We don't inherit the land from our ancestors - we borrow it from our children."

Offline

#4 2014-01-23 07:15:21

Awebb
Member
Registered: 2010-05-06
Posts: 5,324

Re: [SOLVED] Why does wxpython2.8 depend on wxpython?

Just because it makes sense does not mean it has to be true. Ask the maintainer, maybe this shouldn't happen and he'll be happy for your inquery.

Offline

#5 2014-01-23 19:41:24

saultdon
Member
From: Treaty 08
Registered: 2013-06-25
Posts: 41

Re: [SOLVED] Why does wxpython2.8 depend on wxpython?

@awebb true, I was thinking about it some more and it could be something I'll let the pkg maintainer aware of because I noticed that some packages with shared files usually have a separate pkgname-common type of package available.


"We don't inherit the land from our ancestors - we borrow it from our children."

Offline

#6 2014-01-23 19:53:00

alphaniner
Member
From: Ancapistan
Registered: 2010-07-12
Posts: 2,810

Re: [SOLVED] Why does wxpython2.8 depend on wxpython?

drcouzelis wrote:

I did some quick research. Here's my guess:

<snip>

Good detective work, but I hope you're wrong. Otherwise I may have to start scrutinizing dependencies for such madness in other packages.

Edit: It's probably relevant that the two packages have different maintainers.

Last edited by alphaniner (2014-01-23 19:53:43)


But whether the Constitution really be one thing, or another, this much is certain - that it has either authorized such a government as we have had, or has been powerless to prevent it. In either case, it is unfit to exist.
-Lysander Spooner

Offline

#7 2014-01-24 07:29:15

lordheavy
Developer
From: France
Registered: 2010-04-01
Posts: 284

Re: [SOLVED] Why does wxpython2.8 depend on wxpython?

drcouzelis wrote:

I did some quick research. Here's my guess:

"wxpython" and "wxpython2.8" both have a file called "/usr/lib/python2.7/site-packages/wxversion.py". Two packages cannot share ownership of a file, so the packager put it in "wxpython" (which is the latest version of wxpython, makes sense). Therefore, in order to have access to that file (and possibly a few other shared files) "wxpython2.8" depends on "wxpython".

...but that's just my guess. You're welcome to ask the package maintainer. smile

You're right! It's the reason why wxpython2.8 depends on wxpython, because of conflicting file. It's a bit dirty but it works and wxpython2.8 is only needed for one package (playonlinux).

If someone has a better solution.....

Offline

#8 2014-01-24 13:52:30

drcouzelis
Member
From: Connecticut, USA
Registered: 2009-11-09
Posts: 4,035
Website

Re: [SOLVED] Why does wxpython2.8 depend on wxpython?

That solution sounds fine to me. Since Arch Linux is a rolling release distribution "wxpython2.8" will eventually go away. And if someone is bothered enough by needing to install "wxpython" when all they really need is "wxpython2.8" then the ABS (and AUR) makes it easy enough for them to get rid of the dependency.

alphaniner wrote:

Otherwise I may have to start scrutinizing dependencies for such madness in other packages.

This situation with wxPython doesn't bother me. I trust the Arch Linux developers, the decision didn't break anything, and it potentially cost me an extra 50 MB.

Offline

#9 2014-01-24 14:21:57

alphaniner
Member
From: Ancapistan
Registered: 2010-07-12
Posts: 2,810

Re: [SOLVED] Why does wxpython2.8 depend on wxpython?

It doesn't bother me either, because I don't need wxpython2.8. But if it were common practice that 99.9999% (yes, that's a valid calculation for this case) of the space used by dependencies was waste, that would be a different story.

Anyway, I just looked at wxpython's version number (3.0.0.0-2) and learned that version 3.0 was released less than a month ago. So maybe this is just a case of 'growing pains'. smile

Last edited by alphaniner (2014-01-24 14:27:47)


But whether the Constitution really be one thing, or another, this much is certain - that it has either authorized such a government as we have had, or has been powerless to prevent it. In either case, it is unfit to exist.
-Lysander Spooner

Offline

#10 2014-01-24 15:03:37

progandy
Member
Registered: 2012-05-17
Posts: 3,603

Re: [SOLVED] Why does wxpython2.8 depend on wxpython?

alphaniner wrote:

Anyway, I just looked at wxpython's version number (3.0.0.0-2) and learned that version 3.0 was released less than a month ago. So maybe this is just a case of 'growing pains'. smile

If the two version stay for a long time, a clean solution would be to split wxversion in a new package and let wxpython depend on it.


| alias CUTF='LANG=en_XX.UTF-8@POSIX ' |

Offline

#11 2014-02-14 19:52:34

jagan605
Member
Registered: 2011-12-04
Posts: 26

Re: [SOLVED] Why does wxpython2.8 depend on wxpython?

Any ideas on how to solve this issue temporarily, I have a problem with having both versions installed.

Offline

#12 2014-02-14 19:53:43

jagan605
Member
Registered: 2011-12-04
Posts: 26

Re: [SOLVED] Why does wxpython2.8 depend on wxpython?

I will get it from the aur.

Offline

Board footer

Powered by FluxBB