You are not logged in.

#1 2014-01-29 01:24:23

smsware
Member
From: Szczecin, Poland
Registered: 2012-08-14
Posts: 149
Website

[SOLVED] DMAR errors related to Intel graphics

Every time I boot I got message like this:

dmar:DRHD: handling fault status reg 2
dmar:DMAR:[DMA Read] Request device [00:1f.2] fault addr caa40000
DMAR:[fault reason 06] PTE Read access is not set

I've googled that the errors should dissapear after setting intel_iommu=off or intel_iommu=pt kernel parameter but for me it's not working at all. I've only learned that I shoudn't ignore this error as it affects performance (which is correct as my fps in games dropped badly) and destroy filesystems (I don't understand why as it suppouse to be problem with video driver).

What can I do?

Last edited by smsware (2014-01-29 05:22:42)

Offline

#2 2014-01-29 01:53:34

smsware
Member
From: Szczecin, Poland
Registered: 2012-08-14
Posts: 149
Website

Re: [SOLVED] DMAR errors related to Intel graphics

I solved it by disabling virtualization support in bios... I don't get a thing now but I'm not using it anyway so... solved?

Edit: not solved, sorry, it was just for one reboot, probably prompt didn't appear for some reason...

Last edited by smsware (2014-01-29 02:00:26)

Offline

#3 2014-01-29 05:22:28

smsware
Member
From: Szczecin, Poland
Registered: 2012-08-14
Posts: 149
Website

Re: [SOLVED] DMAR errors related to Intel graphics

Okay, so basically the command needs to be intel_iommu=igfx_off now (this error is rare and my previous search gave me solution from 2009) and it fixed the issue. As I've learned, the error is because dmar tables or my BIOS are broken... don't really know what it does, I'll check for upgrade but it's not Linux fault so I'm markin it as solved after all...

Offline

#4 2017-09-29 19:57:11

cambion.web
Member
Registered: 2017-09-29
Posts: 2

Re: [SOLVED] DMAR errors related to Intel graphics

After updating kernel today I was getting this same issue.

Using coreboot BIOS on my T420 laptop, as far as I know the bios isn't broken but I reflashed that just in case. Didn't fix it.
Checked my dmar tables with "sudo ls -al /sys/firmware/acpi/tables" seemed fine.

Adding kernel parameter "intel_iommu=igfx_off" fixed the issue.

Thanks

Last edited by cambion.web (2017-09-29 19:57:49)

Offline

#5 2017-09-29 20:13:59

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 8,912
Website

Re: [SOLVED] DMAR errors related to Intel graphics


Sakura:-
Mobo: MSI X299 TOMAHAWK ARCTIC // Processor: Intel Core i7-7820X 3.6GHz // GFX: nVidia GeForce GTX 970 // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 5x 1TB HDD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Online

Board footer

Powered by FluxBB