You are not logged in.

#1 2014-01-31 21:08:05

Orim
Member
Registered: 2009-12-10
Posts: 61

Systemd service for synergys not working

Hi,

I've set up a synergys@user service file as specified in the wiki:
https://wiki.archlinux.org/index.php/Sy … ch_Linux_2

This works fine when the script is started manually but fails during boot
with exactly the error message the service file is supposed to work around:

Synergy 1.4.15: 2014-01-31T21:49:55 WARNING: primary screen unavailable: unable to open screen

I've tried adding "xorg.target" to "After" but that didn't help.
Any ideas?

Offline

#2 2014-01-31 22:38:09

Raynman
Member
Registered: 2011-10-22
Posts: 1,537

Re: Systemd service for synergys not working

Orim wrote:

Any ideas?

Don't use a service for something that's tied to your X session (unless you happen to run systemd --user to manage that X session). Have your xinitrc/DE/WM (auto)start synergy.

Offline

#3 2014-01-31 23:15:03

Orim
Member
Registered: 2009-12-10
Posts: 61

Re: Systemd service for synergys not working

Oh, I didn't know that was bad...that would explain some other problematic service files as well, I guess.
From the wiki I gather that systemd --user is not 100% working yet? Is that still true?

Offline

#4 2014-01-31 23:34:38

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,414

Re: Systemd service for synergys not working

systemd --user is getting there, but not ready for prime time yet.  I have heard that SailfishOS actually uses full systemd --user, though I'm not sure what hoops had to be jumped through to make it so.  It should come around soon though, as there has been some work on it of late I think.

A bit off topic, but this excites me. smile  I also read that SailfishOS runs on btrfs.  So when you restore the phone/tablet back to stock (factory reset) it simply deletes the in-use subvolume and replaces it with a read-only snapshot of the original.  Oooh nice...

Offline

Board footer

Powered by FluxBB