You are not logged in.

#1 2006-01-06 20:18:01

From: Panama City, Florida
Registered: 2005-04-15
Posts: 28

audio cds misbehaving with hal enabled on kde 3.5

I'm having a rather interesting problem with playing audio cds after enabling hal and dbus. In short, whenever I insert an audio cd, an icon for it gets placed on my desktop, then disappears, reappears, then disappears again, this cycles about 10 times before it finally gives up, and no icon for the cd is present, attempts to play the cd directly from kscd fail. Every other type of medium gets detected and automounted just fine. Neither my cd drive or my dvd drive can play audio cds without annoying malfunction. The disc itself is in great shape and the same events occur with other audio cds. Also, after the cycle of maflunction finishes, if i eject, then re-insert the disc, nothing happens. If i disable hal and dbus and reboot, the cd plays just fine when accessed through kscd (but of course no automount for data cds and usb media!)

I'm not sure what to attribute this problem to, but it seems like it's a problem in kde's automount system because it happens even when I disable ivman. Ivman has been quite good to me, so I imagine this is a kde problem.

if anyone can shed some light on the source of this problem, i'd really appreciate it, and is there a way to disable the automount feature in kde 3.5 and still have the device icons appear on the desktop with new media through ivman?

I use kde 3.5 (compiled from source) on kernel 2.6.14

Desktop: Biostar GeForce 6100-M9 + AMD64 4000+ 2.4GHz, 1MB L2 + 1GB DDR400 + 80GB PATA 500GB SATA + Nvidia 7600GT, 256MB GDDR3
Notebook: HP Pavilion DV6-1245DX + Intel Core 2 Duo T6500, 2.10GHz, 2MB L2 + 4GB DDR2 + 320GB SATA + Intel 4500MHD, 17" Widescreen + Lightscribe DVD+RW


#2 2006-01-23 16:42:39

From: Greece
Registered: 2004-11-18
Posts: 714

Re: audio cds misbehaving with hal enabled on kde 3.5

If using the latest versions of udev/dbus/hal, then remove ivman- it's obsolete... the automounting job is done by pmount.
Do you have created any custom device rules in /etc/udev/rules.d/ ?

Microshaft delenda est


Board footer

Powered by FluxBB