You are not logged in.

#1 2014-02-24 11:55:30

Hotonhum
Member
Registered: 2014-02-02
Posts: 11

[SOLVED] acpi_backlight=vendor not working after update.

Hi,

I'm using xfce4 on a Lenovo E330. Prior to the kernel update my screen brightness adjustments worked fine in nice little steps with

acpi_backlight=vendor

appended as a kernel parameter.

After the update this kernel parameter doesn't seem to work and my screen doesn't adjust the brightness anymore though.

So I tried using xbacklight with keybindings but that doesn't work very well since there are only 3 brightness levels.
Probably because xbacklight collides with the xfce power manager.

And xfce power manager on the other hand seems to have a hard coded screen brightness bug.

http://forum.xfce.org/viewtopic.php?pid=29952#p29952

Does anyone have a solution for nice screen brightness controls or does anyone have the same problem?

Kind regards,

Hotonhum

Last edited by Hotonhum (2014-05-02 18:44:00)

Offline

#2 2014-02-24 18:58:44

Hannus
Member
Registered: 2013-04-04
Posts: 14

Re: [SOLVED] acpi_backlight=vendor not working after update.

I started up my laptop, and by me the adjustment of the backlight also doesn't work now (always 100%)! There was a kernel to update, so I thought that it would be fixed; but no... As you said, it has likely to do with the kernel update. I hope it will be fixed soon...
I don't use Xfce, but KDE.

Last edited by Hannus (2014-02-24 18:59:36)

Offline

#3 2014-02-24 19:19:12

felixculpa
Member
From: Alberta, Canada
Registered: 2012-06-12
Posts: 187

Re: [SOLVED] acpi_backlight=vendor not working after update.

I didn't need to have any kernel parameters before, my backlight and the buttons worked out of the box. However after recent updates that seems to have completely changed. I can't change the brightness at all it seems. I am using Awesome Window Manager and no DE.

Offline

#4 2014-02-24 19:42:35

frank604
Member
From: BC, Canada
Registered: 2011-04-20
Posts: 1,003
Website

Re: [SOLVED] acpi_backlight=vendor not working after update.

What syntax of xbacklight did you bind your key to?


github       bible       blog       screenshot

Offline

#5 2014-02-24 20:20:20

Hotonhum
Member
Registered: 2014-02-02
Posts: 11

Re: [SOLVED] acpi_backlight=vendor not working after update.

The screen brightness always is 100% with acpi_backlight=vendor for me, too! It seems to be exactly the same problem.

I've bound my keys to
xbacklight -inc 40
and
xbacklight -dec 40

The problem with this is that I've got

acpi_video0 and intel_backlight under
/sys/class/backlight

So these commands seem to change both which is why there's flickering and only three different levels.

Offline

#6 2014-02-24 21:20:48

frank604
Member
From: BC, Canada
Registered: 2011-04-20
Posts: 1,003
Website

Re: [SOLVED] acpi_backlight=vendor not working after update.

Since you use xbacklight -inc 40, that would raise it by 40%.  So if you are at 0% you hit it once, you'll be at 40% and one more time to 80% and one more to 100%.  This might explain why you have three different levels.  Change 40 to 20 for more levels.  Hope this helps a little.


github       bible       blog       screenshot

Offline

#7 2014-02-25 06:53:22

m1st3rkr3p
Member
Registered: 2014-02-21
Posts: 34

Re: [SOLVED] acpi_backlight=vendor not working after update.

Try using

video.use_native_backlight=1

That was introduced with the kernel 3.13 and solved the problem on my machine.

Offline

#8 2014-02-25 10:54:17

Hotonhum
Member
Registered: 2014-02-02
Posts: 11

Re: [SOLVED] acpi_backlight=vendor not working after update.

m1st3rkr3p wrote:

Try using

video.use_native_backlight=1

That was introduced with the kernel 3.13 and solved the problem on my machine.

Thanks a lot! That's fixing the issue for me.
It's even working with my lcd brightness slider.

Offline

#9 2014-02-25 15:15:15

m1st3rkr3p
Member
Registered: 2014-02-21
Posts: 34

Re: [SOLVED] acpi_backlight=vendor not working after update.

Hotonhum wrote:
m1st3rkr3p wrote:

Try using

video.use_native_backlight=1

That was introduced with the kernel 3.13 and solved the problem on my machine.

Thanks a lot! That's fixing the issue for me.
It's even working with my lcd brightness slider.

Glad it's working for you too.

Offline

#10 2014-02-25 18:29:27

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [SOLVED] acpi_backlight=vendor not working after update.

This kernel command line parameter does nothing on my E430.  Though acpi_osi=!Windows 2012 still works just fine for me.

But since there are some here who it is working for, I have added this to the troubleshooting section of the Intel wiki page.

Offline

#11 2014-02-25 19:14:28

m1st3rkr3p
Member
Registered: 2014-02-21
Posts: 34

Re: [SOLVED] acpi_backlight=vendor not working after update.

WonderWoofy wrote:

This kernel command line parameter does nothing on my E430.  Though acpi_osi=!Windows 2012 still works just fine for me.

But since there are some here who it is working for, I have added this to the troubleshooting section of the Intel wiki page.

Nice, seems that this works just if you used

acpi_backlight=vendor

before 3.13 and it's a replace for that.

Offline

#12 2014-02-25 23:02:58

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [SOLVED] acpi_backlight=vendor not working after update.

Yeah, the thinkpad-acpi module throws a bunch of warnings if you use acpi_backlight=vendor, so it is probably not the best for people with Thinkpads.  That is how I ended up at acpi_osi=!Windows 2012.

Offline

#13 2014-03-05 18:44:19

Hannus
Member
Registered: 2013-04-04
Posts: 14

Re: [SOLVED] acpi_backlight=vendor not working after update.

I tried the mentioned solutions, but none of them solved the backlight problem with my computer (the screen is always 100%, adjusting isn't possible). For me it is very frustrating, because it worked always out-of-the-box and very well. But now it doesn't work... It's a Asus eee pc-laptop, with KDE. Does someone knows something to get the adjustment of the backlight working again?

Offline

#14 2014-03-05 19:16:32

linux-ka
Member
From: ADL
Registered: 2010-05-07
Posts: 232

Re: [SOLVED] acpi_backlight=vendor not working after update.

I have a Lenovo E330 too, but adding

video.use_native_backlight=1

to the kernel boot line doesn't help. Where is the trick?
My current boot line with grub2:

linux   /vmlinuz-linux root=UUID=xyz cryptdevice=/dev/sda3:home rw  quiet resume=/dev/sda2 resume_offset=208896 acpi_osi=Linux acpi_backlight=vendor

I just exchanged acpi_backlight=vendor, but as already said, it doesn't help :-(

Offline

#15 2014-03-06 00:08:51

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [SOLVED] acpi_backlight=vendor not working after update.

@linux-ka, did you try the xorg.conf.d trickery?  See the Intel page of the wiki.

Offline

#16 2014-03-06 07:37:01

linux-ka
Member
From: ADL
Registered: 2010-05-07
Posts: 232

Re: [SOLVED] acpi_backlight=vendor not working after update.

Thanks for pointing to the new wiki entry.

My 20-intel looks like this:

Section "Screen"
        Identifier "Default Screen"
        DefaultDepth 24
EndSection

Section "Device"
        Identifier  "Intel Graphics"
        Driver      "intel"
#        Option      "AccelMethod"  "uxa"
        Option      "AccelMethod"  "sna"
        Option      "Backlight"    "intel_backlight"
        BusID       "PCI:0:2:0"
EndSection

my Kernel parameter looked like this:

linux   /vmlinuz-linux root=UUID=xyz cryptdevice=/dev/sda3:home rw  quiet resume=/dev/sda2 resume_offset=208896 acpi_osi=Linux acpi_backlight=vendor   video.use_native_backlight=1

While booting the screen brightness decreases to maybe 40%. But I still cannot change it with FN+F8/F7.

I booted linux-3.13.5-1.

What's wrong with the setup?

Offline

#17 2014-03-06 08:29:47

Hannus
Member
Registered: 2013-04-04
Posts: 14

Re: [SOLVED] acpi_backlight=vendor not working after update.

I added the 20-intel.conf file, and now the adjustment of the brightness is working again on my laptop.
But I don't understand why this was working always out-of-the-box and without problems, and after an update it stops working and I have to write a configuration file for it to work. I thought that things after an update would be better/easier...

Offline

#18 2014-03-06 20:09:13

OrangeMediumGreen
Member
Registered: 2008-11-17
Posts: 16

Re: [SOLVED] acpi_backlight=vendor not working after update.

I have the same problem since the last kernel update.

I get this message during boot:

thinkpad_acpi: Unsupported brightness interface, please contact ibm-acpi-devel@lists.sourceforge.net

How about you?

Offline

#19 2014-03-10 18:23:57

jmetal88
Member
Registered: 2007-12-09
Posts: 66

Re: [SOLVED] acpi_backlight=vendor not working after update.

Question: What should I consider adding to my Xorg configuration that's similar to what the Intel file up there is doing if my laptop uses an Nvidia graphics card?  It's a Dell D630, by the way.  My function key brightness controls work fine, but I can't get any of the software controls (power management, brightness sliders, etc) to have any effect.

Offline

#20 2014-03-10 19:40:32

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [SOLVED] acpi_backlight=vendor not working after update.

jmetal88 wrote:

Question: What should I consider adding to my Xorg configuration that's similar to what the Intel file up there is doing if my laptop uses an Nvidia graphics card?  It's a Dell D630, by the way.  My function key brightness controls work fine, but I can't get any of the software controls (power management, brightness sliders, etc) to have any effect.

I don't use Nvidia in any machine I have, but I would imagine that it would depend on whether you are using nouveau or the binary blob.

The reason why some of these machines need the acpi_* command line arguments is apparently because windows decided to change how its backlight was handled and moved control from the ACPI subsystem to userspace.  So of course, the platforms vendors only think about supporting M$ and changed things accordingly in the firmwares.  So you need to tell it specifically that is should be used in the old way. 

I don't know how new/old your machine is, but maybe that bit of information can help you down the path to enlightenment in finding a fix for your specific issue.

Offline

#21 2014-03-20 05:21:15

powerpoint45
Member
Registered: 2013-03-06
Posts: 23

Re: [SOLVED] acpi_backlight=vendor not working after update.

Hi guys I am having the same problem. I am a noob can someone point me in the right direction as to where I enter in

acpi_backlight=vendor

or

video.use_native_backlight=1

Thank you! any help is appreciated!

Last edited by powerpoint45 (2014-03-20 05:25:51)


Developer of Lucid Launcher for Android

Offline

#22 2014-03-20 07:14:50

frank604
Member
From: BC, Canada
Registered: 2011-04-20
Posts: 1,003
Website

Re: [SOLVED] acpi_backlight=vendor not working after update.

powerpoint45 wrote:

Hi guys I am having the same problem. I am a noob can someone point me in the right direction as to where I enter

Depends on your bootloader, ie. grub's is located /etc/default/grub and you grub-mkconfig.


github       bible       blog       screenshot

Offline

#23 2014-03-20 15:09:27

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [SOLVED] acpi_backlight=vendor not working after update.

Typically, it is a better idea to try it out first before sticking it in your config.  So from the bootloader menu, use whatever method it has to edit the kernel command line and add that parameter for the one boot.  I am not a grub user, but that tends to be the most popular choice.  So from the grub menu (right after boot) make sure the selection you intend to boot is highlighted, then hit 'e'.  Edit away and boot with whatever it tells you to do.

Offline

#24 2014-03-20 19:54:16

powerpoint45
Member
Registered: 2013-03-06
Posts: 23

Re: [SOLVED] acpi_backlight=vendor not working after update.

frank604 wrote:
powerpoint45 wrote:

Hi guys I am having the same problem. I am a noob can someone point me in the right direction as to where I enter

Depends on your bootloader, ie. grub's is located /etc/default/grub and you grub-mkconfig.

mine is located in /etc/default/grub I tried the two additions 1 reboot at a time and it did not fix anything. When I try to dim or raise brightness it has no effect even when doing it from the terminal..


Developer of Lucid Launcher for Android

Offline

#25 2014-03-20 22:00:01

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [SOLVED] acpi_backlight=vendor not working after update.

Modifying /etc/default/grub has no effect until you actually regenerate the config.  This is another reason why it might have been better to just edit the kernel command line from the bootloader itself.

Offline

Board footer

Powered by FluxBB