You are not logged in.

#26 2014-03-21 01:37:51

powerpoint45
Member
Registered: 2013-03-06
Posts: 24

Re: [SOLVED] acpi_backlight=vendor not working after update.

WonderWoofy wrote:

Modifying /etc/default/grub has no effect until you actually regenerate the config.  This is another reason why it might have been better to just edit the kernel command line from the bootloader itself.

Unfortunately that still did not work. and some reasaon /etc/default/grub is different than clicking 'e' on boot item. And I pressed ctrl x when I finished editing. I think that was the right combination. It just said that F11 or ctrl e wil boot it

Last edited by powerpoint45 (2014-03-21 01:44:44)


Developer of Lucid Launcher for Android

Offline

#27 2014-03-21 17:29:31

mcloaked
Member
From: Yorkshire, UK
Registered: 2012-02-02
Posts: 1,009

Re: [SOLVED] acpi_backlight=vendor not working after update.

powerpoint45 wrote:
WonderWoofy wrote:

Modifying /etc/default/grub has no effect until you actually regenerate the config.  This is another reason why it might have been better to just edit the kernel command line from the bootloader itself.

Unfortunately that still did not work. and some reasaon /etc/default/grub is different than clicking 'e' on boot item. And I pressed ctrl x when I finished editing. I think that was the right combination. It just said that F11 or ctrl e wil boot it

Did you explicitly run

grub-mkconfig -o /boot/grub/grub.cfg

after editing  /etc/default/grub?  That was what WonderWoofy was saying but you didn't confirm that explicitly.


Mike C

Offline

#28 2014-03-22 02:04:02

powerpoint45
Member
Registered: 2013-03-06
Posts: 24

Re: [SOLVED] acpi_backlight=vendor not working after update.

mcloaked wrote:
powerpoint45 wrote:
WonderWoofy wrote:

Modifying /etc/default/grub has no effect until you actually regenerate the config.  This is another reason why it might have been better to just edit the kernel command line from the bootloader itself.

Unfortunately that still did not work. and some reasaon /etc/default/grub is different than clicking 'e' on boot item. And I pressed ctrl x when I finished editing. I think that was the right combination. It just said that F11 or ctrl e wil boot it

Did you explicitly run

grub-mkconfig -o /boot/grub/grub.cfg

after editing  /etc/default/grub?  That was what WonderWoofy was saying but you didn't confirm that explicitly.


Thanks. before I was only doing

grub-mkconfig

instead of

grub-mkconfig -o /boot/grub/grub.cfg

But it did not fix my issue. and when I try

video.use_native_backlight=1;

it came up with

/etc/default/grub: line 7: video.use_native_backlight=1: command not found

Developer of Lucid Launcher for Android

Offline

#29 2014-03-22 02:19:11

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,414

Re: [SOLVED] acpi_backlight=vendor not working after update.

Offline

#30 2014-03-22 02:54:39

frank604
Member
From: BC, Canada
Registered: 2011-04-20
Posts: 1,211

Re: [SOLVED] acpi_backlight=vendor not working after update.

powerpoint45 wrote:

Thanks. before I was only doing

grub-mkconfig

instead of

grub-mkconfig -o /boot/grub/grub.cfg

But it did not fix my issue. and when I try

video.use_native_backlight=1;

it came up with

/etc/default/grub: line 7: video.use_native_backlight=1: command not found

When I said, edit /etc/default/grub and do grub-mkconfig, I purposefully didn't write the full syntax that goes with grub-mkconfig as it differs between setup.  For a standard bios setup the following syntax can work.

grub-mkconfig -o /boot/grub/grub.cfg

You can see if it was successful by reading the output.

For my EFI setup as well as where I store my grub.cfg, my process to update grub is

grub-mkconfig -o /boot/efi/EFI/grub/grub.cfg

followed by a

cp /boot/efi/EFI/grub/grub.cfg /boot/grub/grub.cfg

You should of done something similar during your initial install of grub, unless you installed archbang, manjaro, or other derivatives.  Also, these kernel params aren't gauranteed to fix your issue, although it does help a number of folks.  Has this worked for you before?  For me, it doesn't and backlight is controlled by xbacklight and binding the fn keys to inc/dec brightness.

Offline

#31 2014-03-26 01:10:24

powerpoint45
Member
Registered: 2013-03-06
Posts: 24

Re: [SOLVED] acpi_backlight=vendor not working after update.

I happened to fix my brightness control issue by adding

Section "Device"
        Driver      "intel"
        Option      "Backlight"  "intel_backlight"
        Identifier "card0"
EndSection

into

/etc/X11/xorg.conf.d/20-intel.conf

Thanks for all the help!


Developer of Lucid Launcher for Android

Offline

#32 2014-04-19 16:30:42

nomeutente94
Member
From: Italy
Registered: 2011-02-21
Posts: 13
Website

Re: [SOLVED] acpi_backlight=vendor not working after update.

Thank you so much, now it works.

Offline

#33 2014-11-14 06:16:17

azyr
Member
Registered: 2014-11-14
Posts: 1

Re: [SOLVED] acpi_backlight=vendor not working after update.

I confirm that on 3.13.0-24-generic kernel using acpi_backlight=vendor kernel parameter the solution to get brightness controls (fn+f8 and fn+f9) working was to adjust Xorg.conf like linux-ka originally pointed out.

Just add Option "Backlight" "intel_backlight" under Section "Device".

With acpi_backlight=vendor setting /sys/class/backlight directory tree changes and you need to inform X11 about this it seems.

I'm using Lenovo X230.

Last edited by azyr (2014-11-14 06:17:11)

Offline

#34 2014-11-14 11:57:25

AnAkkk
Member
Registered: 2014-03-03
Posts: 148

Re: [SOLVED] acpi_backlight=vendor not working after update.

azyr wrote:

I confirm that on 3.13.0-24-generic kernel using acpi_backlight=vendor kernel parameter the solution to get brightness controls (fn+f8 and fn+f9) working was to adjust Xorg.conf like linux-ka originally pointed out.

Just add Option "Backlight" "intel_backlight" under Section "Device".

With acpi_backlight=vendor setting /sys/class/backlight directory tree changes and you need to inform X11 about this it seems.

I'm using Lenovo X230.

This is a Arch Linux forum, not Ubuntu. There have been many backlight fixes since 3.13, and Arch has 3.17 now.

Offline

#35 2014-11-14 19:06:30

MoonSwan
Member
From: Great White North
Registered: 2008-01-23
Posts: 873

Re: [SOLVED] acpi_backlight=vendor not working after update.

AnAkkk wrote:

This is a Arch Linux forum, not Ubuntu. There have been many backlight fixes since 3.13, and Arch has 3.17 now.

Oh calm down!  Not everyone is up-to-date with the forums and news from it. 

My own experience using an ATI chip on a HP Envy 6 and the newest kernel (3.17) is that using video.use_native_backlight=1 doesn't work at all.  I had to adjust this and instead of a 1 I used a zero at the end.  To get my brightness control back I now use:  video.use_native_backlight=0

Should I add this information to the wiki page on brightness control?

I hope it helps someone else.  smile


I'm torn apart between worlds. Basically, using vim in a highly visual environment with a lot of mouse features feels like soldering a lose wire to a motherboard with a Zippo and a needle, while working with ANY TEXT AT ALL with a "modern GUI" text editor feels like joining the London Philharmonic Orchestra with a Fisher-Price Laugh and Learn Magical Musical Mirror.  --Awebb

Offline

#36 2014-11-15 00:46:33

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,414

Re: [SOLVED] acpi_backlight=vendor not working after update.

MoonSwan wrote:

My own experience using an ATI chip on a HP Envy 6 and the newest kernel (3.17) is that using video.use_native_backlight=1 doesn't work at all.  I had to adjust this and instead of a 1 I used a zero at the end.  To get my brightness control back I now use:  video.use_native_backlight=0

Should I add this information to the wiki page on brightness control?

Yes, I think you should add this to the wiki.  It is good innformation!

Offline

Board footer

Powered by FluxBB