You are not logged in.

#1 2014-02-26 22:28:47

dalingrin
Member
Registered: 2009-03-18
Posts: 125

No speaker audio after resume

I have a Gigabyte P35K with a realtek audio codec.
Audio works great out of the box, including the speakers, hdmi, and headphones. However, once I let the laptop suspend I no longer have audio via speakers but it keeps working from all other outputs.
Alsamixer still shows all the controls as it should and I've tried toggling mutes and volume but there is no change. I've also tried reloading Pulseaudio but it makes no change.

Anyone have some ideas?

Offline

#2 2014-02-27 13:34:10

drcouzelis
Member
From: Connecticut, USA
Registered: 2009-11-09
Posts: 3,506
Website

Re: No speaker audio after resume

Back in the day (2002?) I had to unload and releoad the kernel modules for my audio card after waking up the laptop for audio to work properly again.

Does doing that help? If so, you can modify your "wake up" scripts to do it automatically.

Offline

#3 2014-02-27 18:23:22

dalingrin
Member
Registered: 2009-03-18
Posts: 125

Re: No speaker audio after resume

drcouzelis wrote:

Back in the day (2002?) I had to unload and releoad the kernel modules for my audio card after waking up the laptop for audio to work properly again.

Does doing that help? If so, you can modify your "wake up" scripts to do it automatically.

It does not. I went to a TTY and stopped X11. Then removed most of the snd_* modules and reloaded them but still no audio from speakers.

Offline

#4 2014-03-02 20:16:28

emeres
Member
Registered: 2013-10-08
Posts: 1,570

Re: No speaker audio after resume

I would save current state of alsa settings (alsactl store) and remove all card specific modules before suspending and then after resume try to load them and restore previous state.

Offline

#5 2014-03-05 21:14:00

dalingrin
Member
Registered: 2009-03-18
Posts: 125

Re: No speaker audio after resume

emeres wrote:

I would save current state of alsa settings (alsactl store) and remove all card specific modules before suspending and then after resume try to load them and restore previous state.

Thanks for the advice but this didn't seem to work either. Still no audio from speakers.

Offline

#6 2014-03-06 17:37:41

emeres
Member
Registered: 2013-10-08
Posts: 1,570

Re: No speaker audio after resume

I could not get any useful specifications on that laptop, meaning what model of Realteks chips your system has, but I assume it is snd-hda-intel compliant, so try using these options in modules configuration according to this (line 891):

options snd-hda-intel power_save=0 power_save_controller=0

Or the other way around, although that may be enabled by default. This driver supports power management out of box. Autoprobe could be detecting wrong model for your hardware though. I would also look into systemds journal, dmesg and other logs that may be relevant for your system just after sending suspend command. Are not using any sound servers (pulseaudio, jack)?
And since only your speakers are not working afterwards, did your also remove/reload pcskpr module after resume? Did you tried suspending and resuming on a live distribution like mint? I am wondering if there is a dedicated module for those speakers and if they are released cleanly or not at all.

Offline

#7 2014-04-09 06:08:46

orschiro
Member
Registered: 2009-06-04
Posts: 2,136
Website

Re: No speaker audio after resume

I suddenly face the same issue. I also have an snd-hda-intel sound card. It's an Conexant CX20561.

The Master, Headphone, Speakers channels are set to 0 in alsamixer on resume from hibernation.

It used to work before.

Offline

#8 2014-04-09 11:43:44

emeres
Member
Registered: 2013-10-08
Posts: 1,570

Re: No speaker audio after resume

orschiro wrote:

The Master, Headphone, Speakers channels are set to 0 in alsamixer on resume from hibernation.

This sounds more like alsa-restore.service. If only mixer settings are changed, maybe adding [After|WantedBy]=[suspend|hibernate].target  to alsa-restore.service would help. (Proper settings would have to be saved before as root to /var/lib/alsa/asound.state)

Offline

#9 2014-04-10 07:19:15

orschiro
Member
Registered: 2009-06-04
Posts: 2,136
Website

Re: No speaker audio after resume

@emeres

Thanks. I will investigate this. Though it always worked in the past. I don't understand why the service would suddenly fail on resume.

Furthermore, systemctl tells me that it is working fine.

~ systemctl status alsa-restore   
● alsa-restore.service - Restore Sound Card State
   Loaded: loaded (/usr/lib/systemd/system/alsa-restore.service; static)
   Active: inactive (dead) since Do 2014-04-10 08:11:12 CEST; 1h 7min ago
  Process: 408 ExecStart=/usr/bin/alsactl restore (code=exited, status=0/SUCCESS)
 Main PID: 408 (code=exited, status=0/SUCCESS)

Apr 10 08:11:12 thinkpad systemd[1]: Started Restore Sound Card State.

Offline

#10 2014-04-10 10:10:21

emeres
Member
Registered: 2013-10-08
Posts: 1,570

Re: No speaker audio after resume

@orschiro It usually runs only at boot, just like in your case (I do not see any reference to other power state targets than shutdown in any of the alsa services). PA or something else that can control mixer levels might be responsible. Try killing PA before hibernating, if previous levels are sustained, PA is definitely at fault. Other possibility would be changes in the driver or (default) loading options for modules, but you stated that nothing was changed. Either way, using alsa-store and alsa-restore service should fix this. You would have tell systemd to run alsa-store before hibernate.target and alsa-restore after.

Offline

#11 2014-04-20 07:42:41

orschiro
Member
Registered: 2009-06-04
Posts: 2,136
Website

Re: No speaker audio after resume

@emeres

Thanks for your advice!

I think my problem was somewhat related to an old asound.state.

I followed the instructions here [1] and since then my speaker channel is no longer muted anymore on resume.

[1] https://wiki.archlinux.org/index.php/Al … d.state.29

Offline

Board footer

Powered by FluxBB