You are not logged in.

#1 2014-03-10 21:00:56

itektur
Member
Registered: 2014-03-01
Posts: 18

[SOLVED] Missing LADSPA support and bs2b in mpv

I'm missing LADSPA support in mpv. (I know that mplayer2 supports it, in general.) Specifically, when I run mpv the following way, I get an error message:

$ mpv --af=ladspa=/usr/lib/ladspa/cmt.so:amp_stereo:1 some.avi
Option af: ladspa doesn't exist.
Error parsing option af (option parameter could not be parsed)
Setting commandline option --af=ladspa=/usr/lib/ladspa/cmt.so:amp_stereo:1 failed.

Exiting... (Fatal error)

(The path to the LADSPA plugin exists on my system.)

I tried this:

$ mpv --af=help
Available audio filters:
  dummy          : dummy
  delay          : Delay audio filter
  channels       : Insert or remove channels
  format         : Force audio format
  volume         : Volume control audio filter
  equalizer      : Equalizer audio filter
  pan            : Panning audio filter
  surround       : Surround decoder filter
  sub            : Audio filter for adding a sub-base channel
  export         : Sound export filter
  drc            : Dynamic range compression filter
  extrastereo    : Increase difference between audio channels
  lavcac3enc     : runtime encode to ac3 using libavcodec
  lavrresample   : Sample frequency conversion using libavresample
  sweep          : sine sweep
  hrtf           : HRTF Headphone
  center         : Audio filter for adding a center channel
  sinesuppress   : Sine Suppress
  karaoke        : Simple karaoke/voice-removal audio filter
  scaletempo     : Scale audio tempo while maintaining pitch
  lavfi          : libavfilter bridge
  convert24      : Convert between 24 and 32 bit sample format
  convertsignendian: Convert between sample format sign/endian

While man mpv suggests that LADSPA might be supported, it looks like it is actually not, at least not for the current community/mpv 0.3.5-1 release. I looked it up and this site suggests that there is a ladspa flag for compilation which, I presume, has not been used/enabled for compilation here.

EDIT: I just tried the bs2b filter and it fails just the same way:

Option af: bs2b doesn't exist.
Error parsing option af (option parameter could not be parsed)
Setting commandline option --af=bs2b=profile=default failed.

Exiting... (Fatal error)

So, did I forget to install something? Or is it a compilation problem?

Last edited by itektur (2014-03-13 13:11:13)

Offline

#2 2014-03-10 21:30:17

brebs
Member
Registered: 2007-04-03
Posts: 3,742

Re: [SOLVED] Missing LADSPA support and bs2b in mpv

It's a compilation problem wink

I have:

$ mpv --af=help | egrep "ladspa|bs2b"
  ladspa         : LADSPA plugin loader
  bs2b           : Bauer stereophonic-to-binaural audio filter

And during compilation, you should see:

Checking for LADSPA plugin support                    : yes 
Checking for libbs2b audio filter support             : yes

Offline

#3 2014-03-10 22:01:22

itektur
Member
Registered: 2014-03-01
Posts: 18

Re: [SOLVED] Missing LADSPA support and bs2b in mpv

brebs wrote:

It's a compilation problem wink

Thank you for the quick reply. I think that other users might be interested in using LADSPA plugins or other audio/video filters as well, so I wonder what should happen next in order to fix this in the community repo. (I'm new to Arch and I don't compile mpv myself.)

Offline

#4 2014-03-10 22:56:41

brebs
Member
Registered: 2007-04-03
Posts: 3,742

Re: [SOLVED] Missing LADSPA support and bs2b in mpv

File a bug report.

Offline

#5 2014-03-13 13:10:26

itektur
Member
Registered: 2014-03-01
Posts: 18

Re: [SOLVED] Missing LADSPA support and bs2b in mpv

There is a new version of mpv which has LADSPA enabled but not bs2b. Luckily, there is a workaround for bs2b: You simply install ladspa-bs2b (AUR) and use it via LADSPA, e.g.

mpv --af=ladspa=/usr/lib/ladspa/bs2b.so:bs2b:[725,4.5] some.ogg

Offline

Board footer

Powered by FluxBB