You are not logged in.

#1 2014-03-10 22:14:10

vincent7
Member
Registered: 2014-02-27
Posts: 13

Failed to start Remount Root and Kernel File System (systemd)

Hi,

since i updated systemd a couple of days ago, i get an Error while booting.

This is what `systemctl status systemd-remount-fs.service` says:

[user@machine ~]$ systemctl status systemd-remount-fs.service
systemd-remount-fs.service - Remount Root and Kernel File Systems
   Loaded: loaded (/usr/lib/systemd/system/systemd-remount-fs.service; static)
   Active: failed (Result: exit-code) since Mon 2014-03-10 22:58:51 CET; 6min ago
     Docs: man:systemd-remount-fs.service(8)
           http://www.freedesktop.org/wiki/Software/systemd/APIFileSystems
 Main PID: 6966 (code=exited, status=1/FAILURE)

Mar 10 22:58:50 machine systemd-remount-fs[6966]: mount: /etc/fstab: parse error: ignore entry at line 5.
Mar 10 22:58:50 machine systemd-remount-fs[6966]: mount: /etc/fstab: parse error: ignore entry at line 8.
Mar 10 22:58:50 machine systemd-remount-fs[6966]: mount: /etc/fstab: parse error: ignore entry at line 11.
Mar 10 22:58:51 machine systemd-remount-fs[6966]: mount: / not mounted or bad option
Mar 10 22:58:51 machine systemd-remount-fs[6966]: In some cases useful info is found in syslog - try
Mar 10 22:58:51 machine systemd-remount-fs[6966]: dmesg | tail or so.
Mar 10 22:58:51 machine systemd[1]: systemd-remount-fs.service: main process exited, code=exited, status=1/FAILURE
Mar 10 22:58:51 machine systemd[1]: Failed to start Remount Root and Kernel File Systems.
Mar 10 22:58:51 machine systemd[1]: Unit systemd-remount-fs.service entered failed state.

This is what blkid tells me:

/dev/sda1: LABEL="EFI" UUID="70D6-1701" TYPE="vfat" PARTLABEL="EFI System Partition" PARTUUID="0b59a783-8d1f-4923-8136-44151a653b9e" 
/dev/sda2: UUID="0a9de25e-ec90-3e7b-ab65-5ed4b22c2d1f" LABEL="Macintosh HD" TYPE="hfsplus" PARTLABEL="Macintosh HD" PARTUUID="ffbfb815-51bb-4797-b35a-dd4a9acdb63f" 
/dev/sda3: UUID="475699d6-1fac-3da8-b391-f417ce11288c" LABEL="Recovery HD" TYPE="hfsplus" PARTLABEL="Recovery HD" PARTUUID="b855bfe8-52a4-4ed1-bd86-e2f664e95107" 
/dev/sda4: UUID="ab78d78c-bc47-350f-8122-010a538dad81" LABEL="booter" TYPE="hfsplus" PARTLABEL="Boot Part" PARTUUID="3769aa28-2909-487d-a406-108e969b2cc2" 
/dev/sda5: UUID="27af4583-6c81-460f-a027-c2c64379971b" TYPE="ext4" PARTLABEL="Boot" PARTUUID="752d4d1d-e5ad-411e-9b18-8c029b290dd8" 
/dev/sda6: UUID="b9a9f27e-04ca-4141-9b22-ae1c6bd64d3e" TYPE="swap" PARTLABEL="SWAP drive" PARTUUID="a9b32507-f88c-49e5-8566-052dc8c0abf2" 
/dev/sda7: UUID="d18f76b7-96cc-48e2-854a-c361f069c197" TYPE="ext4" PARTLABEL="Root" PARTUUID="4608ccaf-ba93-4b23-8528-2878c6cc1db1"

This is how my fstab looks like:

# 
# /etc/fstab: static file system information
#
# <file system>	<dir>	<type>	<options>	<dump>	<pass>
UUID=d18f76b7-96cc-48e2-854a-c361f069c197
/dev/sda7           	/         	ext4      	rw,relatime,data=ordered	0 1

UUID=27af4583-6c81-460f-a027-c2c64379971b
/dev/sda5           	/boot     	ext4      	rw,relatime,data=ordered	0 2

UUID=b9a9f27e-04ca-4141-9b22-ae1c6bd64d3e
/dev/sda6           	none      	swap      	defaults  	0 0

This is the interesting part of /boot/grub/grub.cfg

### BEGIN /etc/grub.d/10_archlinux ###

menuentry "Arch Linux pkg-linux kernel" --class arch-linux --class arch --class gnu-linux --class gnu --class os {
    if [ x$feature_all_video_module = xy ]; then
        insmod all_video
    fi
    set gfxpayload=keep
    insmod ext2
    if [ x$feature_platform_search_hint = xy ]; then
        search --no-floppy --fs-uuid  --set=root --hint-bios=hd0,gpt5 --hint-efi=hd0,gpt5 --hint-baremetal=ahci0,gpt5  27af4583-6c81-460f-a027-c2c64379971b
    else
        search --no-floppy --fs-uuid  --set=root 27af4583-6c81-460f-a027-c2c64379971b
    fi
    echo 'Loading Arch Linux pkg-linux kernel ...'
    linux /vmlinuz-linux root=UUID=d18f76b7-96cc-48e2-854a-c361f069c197 rw  quiet rootflags=data=writeback
    echo 'Loading Arch Linux pkg-linux kernel initramfs ...'
    initrd /initramfs-linux.img
}


menuentry "Arch Linux pkg-linux kernel (fallback initramfs)" --class arch-linux --class arch --class gnu-linux --class gnu --class os {
    if [ x$feature_all_video_module = xy ]; then
        insmod all_video
    fi
    set gfxpayload=keep
    insmod ext2
    if [ x$feature_platform_search_hint = xy ]; then
        search --no-floppy --fs-uuid  --set=root --hint-bios=hd0,gpt5 --hint-efi=hd0,gpt5 --hint-baremetal=ahci0,gpt5  27af4583-6c81-460f-a027-c2c64379971b
    else
        search --no-floppy --fs-uuid  --set=root 27af4583-6c81-460f-a027-c2c64379971b
    fi
    echo 'Loading Arch Linux pkg-linux kernel ...'
    linux /vmlinuz-linux root=UUID=d18f76b7-96cc-48e2-854a-c361f069c197 rw  quiet rootflags=data=writeback
    echo 'Loading Arch Linux pkg-linux kernel fallback initramfs ...'
    initrd /initramfs-linux-fallback.img
}

### END /etc/grub.d/10_archlinux ###

### BEGIN /etc/grub.d/10_linux ###
menuentry 'Arch Linux, with Linux linux' --class arch --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-linux-advanced-d18f76b7-96cc-48e2-854a-c361f069c197' {
	load_video
	set gfxpayload=keep
	insmod gzio
	insmod part_gpt 
	insmod ext2
	set root='hd0,gpt5'
	if [ x$feature_platform_search_hint = xy ]; then
	  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt5 --hint-efi=hd0,gpt5 --hint-baremetal=ahci0,gpt5  27af4583-6c81-460f-a027-c2c64379971b
	else
	  search --no-floppy --fs-uuid --set=root 27af4583-6c81-460f-a027-c2c64379971b
	fi
	echo	'Loading Linux linux ...'
	linux	/vmlinuz-linux root=UUID=d18f76b7-96cc-48e2-854a-c361f069c197 rw  quiet rootflags=data=writeback
	echo	'Loading initial ramdisk ...'
	initrd	/initramfs-linux.img
}

### END /etc/grub.d/10_linux ###


I already tried this, which is -the way I understand it- checking if the entries in fstab and grub.cfg are correct, compared to what `blkid` says.

But I dont seem to have done it right...

Please help me!

Thanks a lot.

vincent

Offline

#2 2014-03-10 22:59:26

ubunchu
Member
Registered: 2012-05-01
Posts: 176

Re: Failed to start Remount Root and Kernel File System (systemd)

1. Did you use mkinitcpio - linux ? Did you re-generate grub?
2. Downgrade systemd and util-linux? (and others?)
3. Try to remove the "quiet" part of grub, and paste relevant log output?


Don't forget to mark as [SOLVED].

Offline

#3 2014-03-11 15:32:09

vincent7
Member
Registered: 2014-02-27
Posts: 13

Re: Failed to start Remount Root and Kernel File System (systemd)

1. Yes (mkinitcpio -p linux). Yes (grub-mkconfig -o /boot/grub/grub.cfg)
2. I didn't think about this, maybe because everytime someone brings it up here, 10 others yell NO. Should I try it anyway?
3. I removed the "quiet" part but I can't find a "grub.log" in /var/log/. Where are grub log files?

Offline

#4 2014-03-11 15:50:04

falconindy
Developer
From: New York, USA
Registered: 2009-10-22
Posts: 4,100
Website

Re: Failed to start Remount Root and Kernel File System (systemd)

The error is pretty clear. You have invalid entries in your /etc/fstab. Seems like you mangled/uncommented the informational comments that genfstab adds.

Better yet, replace the /dev/sdxy with the UUID=$uuid just above it.

I would suspect that the other error goes away when you fix this. Alternatively, just get rid of the / entry. Your filesystem is already mounted, and you aren't doing anything exotic with it. Remounting serves no purpose.

Last edited by falconindy (2014-03-11 16:08:57)

Offline

#5 2014-03-12 17:26:20

lpb612
Member
Registered: 2009-09-29
Posts: 16

Re: Failed to start Remount Root and Kernel File System (systemd)

I had the same issue. In my case, I was able to solve it by removing the "data=writeback" parameter on the root mount line of the /etc/fstab file. Hope this helps.

Offline

#6 2014-03-12 21:22:01

falconindy
Developer
From: New York, USA
Registered: 2009-10-22
Posts: 4,100
Website

Re: Failed to start Remount Root and Kernel File System (systemd)

lpb612 wrote:

I had the same issue. In my case, I was able to solve it by removing the "data=writeback" parameter on the root mount line of the /etc/fstab file. Hope this helps.

Ah, this is the correct solution. You can't change the journaling mode online.

Offline

#7 2014-03-14 00:42:17

vincent7
Member
Registered: 2014-02-27
Posts: 13

Re: Failed to start Remount Root and Kernel File System (systemd)

I got it to work!

I commented out the /dev/sdXY part and used UUID instead!

But that didn't change anything. Just the parsing errors were solved by that.

I then # commented out the line for / mounting in fstab and that did the trick!

So thanks a lot for the help, esp. falconindy!

I can't say, that I'm too satisfied with that solution because I strickly followed the Beginner's Guide while setting up arch. And it's a "brand" new system (~3 weeks old). So i guess having a / entry in fstab is some kind of default and shouldn't lead to problems.


----

I'm now reading the new comments by lpb612 and falconindy.
Curious about that data=writeback thing.

Are guys talking about fstab or about grub? I have no date=writeback in fstab, but i found one in grub.cfg :

 linux /vmlinuz-linux root=UUID=d18f76b7-96cc-48e2-854a-c361f069c197 rw  quiet rootflags=data=writeback

do you mean that?
how should I edit this out? delete "rootflag=data=writeback" ?

Thanks for your help!!

I'm an arch-newbie/noob coming from ubuntu/debian. Some things are hard to figure out, but it's such a great system and sooo faaaast.

Cheers!

Offline

Board footer

Powered by FluxBB