You are not logged in.

#1 2014-03-14 00:56:44

vibee
Member
Registered: 2013-06-15
Posts: 38

[Solved] Cannot play youtube flash videos with Firefox

Hi,

since a few weeks, I am not able to play youtube flash videos with Firefox with my laptop and my PC. I am running 64bit Arch on both systems. However, using Chromium, it works fine.

The error message is "An error occured, please try again later." for all videos, there is not one video which works.

When starting firefox from the terminal, this is the output when trying to open a flash video:

[VS] Software VDPAU backend library initialized
libva info: VA-API version 0.34.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/dri/i965_drv_video.so
libva info: Found init function __vaDriverInit_0_34
libva info: va_openDriver() returns 0

I already tried to disable hardware acceleration within the settings window. Setting EnableLinuxHWVideoDecode and OverrideGPUValidation to 0 or 1  in /etc/adobe/mms.cfg didn't change anything neither. I also removed the file in ~/.adobe without success.

My hardware is an Intel Ivy Bridge with Intel HD4000 graphics, I also got the 32bit libs installed. My laptop's graphics card is an ATI HD4200, using radeon driver.

I really don't know what else I could try? Also, I am confused that nobody else seems to have this problem, although both of my systems with completely different hardware are affected.

Last edited by vibee (2015-01-12 03:46:42)

Offline

#2 2014-03-14 08:20:00

tumas
Member
Registered: 2012-02-08
Posts: 89

Re: [Solved] Cannot play youtube flash videos with Firefox

Not sure if this is any help, but how does your /etc/adobe/mms.cfg looks like? You could try to enable/disable EnableLinuxHWVideoDecode=1.

Last edited by tumas (2014-03-14 08:20:12)

Offline

#3 2014-03-14 10:35:25

2Karl
Member
From: Rugby, UK
Registered: 2012-03-26
Posts: 56
Website

Re: [Solved] Cannot play youtube flash videos with Firefox

Switch youtube to view HTML5 videos. You could also use VLC to stream them as a workaround.


It's affine day for a new sig:
13XQLTXH?R%20GLVHDVB!1046210467104640201045B104731046F02010458104731045902
010450104681045B1046910462104681046F02E0201045A104731045102010458104750201
04780201046F1046A104510201046902010461104671045B1047202010458104671045102E

Offline

#4 2014-03-16 06:55:49

ConnorBehan
Trusted User (TU)
From: Long Island NY
Registered: 2007-07-05
Posts: 1,356
Website

Re: [Solved] Cannot play youtube flash videos with Firefox

Someone else is having this problem, but so far that post lacks information about how exactly it was solved.


6EA3 F3F3 B908 2632 A9CB E931 D53A 0445 B47A 0DAB
Great things come in tar.xz packages.

Offline

#5 2014-03-20 08:43:34

dispanser
Member
Registered: 2009-04-10
Posts: 20

Re: [Solved] Cannot play youtube flash videos with Firefox

I just added a response to the other thread: installing pulseaudio-alsa worked for me.

HTH

Offline

#6 2014-03-27 21:48:30

kaueraal
Member
Registered: 2012-04-28
Posts: 5

Re: [Solved] Cannot play youtube flash videos with Firefox

Both that and adding an .asoundrc didn't fix it for me.

Offline

#7 2014-03-30 14:02:31

Radioactiveman
Member
From: Germany
Registered: 2010-05-13
Posts: 377

Re: [Solved] Cannot play youtube flash videos with Firefox

I have the same problem but only if https is used.
Do you experience this also with http?

Offline

#8 2014-03-30 15:29:29

kaueraal
Member
Registered: 2012-04-28
Posts: 5

Re: [Solved] Cannot play youtube flash videos with Firefox

I found the problem: I disabled RC4 in my browser.. When re-enabling it, youtube works again... yeah for weak chiphers..

Offline

#9 2014-03-30 16:21:20

Radioactiveman
Member
From: Germany
Registered: 2010-05-13
Posts: 377

Re: [Solved] Cannot play youtube flash videos with Firefox

Doesn't help here, I have even tried a new Firefox profile.

Offline

#10 2014-03-30 18:46:24

kostas213
Member
From: Zürich
Registered: 2012-04-11
Posts: 53

Re: [Solved] Cannot play youtube flash videos with Firefox

I had a similar problem with HTML5 videos. I downgraded to xf86-video-intel to 2.99.910 from 2.99.911 and now everything works.

Offline

#11 2014-04-01 09:17:32

vibee
Member
Registered: 2013-06-15
Posts: 38

Re: [Solved] Cannot play youtube flash videos with Firefox

Hi,

thanks for all replies. One thing I found out about non-working flash videos in firefox is that it has something to do with ALSA. I use mpd which uses an ALSA hardware device for output, meaning that the mpd stream is blocking my audio hardware when playing music. However, I need to completely restart firefox if mpd was running and blocking the flash audio stream, it does not help to just stop the mpd playback. Running chromium, stopping the mpd stream is succifient. Within firefox, it neither helps to kill the plugin-container after stopping mpd playback - somehow, firefox can not play back sound once the audio hardware was run in exclusive mode.

I removed the flash plugin and tried to use the HTML5 player. This does not work neither, it sais "the video is curently unavailible" for any youtube video.

kaueraal wrote:

I found the problem: I disabled RC4 in my browser.. When re-enabling it, youtube works again... yeah for weak chiphers..

I guess that this might be the cause, as I also disabled RC4. I am now using chromium for any flash video playback (installed the pepper flash package) and it works like a charm. It's a bit annoying to switch the browsers for flash or video related content, but I don't want to miss firefox at all.

Radioactiveman wrote:

I have the same problem but only if https is used.
Do you experience this also with http?

You are right, using http instead of https fixes the HTML5 playback.

Last edited by vibee (2014-04-01 09:19:37)

Offline

#12 2014-04-06 15:21:37

matrs
Member
Registered: 2013-05-14
Posts: 11

Re: [Solved] Cannot play youtube flash videos with Firefox

i had problems with youtube and others flash video sites, installing pulseaudio-alsa worked for me  too

Offline

#13 2014-06-22 07:33:42

B-Con
Member
From: USA
Registered: 2007-12-17
Posts: 553
Website

Re: [Solved] Cannot play youtube flash videos with Firefox

kaueraal wrote:

I found the problem: I disabled RC4 in my browser.. When re-enabling it, youtube works again... yeah for weak chiphers..

Kind of late, but for posterity's sake: I had the same problem (YouTube videos) and this was the fix. Went into "about:config" and had to set

security.ssl3.rsa_rc4_128_sha

to "true".

(Amusingly, only one of the other RC4 cipher suites was set to true, because a couple years ago I had a similar problem with the Arch Wiki.)

Last edited by B-Con (2014-06-22 07:35:09)

Offline

Board footer

Powered by FluxBB