You are not logged in.

#1 2014-03-26 19:56:34

Strubbl
Member
Registered: 2013-12-10
Posts: 8

set correct high resolution 2560x1440 with xrandr

Hello,
I am just trying to install the maximum resolution my monitor can handle. This is the resolution 2560x1440. I have an Intel onboard graphic card, please see:


00:02.0 VGA compatible controller: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller (rev 06) (prog-if 00 [VGA controller])
	Subsystem: Gigabyte Technology Co., Ltd Device d000
	Flags: bus master, fast devsel, latency 0, IRQ 42
	Memory at f0000000 (64-bit, non-prefetchable) [size=4M]
	Memory at e0000000 (64-bit, prefetchable) [size=256M]
	I/O ports at f000 [size=64]
	Expansion ROM at <unassigned> [disabled]
	Capabilities: <access denied>
	Kernel driver in use: i915
	Kernel modules: i915

When I want the resolution added to xrandr to be assigned, I get an error message:

$ xrandr
Screen 0: minimum 8 x 8, current 1920 x 1200, maximum 32767 x 32767
VGA1 disconnected (normal left inverted right x axis y axis)
HDMI1 connected 1920x1200+0+0 (normal left inverted right x axis y axis) 597mm x 336mm
   1920x1200      60.0* 
   1600x1200      60.0  
   1680x1050      59.9  
   1280x1024      75.0     60.0  
   1280x800       59.9  
   1152x864       75.0  
   1024x768       75.1     60.0  
   800x600        75.0     60.3  
   640x480        75.0     60.0  
   720x400        70.1  
HDMI2 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)
$ cvt 2560 1440
# 2560x1440 59.96 Hz (CVT 3.69M9) hsync: 89.52 kHz; pclk: 312.25 MHz
Modeline "2560x1440_60.00"  312.25  2560 2752 3024 3488  1440 1443 1448 1493 -hsync +vsync
$ xrandr --newmode "2560x1440_60.00"  312.25  2560 2752 3024 3488  1440 1443 1448 1493 -hsync +vsync
$ xrandr --addmode HDMI1 "2560x1440_60.00"
$ xrandr --output HDMI1 --mode "2560x1440_60.00"
xrandr: Configure crtc 0 failed

My Xorg log file can be found here: https://gist.github.com/Strubbl/9791966

The crazy thing is, that I was using this resolution until yesterday and it worked. So today it does not and it is using 1920x1200 as resolution. Maybe the yesterdays update broke something? I have no idea what this xrandr error "xrandr: Configure crtc 0 failed" means and how I can get my high resolution back.
Any help in solving this issue is appreciated.

Last edited by Strubbl (2014-03-26 20:44:48)

Offline

#2 2014-03-28 14:35:22

lknix
Member
Registered: 2008-10-20
Posts: 11

Re: set correct high resolution 2560x1440 with xrandr

After upgrading yesterday, I'm unable to change to manually added resolution using xrandr. Changing to any other, which are presented in xrandr's output by default, works. I have exactly the same problem as Strubbl (https://bbs.archlinux.org/viewtopic.php?id=179120), but I think this belongs to Kernel & Hardware section.

Sys info

% uname -a 
Linux arch 3.13.7-1-ARCH #1 SMP PREEMPT Mon Mar 24 20:06:08 CET 2014 x86_64 GNU/Linux

% lscpi -v
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09) (prog-if 00 [VGA controller])
	Subsystem: Hewlett-Packard Company Device 17f8
	Flags: bus master, fast devsel, latency 0, IRQ 50
	Memory at c0000000 (64-bit, non-prefetchable) [size=4M]
	Memory at b0000000 (64-bit, prefetchable) [size=256M]
	I/O ports at 4000 [size=64]
	Expansion ROM at <unassigned> [disabled]
	Capabilities: <access denied>
	Kernel driver in use: i915
	Kernel modules: i915

XrandR

% xrandr                                
Screen 0: minimum 320 x 200, current 3286 x 1200, maximum 32767 x 32767
LVDS1 connected primary 1366x768+1920+0 (normal left inverted right x axis y axis) 294mm x 166mm
   1366x768       60.0*+
   1024x768       60.0  
   800x600        60.3     56.2  
   640x480        59.9  
VGA1 disconnected (normal left inverted right x axis y axis)
HDMI1 connected 1920x1200+0+0 (normal left inverted right x axis y axis) 597mm x 336mm
   1920x1200      60.0* 
   1600x1200      60.0  
   1680x1050      59.9  
   1280x1024      75.0     60.0  
   1280x800       59.9  
   1152x864       75.0  
   1024x768       75.1     60.0  
   800x600        75.0     60.3  
   640x480        75.0     60.0  
   720x400        70.1  
   2560x1440_40.00   40.0  
DP1 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)

Steps

% xrandr --newmode "2560x1440_40.00"  201.00  2560 2720 2984 3408  1440 1443 1448 1476 +hsync +vsync
% xrandr --addmode HDMI1 2560x1440_40.00
% xrandr --output HDMI1 --mode 2560x1440_40.00 --verbose
screen 0: 3286x1440 865x379 mm  96.46dpi
crtc 1: 2560x1440_40.00   40.0 +0+0 "HDMI1"
xrandr: Configure crtc 1 failed
crtc 0: disable
crtc 1: disable
crtc 2: disable
screen 0: revert
crtc 0: revert
crtc 1: revert
crtc 2: revert

X.org.0 excerpt

[    13.556] (II) intel(0): switch to mode 2560x1440@40.0 on HDMI1 using pipe 1, position (0, 0), rotation normal, reflection none
[    13.746] (EE) intel(0): failed to set mode: Invalid argument
[    14.111] (II) intel(0): resizing framebuffer to 1920x1200

List of upgraded packages

libedit-20140213_3.1-1-x86_64.pkg.tar.xz
linux-firmware-20140316.dec41bc-1-any.pkg.tar.xz
linux-3.13.7-1-x86_64.pkg.tar.xz
linux-headers-3.13.7-1-x86_64.pkg.tar.xz
cmake-2.8.12.2-2-x86_64.pkg.tar.xz
libmodplug-0.8.8.5-1-x86_64.pkg.tar.xz
libva-1.3.0-1-x86_64.pkg.tar.xz
ffmpeg-compat-1:0.10.12-1-x86_64.pkg.tar.xz
libmikmod-3.3.6-1-x86_64.pkg.tar.xz
nspr-4.10.4-1-x86_64.pkg.tar.xz
nss-3.15.5-1-x86_64.pkg.tar.xz
pango-1.36.3-1-x86_64.pkg.tar.xz
xf86-video-intel-2.99.911-1-x86_64.pkg.tar.xz
glances-1.7.6-1-any.pkg.tar.xz
libsystemd-212-1-x86_64.pkg.tar.xz
libutil-linux-2.24.1-4-x86_64.pkg.tar.xz
systemd-212-1-x86_64.pkg.tar.xz
systemd-sysvcompat-212-1-x86_64.pkg.tar.xz
util-linux-2.24.1-4-x86_64.pkg.tar.xz
sip-4.15.5-2-x86_64.pkg.tar.xz
xcb-proto-1.10-2-any.pkg.tar.xz

I've tried reverting xf86-video-intel-2.99.911-1-x86_64.pkg.tar.xz to a previous version without much luck - the problem stays. Now, I'm guessing this is a kernel bug, so I'm gonna revert the kernel from linux-3.13.7-1 back to linux-3.13.6, since this lower resolution is making my monitor useless.

This issue should also be reported upstream, right?

Does anybody have any other ideas what else should I try?

Thanks!

Last edited by lknix (2014-03-28 14:39:02)

Offline

#3 2014-03-28 14:36:54

lknix
Member
Registered: 2008-10-20
Posts: 11

Re: set correct high resolution 2560x1440 with xrandr

I have this issue, and I've opened a new topic in Kernel & Hardware section: https://bbs.archlinux.org/viewtopic.php?id=179190

Last edited by lknix (2014-03-28 22:35:04)

Offline

#4 2014-03-28 16:01:44

lknix
Member
Registered: 2008-10-20
Posts: 11

Re: set correct high resolution 2560x1440 with xrandr

Reducing frequency from 40Hz to 33Hz gets my 2560x1440 resolution back.

 
% gtf 2560 1440 33                                                                                   
  # 2560x1440 @ 33.00 Hz (GTF) hsync: 48.44 kHz; pclk: 162.77 MHz
  Modeline "2560x1440_33.00"  162.77  2560 2688 2960 3360  1440 1441 1444 1468  -HSync +Vsync

% xrandr --newmode "2560x1440_33.00"  162.77  2560 2688 2960 3360  1440 1441 1444 1468  -HSync +Vsync

% xrandr --addmode HDMI1 2560x1440_33.00

% xrandr --output HDMI1 --mode 2560x1440_33.00

Offline

#5 2014-04-01 21:33:09

Strubbl
Member
Registered: 2013-12-10
Posts: 8

Re: set correct high resolution 2560x1440 with xrandr

Thanks for that hint. I'll follow your topic, too.

Offline

#6 2014-04-01 21:33:54

Strubbl
Member
Registered: 2013-12-10
Posts: 8

Re: set correct high resolution 2560x1440 with xrandr

How did you find out about reducing frequency might help? And where did you get that value 33 Hz from? Guessing??

Offline

#7 2014-04-01 21:47:01

lknix
Member
Registered: 2008-10-20
Posts: 11

Re: set correct high resolution 2560x1440 with xrandr

Strubbl wrote:

How did you find out about reducing frequency might help? And where did you get that value 33 Hz from? Guessing??

I've already done it once. I guessed the values and 33Hz seemed to be the highest possible.

Offline

#8 2014-04-01 22:26:52

jasonwryan
Forum & Wiki Admin
From: .nz
Registered: 2009-05-09
Posts: 18,529
Website

Re: set correct high resolution 2560x1440 with xrandr

Merging...


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#9 2014-04-03 05:10:04

ilkyest
Member
From: Brazil
Registered: 2010-02-13
Posts: 260

Re: set correct high resolution 2560x1440 with xrandr

yes or no lknix... I've ever seen this problem with my "oldies" monitor, when I use, on "20-monitor.conf" the option "IgnoreEDIDChecksum"

Without the ignore seetings nothing more about 1440x900. maybe, repeat, maybe it's a EDID problem

Offline

#10 2014-04-05 07:35:19

frax
Member
Registered: 2014-04-05
Posts: 2

Re: set correct high resolution 2560x1440 with xrandr

This is the recent commit in the intel drivers that disabled 2560x1440 over DVI.

commit 6375b768a9850b6154478993e5fb566fa4614a9c
Author: Ville Syrjälä <ville.syrjala@linux.intel.com>
Date:   Mon Mar 3 11:33:36 2014 +0200

    drm/i915: Reject >165MHz modes w/ DVI monitors
   
    Single-link DVI max dotclock is 165MHz. Filter out modes with higher
    dotclock when the monitor doesn't support HDMI.
   
    Modes higher than 165 MHz were allowed in
   
    commit 7d148ef51a657fd04036c3ed7803da600dd0d451
    Author: Daniel Vetter <daniel.vetter@ffwll.ch>
    Date:   Mon Jul 22 18:02:39 2013 +0200
   
        drm/i915: fix hdmi portclock limits
   
    Also don't attempt to use 12bpc mode with DVI monitors.
   
    Cc: Adam Nielsen <a.nielsen@shikadi.net>
    Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=75345
    Bugzilla: https://bugzilla.kernel.org/show_bug.cgi?id=70331
    Tested-by: Ralf Jung <post+kernel@ralfj.de>
    Cc: stable@vger.kernel.org
    Signed-off-by: Ville Syrjälä <ville.syrjala@linux.intel.com>
    Signed-off-by: Jani Nikula <jani.nikula@intel.com>

The changeset is very small, it is only this:

diff --git a/drivers/gpu/drm/i915/intel_hdmi.c b/drivers/gpu/drm/i915/intel_hdmi.c
index 6db0d9d..ee3181e 100644
--- a/drivers/gpu/drm/i915/intel_hdmi.c
+++ b/drivers/gpu/drm/i915/intel_hdmi.c
@@ -845,7 +845,7 @@ static int hdmi_portclock_limit(struct intel_hdmi *hdmi)
{
        struct drm_device *dev = intel_hdmi_to_dev(hdmi);

-       if (IS_G4X(dev))
+       if (!hdmi->has_hdmi_sink || IS_G4X(dev))
                return 165000;
        else if (IS_HASWELL(dev) || INTEL_INFO(dev)->gen >= 8)
                return 300000;
@@ -899,8 +899,8 @@ bool intel_hdmi_compute_config(struct intel_encoder *encoder,
         * outputs. We also need to check that the higher clock still fits
         * within limits.
         */
-       if (pipe_config->pipe_bpp > 8*3 && clock_12bpc <= portclock_limit
-           && HAS_PCH_SPLIT(dev)) {
+       if (pipe_config->pipe_bpp > 8*3 && intel_hdmi->has_hdmi_sink &&
+           clock_12bpc <= portclock_limit && HAS_PCH_SPLIT(dev)) {
                DRM_DEBUG_KMS("picking bpc to 12 for HDMI output\n");
                desired_bpp = 12*3;

I reverted the first hunk of this commit and built a new custom kernel for my debian box, and that reenabled 2560x1440 over DVI.

My motherboard is:
Gigabyte H87N-Wifi Rev.2 (Two HDMI connectors and one DVI connector)

My display is:
Dell U2713HM (Should only support 2560x1440 over DVI and Displayport)

In my xorg.conf, I have this modeline in my Monitor section:

Modeline "2560x1440R"  241.50  2560 2608 2640 2720  1440 1443 1448 1481 +hsync -vsync

Offline

#11 2014-04-05 11:23:06

graysky
Member
From: /run/user/1000
Registered: 2008-12-01
Posts: 8,440
Website

Re: set correct high resolution 2560x1440 with xrandr

My P8Z77-Pro with onboard HD4000 only supports 2560x1440 over the displayport.  Will not work over DVI or HDMI.


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

#12 2014-04-05 12:08:24

frax
Member
Registered: 2014-04-05
Posts: 2

Re: set correct high resolution 2560x1440 with xrandr

graysky wrote:

My P8Z77-Pro with onboard HD4000 only supports 2560x1440 over the displayport.  Will not work over DVI or HDMI.

My motherboard is not supposed to support higher resolutions than 1920x1200 over DVI either. But it still did before the commit I quoted in my previous post.

Offline

#13 2014-04-09 08:03:40

PedsXing
Member
Registered: 2010-08-15
Posts: 6

Re: set correct high resolution 2560x1440 with xrandr

I have the exact same problem since the update:

Mainboard: Asus Z87-A
Video card: Intel HD 4600
Display: Dell U2713HM

The mainboard specifications says "Supports DVI-D with max. resolution 1920 x 1200 @ 60 Hz", so I guess that is technically working as intended. It's a bit annoying though, considering that I worked fine before ...

Can I expect some upstream solution to this "problem" or should I just buy a DisplayPort cable?

Offline

#14 2014-04-09 10:03:26

PedsXing
Member
Registered: 2010-08-15
Posts: 6

Re: set correct high resolution 2560x1440 with xrandr

I've found that using 2560x1440 over DVI-D actually works if you lower the refresh rate enough to stay within the 165MHz portclock limit. 33Hz is the largest (integer) refreshrate that still works:

xrandr --newmode "2560x1440_33.00"  162.75  2560 2696 2960 3360  1440 1443 1448 1470 -hsync +vsync
xrandr --addmode HDMI1 2560x1440_33.00
xrandr --output HDMI1 --mode 2560x1440_33.00

It's not really a solution though: 33Hz feels horrible. Show that to anyone who claims that 24Hz is enough ...

Offline

#15 2014-04-09 22:02:30

Malvineous
Member
From: Brisbane, Australia
Registered: 2011-02-03
Posts: 119
Website

Re: set correct high resolution 2560x1440 with xrandr

Hi all,

I'm the one who reported this bug as it was causing problems for me with my Dell 3008WFP.

Here is the problem in a nutshell, as you have mostly figured out:

  • DVI single link has a maximum resolution of 1920x1200@60Hz, or higher resolutions at a much lower refresh rate.

  • HDMI is the same as DVI single link, but it extends the spec to allow much higher resolutions, like 2560x1600@60Hz.

  • In order to go above 1920x1200@60Hz, the DVI spec says you must go into dual-link mode, which is not supported by these motherboards.

  • The drivers had a bug which would allow you to exceed the spec by treating the DVI port as if it was a HDMI port, and allowing resolutions beyond 1920x1200@60Hz.  This doesn't work for many monitors, but evidently there are a few that it does work for (possibly those supporting resolutions > 1920x1200 over the HDMI port.)

The only real solution I can think of that would keep everyone happy would be to introduce some override option that removes this limitation and allows you to drive the port and your monitor beyond the spec, with all the risks that entails.  I'm not sure how this could be implemented though, but it would allow you to get your resolution back!

Offline

#16 2014-04-11 18:14:16

Tom B
Member
Registered: 2014-01-15
Posts: 83
Website

Re: set correct high resolution 2560x1440 with xrandr

What's wrong with using Dual-Link DVI? or does the GPU not support it?

Offline

#17 2014-04-15 06:46:55

Malvineous
Member
From: Brisbane, Australia
Registered: 2011-02-03
Posts: 119
Website

Re: set correct high resolution 2560x1440 with xrandr

Yep, they removed hardware support for dual-link DVI :-(  The Intel guys were surprised I had a motherboard with a DVI socket as it's being phased out in favour of DisplayPort.  I'd much rather have three DisplayPort sockets on the (Intel branded) motherboard, but even that's a bit limiting as you can only connect three monitors even if you use DisplayPort 1.2 to physically connect more than three - the GPU will only drive up to three screens.  Here's hoping a future revision will lift that limit and include more DisplayPort sockets so this isn't an issue!

Offline

Board footer

Powered by FluxBB