You are not logged in.

#1 2014-03-27 08:35:10

dudefellaguy
Member
Registered: 2012-02-08
Posts: 21

[Xorg] Some applications have blank fonts; no error messages

I have a really strange problem. In Xorg, dzen2, st, and gvim don't display any glyphs when using the Terminus font. The size/spacing is correct, the applications work fine, background color changes still work, but there aren't any visible characters. They don't print any "font not found" errors while being launched, and the fonts in question are listed in xlsfonts and xselfont, and work with xterm. Here is a screenshot of what I'm talking about.

I have two other machines on which the same configuration works perfectly fine, and I tried using a USB-installtion (again, with the same configuration) on to the problematic machine, and it worked perfectly. I even re-installed Arch from scratch out of frustration, and the problem persisted.

In GVim's font selection dialog, the "Normal" and "Bold" versions display a blank font, but the "Italic" and "Bold Italic" work just fine.

I'm totally stumped. Any ideas?

Offline

#2 2014-04-24 20:08:18

ninian
Member
From: United Kingdom
Registered: 2008-02-24
Posts: 694
Website

Re: [Xorg] Some applications have blank fonts; no error messages

On one - only one - of our family's systems, I have the same problem with the Terminus font. In our case it's using Terminus as the font for LilyTerm. The font and X settings seem the same as on the other systems, but Terminus behaves differently. So I've just sent the font in LilyTerm to Cousine for now.

Offline

Board footer

Powered by FluxBB