You are not logged in.

#1 2014-04-07 15:10:00

thiagowfx
Member
Registered: 2013-07-09
Posts: 552

[SOLVED] No natural scrolling on gnome/GTK applications

Recently I enabled natural scrolling with Xmodmap:

thiago@arch ~ $ cat .Xmodmap 
! -*- conf-Xdefaults -*-
! enable natural scrolling
pointer = 1 2 3 5 4 6 7 8 9 10 11 12

(notice that 4 and 5 are inverted)

It works okay on the majority of applications: chromium, sakura, etc. This applies both to USB Mouse and Laptop Touchpad. Although, it seems that most gnome applications (examples: gitg, nautilus, spacefm) do not respect this setting, keeping normal scrolling. I think it is related to GTK 3.

I did some research but couldn't find relevant results. Some of them included bug reports, others suggested to change the VertScrollDelta option from synclient/Xorg to a negative value. This suggestion worked 100% okay with the touchpad, both on gnome and non-gnome applications, provided that I undid my Xmodmap config. But the USB mouse continued with the same problem (=normal scrolling).

TL;DR: Gnome applications are not honoring xinput/xmodmap settings. Question is: how to enable natural scrolling everywhere, both with mouse and touchpad?

Last edited by thiagowfx (2014-04-17 22:01:19)

Offline

#2 2014-04-07 15:34:35

oldswag
Member
Registered: 2013-10-15
Posts: 1

Re: [SOLVED] No natural scrolling on gnome/GTK applications

I'm a little confused why you used Xmodmap to achieve this. There is a setting in the mouse & touchpad settings for natural scrolling.

Offline

#3 2014-04-07 17:00:15

thiagowfx
Member
Registered: 2013-07-09
Posts: 552

Re: [SOLVED] No natural scrolling on gnome/GTK applications

Forgot to say, I'm using the i3 window manager. What is the package / program name I have to install to get to the gnome settings dialog? I could only find gnome-settings-daemon.

By the way, I used Xmodmap because I want to keep my settings to dotfiles as much as possible, avoiding GUI options (it is easier to keep my configs synchronized to other computers this way).

Offline

#4 2014-04-07 17:23:41

Pse
Member
Registered: 2008-03-15
Posts: 389

Re: [SOLVED] No natural scrolling on gnome/GTK applications

Use dconf and enable natural-scroll in org.gnome.settings-daemon.peripherals.touchpad.

Offline

#5 2014-04-07 20:18:13

thiagowfx
Member
Registered: 2013-07-09
Posts: 552

Re: [SOLVED] No natural scrolling on gnome/GTK applications

It was enabled already.

Offline

#6 2014-04-17 22:01:04

thiagowfx
Member
Registered: 2013-07-09
Posts: 552

Re: [SOLVED] No natural scrolling on gnome/GTK applications

@Pse's suggestion worked for me, but not out-of-the-box. I had to run /usr/lib/gnome-settings-daemon/gnome-settings-daemon to apply the dconf touchpad setting. Also, I'm not inverting 4 and 5 from Xmodmap's pointer anymore.

Last edited by thiagowfx (2014-04-17 22:03:02)

Offline

#7 2014-08-27 01:42:37

Manraj
Member
Registered: 2014-05-03
Posts: 1

Re: [SOLVED] No natural scrolling on gnome/GTK applications

This solution does not work for me. I have enabled Natural scrolling in gnome-settings-daemon  and xmodmap is enabled with

pointer = 1 2 3 5 4 7 6 8 9 10 11 12

This does not enable natural scrolling on GTK apps like Web, Files etc. with regular Mouse.

Offline

#8 2014-08-27 02:37:41

thiagowfx
Member
Registered: 2013-07-09
Posts: 552

Re: [SOLVED] No natural scrolling on gnome/GTK applications

Which DE/WM are you running? Are you running the gnome-settings-daemon? It is not sufficient to just enable the correct option in dconf/gnome-settings; gnome-settings-daemon must also be running.
Another thing: try combinations of those things, e.g., Xmodmap enabled but not gnome-settings-daemon; the converse too; both of them, etc.

If this still not works for you, please open a new thread with your issue, then reference it from here.

Offline

#9 2014-10-22 04:46:10

frigaut
Member
From: Canberra, Australia
Registered: 2009-05-10
Posts: 215
Website

Re: [SOLVED] No natural scrolling on gnome/GTK applications

Thiagowfx,

I'm sorry, can you confirm that you were able to get natural scrolling for:
(a) non gtk3 applications, both with the trackpad (a1) *and* the mouse (a2)?
(b) gtk3 applications, both with the trackpad (b1) *and* the mouse (b2)?

(For me, I have a1, a2, and b1, but b2 is inverted)
Thanks.


Samsung NP900X3F / MBP retina mid-2012.  Archer since 03/2009 / Arch donor

Offline

#10 2014-10-22 05:50:12

progandy
Member
Registered: 2012-05-17
Posts: 3,331

Re: [SOLVED] No natural scrolling on gnome/GTK applications

You'll have to invert not only the buttons, but the scrolling distance, too.  In xinput it might be one of these:
* Synaptics Scrolling Distance (298)
* Evdev Scrolling Distance (274)
Each setting has at least a parameter for vertical scrolling distance and horizontal distance. To invert one axis, use a negative number.

Edit: I have to use these settings to reverse the scroll
up/down invert: swap button 4<>5  and "Synaptics Scrolling Distance" -48 48
left/right invert: swap button 6<>7  and "Synaptics Scrolling Distance" 48 -48
both: swap button 4<>5, 6<>7  and "Synaptics Scrolling Distance" -48 -48
normal: keep buttons 4 5 6 7  and "Synaptics Scrolling Distance" 48 48
(I don't have gnome-settings-daemon)

Last edited by progandy (2014-10-22 05:55:27)


| alias CUTF='LANG=en_XX.UTF-8@POSIX ' |

Offline

#11 2014-10-24 05:05:28

frigaut
Member
From: Canberra, Australia
Registered: 2009-05-10
Posts: 215
Website

Re: [SOLVED] No natural scrolling on gnome/GTK applications

hum... ok. In my case, to get the natural scrolling both with the trackpad *and* the mouse, and for gtk3 and other windows, I only had to set the scrolling, no button swapping:

$ xinput --list-props "pointer:MOSART Semi. 2.4G Keyboard Mouse" | grep scroll
Evdev Scrolling Distance (275):	-1, 1, 1  << that's the mouse (no horiz scrolling button, thus no horiz scrolling setting needed)
$ xinput --list-props "ETPS/2 Elantech Touchpad" | grep scroll
Synaptics Scrolling Distance (301):	-70, -70  << that's the trackpad

Buttons are not swapped:

154:~ $ xmodmap -pp
There are 13 pointer buttons defined.

    Physical        Button
     Button          Code
        1              1
        2              2
        3              3
        4              4
        5              5
        6              6
        7              7
        8              8
        9              9
       10             10
       11             11
       12             12
       13             13

gnome-settings-daemon is not running:

156:~ $ ps auxc | grep daemon | grep gnome
157:~ $ 

But xfsettingsd is (the xfce setting daemon):

157:~ $ ps auxc | grep setting
frigaut    383  0.0  0.4 367420 14884 ?        Ssl  15:38   0:00 xfsettingsd
158:~ $

So, not compatible with your experience. Nonetheless, you pointing to the scrolling property solving the problem, well, ... solved my problem, so thanks a bunch !


Samsung NP900X3F / MBP retina mid-2012.  Archer since 03/2009 / Arch donor

Offline

#12 2014-10-25 00:57:18

thiagowfx
Member
Registered: 2013-07-09
Posts: 552

Re: [SOLVED] No natural scrolling on gnome/GTK applications

@frigaut: I'm afraid I can't help you now, because I switched back to normal (non-natural) scrolling. But I'm happy you had your problem solved anyway.

Offline

Board footer

Powered by FluxBB