You are not logged in.

#1 2014-04-11 22:42:24

HorizonShadow
Member
Registered: 2014-04-11
Posts: 15

Windows 8 won't boot through Gummiboot

I installed arch following the beginner's guide.

I have sda3 set to root, sda4 set to home, and sda 5 set to /boot. sda1 is window's reserved partition, and sda2 is windows itself.

When the gummiboot menu is displayed, I'm presented with three options:

* Arch Linux
* EFI Default Loader
* Reboot Into Firmware Interface

Selecting Arch Linux boots into linux, but selecting EFI Default Loader also loads linux.

I'm assuming I should have set sda1 to /boot instead of sda5, but I'm new to this so correct me if I'm wrong. Is there a way for me to fix this without reinstalling arch?

Offline

#2 2014-04-11 23:02:14

Head_on_a_Stick
Member
From: Asteroid B-612
Registered: 2014-02-20
Posts: 3,850
Website

Re: Windows 8 won't boot through Gummiboot

From the wiki:

Note: Gummiboot will automatically check for "Windows Boot Manager" (\EFI\Microsoft\Boot\Bootmgfw.efi), "EFI Shell" (\shellx64.efi) and "EFI Default Loader" (\EFI\Boot\bootx64.efi), and display entries for them if they are present, so you do not have to manually create entries for them. However it does not autodetect other EFI applications (unlike rEFInd), so for booting the kernel, manual config entries must be created as mentioned above.

It doesn't matter if your /boot is on /dev/sda5; I had mine on /dev/sda2 for a while & it worked fine... (it is positioned at the "end" of the drive, in the last sectors and still works)
You could try running:

# gummiboot update

_0_
__0
000

Offline

#3 2014-04-12 12:17:23

HorizonShadow
Member
Registered: 2014-04-11
Posts: 15

Re: Windows 8 won't boot through Gummiboot

Alright, it's putting the same EFI into both directories.

# gummiboot update
Copied /usr/lib/gummiboot/gummibootx64.efi to /boot/EFI/gummiboot/gummibootx64.efi.
Copied /usr/lib/gummiboot/gummibootx64.efi to /boot/EFI/Boot/BOOTX64.EFI.

Offline

#4 2014-04-12 18:03:14

Head_on_a_Stick
Member
From: Asteroid B-612
Registered: 2014-02-20
Posts: 3,850
Website

Re: Windows 8 won't boot through Gummiboot

Sorry, I've just read man gummiboot (should have done that first really...) & all "gummiboot update" does is update the installed versions of gummiboot: not what I thought sad
I'm not using gummiboot at the moment so you'll have to excuse me; the gummiboot wiki may be of more use to you wink


_0_
__0
000

Offline

#5 2014-04-13 13:24:15

HorizonShadow
Member
Registered: 2014-04-11
Posts: 15

Re: Windows 8 won't boot through Gummiboot

Alright, thanks for the help anyway.

All the wiki says is " Both Gummiboot and rEFInd autodetect Windows Boot Manager \EFI\Microsoft\Boot\bootmgfw.efi and show it in their boot menu, so there is no manual config required. ", which is less than helpful. I believe I read something last night stating that gummiboot was a boot manager, and I still needed a boot loader, is this true? I'm new to this, so excuse me if that's a foolish question.

Offline

#6 2014-04-13 14:41:38

Head_on_a_Stick
Member
From: Asteroid B-612
Registered: 2014-02-20
Posts: 3,850
Website

Re: Windows 8 won't boot through Gummiboot

Gummiboot is a boot manager for use with the latest linux kernel --- the kernel can boot itself up without a bootloader wink
See the wiki entry on EFISTUB for more on this...
EDIT: this also means that gummiboot will not boot windows: it doesn't have the capability to boot itself...

Last edited by Head_on_a_Stick (2014-04-13 16:20:02)


_0_
__0
000

Offline

#7 2014-04-13 16:52:55

HorizonShadow
Member
Registered: 2014-04-11
Posts: 15

Re: Windows 8 won't boot through Gummiboot

See, that doesn't sound good.

So how do I boot windows if the only OS I can boot to is Arch?

Offline

#8 2014-04-13 17:50:09

Head_on_a_Stick
Member
From: Asteroid B-612
Registered: 2014-02-20
Posts: 3,850
Website

Re: Windows 8 won't boot through Gummiboot

You'll have to use GRUB, as described in the wiki...
As long as you have installed os-prober before you run

grub-mkconfig -o /boot/grub/grub.cfg

it should detect your windows installation --- fingers crossed wink


_0_
__0
000

Offline

#9 2014-04-13 18:06:03

HorizonShadow
Member
Registered: 2014-04-11
Posts: 15

Re: Windows 8 won't boot through Gummiboot

# grub-mkconfig -o /boot/grub/grub.cfg
Generating grub configuration file ...
Found linux image: /boot/initramfs-linux.img
Found fallback initramfs image: /boot/initramfs-linux-fallback.img
Found linux image: /boot/vmlinuz-linux
Found inited image: /boot/initramfs-linux.img
    /dev/cdrom: open failed: no medium found
    No volume groups found
done

I'm glad I don't store any important data on this box. The only thing I lose of I can't boot back into windows is ~90 gigs of space.

Last edited by HorizonShadow (2014-04-13 18:06:37)

Offline

#10 2014-04-13 18:35:14

Head_on_a_Stick
Member
From: Asteroid B-612
Registered: 2014-02-20
Posts: 3,850
Website

Re: Windows 8 won't boot through Gummiboot

Did you follow the instructions in the link I posted?
In particular, did you run

# grub-install --target=x86_64-efi --efi-directory=/boot --bootloader-id=arch_grub --recheck

before the grub-mkconfig step?
It does note that

os-prober is not known to properly detect UEFI OSes

I think there may be an error in the beginners guide because this section claims the mkconfig command should be

# grub-mkconfig -o /boot/efi/EFI/GRUB/grub.cfg

in UEFI-GPT mode...
Also, I'm very sorry but my previous "EDIT" regarding gummiboot & windows is not correct --- gummiboot should load up the windows bootloader (as described in the wiki entry in my first post); I wasn't paying attention there...


_0_
__0
000

Offline

#11 2014-04-13 18:52:38

HorizonShadow
Member
Registered: 2014-04-11
Posts: 15

Re: Windows 8 won't boot through Gummiboot

Thanks, I didn't notice there was a link in your post.

Following those directions in the wiki gave me the same output as previous. I rebooted, and booted into grub. The only options presented were linux.

Running grub-mkconfig -o /boot/efi/EFI/GRUB/grub.cfg throws an error about the location not existing.

Offline

#12 2014-04-13 19:48:19

olive
Member
From: Belgium
Registered: 2008-06-22
Posts: 1,110

Re: Windows 8 won't boot through Gummiboot

Head_on_a_Stick wrote:

Gummiboot is a boot manager for use with the latest linux kernel --- the kernel can boot itself up without a bootloader wink
See the wiki entry on EFISTUB for more on this...
EDIT: this also means that gummiboot will not boot windows: it doesn't have the capability to boot itself...

Gummiboot can boot Windows. In UEFI mode, the firmware execute an UEFI application; the Linux kernel is such an application (if EFISTUB is enabled); rather than saying that the kernel boot without a bootloader it is better to say see the UEFI firmware act as a bootloader for UEFI applications, including the kernel. Gummit is a simple UEFI application that present a menu allowing another UEFI application to be executed; normally the UEFI firmware have this capability too but for some reasons, it can pose problems. For booting Windows, you should execute the Windows bootloader; which is an UEFI application (I think the name is something like bootmgr.efi); it will take care of the rest.

Last edited by olive (2014-04-13 19:50:15)

Offline

#13 2014-04-13 20:04:48

Head_on_a_Stick
Member
From: Asteroid B-612
Registered: 2014-02-20
Posts: 3,850
Website

Re: Windows 8 won't boot through Gummiboot

^Yes @olive you're completely right, a mistake on my part, sorry all sad


_0_
__0
000

Offline

#14 2014-04-13 20:08:01

HorizonShadow
Member
Registered: 2014-04-11
Posts: 15

Re: Windows 8 won't boot through Gummiboot

I don't suppose what @olive wrote helps me, does it?

I feel like this is such a trivial problem, but I don't have any knowledge of the subject to peice it together myself.

Offline

#15 2014-04-13 20:13:06

Head_on_a_Stick
Member
From: Asteroid B-612
Registered: 2014-02-20
Posts: 3,850
Website

Re: Windows 8 won't boot through Gummiboot

HorizonShadow wrote:

Running grub-mkconfig -o /boot/efi/EFI/GRUB/grub.cfg throws an error about the location not existing.

Confusing... hmm
If you boot into your arch installation & run

efivars -l

does it give you a list of efi variables?
Its not a trivial problem, don't worry; but there is something I've missed here sad
@olive's statement is correct, but according to the wiki entry on gummiboot it should auto-detect windows & provide an entry for it.
EDIT: if you go into your BIOS options during bootup, can you see an entry for the windows bootloader there? Also: can you post the output of

# blkid

Last edited by Head_on_a_Stick (2014-04-13 20:17:01)


_0_
__0
000

Offline

#16 2014-04-13 20:21:07

the.ridikulus.rat
Member
From: Indiana, USA
Registered: 2011-10-04
Posts: 765

Re: Windows 8 won't boot through Gummiboot

HorizonShadow wrote:

I installed arch following the beginner's guide.

I have sda3 set to root, sda4 set to home, and sda 5 set to /boot. sda1 is window's reserved partition, and sda2 is windows itself.

When the gummiboot menu is displayed, I'm presented with three options:

* Arch Linux
* EFI Default Loader
* Reboot Into Firmware Interface

Selecting Arch Linux boots into linux, but selecting EFI Default Loader also loads linux.

I'm assuming I should have set sda1 to /boot instead of sda5, but I'm new to this so correct me if I'm wrong. Is there a way for me to fix this without reinstalling arch?

Can you post the partition table or bootinfoscript output? I suspect Windows in your system might be installed in bios-mbr mode.

Offline

#17 2014-04-13 20:25:50

HorizonShadow
Member
Registered: 2014-04-11
Posts: 15

Re: Windows 8 won't boot through Gummiboot

Alright, here we go.

Output from blkid:

/dev/sda1: LABEL="System Reserved" UUID="A4BE1067BE1033F0" TYPE="ntfs" PARTLABEL="Microsoft basic data" PARTUUID="ed86519a-0271-4623-bd41-e2c2bdac78cd" 
/dev/sda2: UUID="D24612E74612CBDB" TYPE="ntfs" PARTLABEL="Microsoft basic data" PARTUUID="625b15f6-2acd-4cc2-86d7-1bdb716d3eae" 
/dev/sda3: UUID="d56a6256-b2b8-4405-bfb8-0fdd9d3f32f6" TYPE="ext4" PARTLABEL="Root" PARTUUID="a5081c18-4449-44e9-bdf9-5a8f56638336" 
/dev/sda4: UUID="03856671-3821-4eee-82be-9faf0d66089a" TYPE="ext4" PARTLABEL="Home" PARTUUID="f2516259-d55a-4feb-a9e4-b864e266dc7d" 
/dev/sda5: UUID="36D0-C0F7" TYPE="vfat" PARTLABEL="EFI System Partition" PARTUUID="0121d5ba-d767-4278-9f8c-76170a157f4f" 
/dev/sdb1: LABEL="My Passport" UUID="F474B7AA74B76DCC" TYPE="ntfs" PARTUUID="0005f107-01" 

output from lsblk:

NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sda      8:0    0 111.8G  0 disk 
├─sda1   8:1    0   100M  0 part 
├─sda2   8:2    0  82.4G  0 part 
├─sda3   8:3    0    15G  0 part /
├─sda4   8:4    0    14G  0 part /home
└─sda5   8:5    0   100M  0 part /boot
sdb      8:16   0   1.8T  0 disk 
└─sdb1   8:17   0   1.8T  0 part 
sr0     11:0    1  1024M  0 rom  

output from efivars -l

bash: efivars: command not found

Regarding the boot options on startup, the only options I have are Arch Linux, and UEFI OS, both of which boot to linux.

Offline

#18 2014-04-13 20:35:36

the.ridikulus.rat
Member
From: Indiana, USA
Registered: 2011-10-04
Posts: 765

Re: Windows 8 won't boot through Gummiboot

HorizonShadow wrote:

Alright, here we go.

Output from blkid:

/dev/sda1: LABEL="System Reserved" UUID="A4BE1067BE1033F0" TYPE="ntfs" PARTLABEL="Microsoft basic data" PARTUUID="ed86519a-0271-4623-bd41-e2c2bdac78cd" 
/dev/sda2: UUID="D24612E74612CBDB" TYPE="ntfs" PARTLABEL="Microsoft basic data" PARTUUID="625b15f6-2acd-4cc2-86d7-1bdb716d3eae" 
/dev/sda3: UUID="d56a6256-b2b8-4405-bfb8-0fdd9d3f32f6" TYPE="ext4" PARTLABEL="Root" PARTUUID="a5081c18-4449-44e9-bdf9-5a8f56638336" 
/dev/sda4: UUID="03856671-3821-4eee-82be-9faf0d66089a" TYPE="ext4" PARTLABEL="Home" PARTUUID="f2516259-d55a-4feb-a9e4-b864e266dc7d" 
/dev/sda5: UUID="36D0-C0F7" TYPE="vfat" PARTLABEL="EFI System Partition" PARTUUID="0121d5ba-d767-4278-9f8c-76170a157f4f" 
/dev/sdb1: LABEL="My Passport" UUID="F474B7AA74B76DCC" TYPE="ntfs" PARTUUID="0005f107-01" 

From sda1 it looks like you had Windows installed in BIOS-MBR mode but later you converted your disk to GPT, created an EFI System Partition sda5 and installed Arch in UEFI-GPT mode.

You can fix this by making sure Windows uses UEFI-GPT mode, which will then be auto-detected by Gummiboot. This can be done by booting into Windows ISO (make sure in UEFI mode, not in BIOS mode), and then select "repair your computer" or similar option. It should automatically fix the issue by copying necessary Windows bootmgr files to the ESP sda5 and recreate the BCD (eqv to grub.cfg etc.) file, which then set up Windows to boot in UEFI-GPT mode. I also suggest reading about "bcdboot" command just in case the Windows ISO does not auto repair your system.

EDIT: One issue that might occur once Windows does its repair work is that "Windows Boot Manager" will be added to the top of firmware boot manager list, so you system might boot directly into Windows unless you boot into linux ISO (or the firmware setup in some cases) and change the boot order to place gummiboot above windows bootmgr.

output from efivars -l

bash: efivars: command not found

Regarding the boot options on startup, the only options I have are Arch Linux, and UEFI OS, both of which boot to linux.

It is "efivar" not "efivars" (ie. singular, not plural).

Last edited by the.ridikulus.rat (2014-04-13 22:46:12)

Offline

#19 2014-04-13 20:44:46

Head_on_a_Stick
Member
From: Asteroid B-612
Registered: 2014-02-20
Posts: 3,850
Website

Re: Windows 8 won't boot through Gummiboot

HorizonShadow wrote:

Alright, here we go.

Output from blkid:

/dev/sda1: LABEL="System Reserved" UUID="A4BE1067BE1033F0" TYPE="ntfs" PARTLABEL="Microsoft basic data" PARTUUID="ed86519a-0271-4623-bd41-e2c2bdac78cd" 
/dev/sda2: UUID="D24612E74612CBDB" TYPE="ntfs" PARTLABEL="Microsoft basic data" PARTUUID="625b15f6-2acd-4cc2-86d7-1bdb716d3eae" 
/dev/sda3: UUID="d56a6256-b2b8-4405-bfb8-0fdd9d3f32f6" TYPE="ext4" PARTLABEL="Root" PARTUUID="a5081c18-4449-44e9-bdf9-5a8f56638336" 
/dev/sda4: UUID="03856671-3821-4eee-82be-9faf0d66089a" TYPE="ext4" PARTLABEL="Home" PARTUUID="f2516259-d55a-4feb-a9e4-b864e266dc7d" 
/dev/sda5: UUID="36D0-C0F7" TYPE="vfat" PARTLABEL="EFI System Partition" PARTUUID="0121d5ba-d767-4278-9f8c-76170a157f4f" 
/dev/sdb1: LABEL="My Passport" UUID="F474B7AA74B76DCC" TYPE="ntfs" PARTUUID="0005f107-01" 

output from lsblk:

NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sda      8:0    0 111.8G  0 disk 
├─sda1   8:1    0   100M  0 part 
├─sda2   8:2    0  82.4G  0 part 
├─sda3   8:3    0    15G  0 part /
├─sda4   8:4    0    14G  0 part /home
└─sda5   8:5    0   100M  0 part /boot
sdb      8:16   0   1.8T  0 disk 
└─sdb1   8:17   0   1.8T  0 part 
sr0     11:0    1  1024M  0 rom  

output from efivars -l

bash: efivars: command not found

Regarding the boot options on startup, the only options I have are Arch Linux, and UEFI OS, both of which boot to linux.

Sorry again should be "efivar -l", no plural... sad
Are those the options present in your BIOS menu (ie when you press <esc> or f2 or whatever during startup), or the options in the gummiboot menu? I meant the former wink
EDIT: @the.ridikulus.rat got there first sad

Last edited by Head_on_a_Stick (2014-04-13 20:45:26)


_0_
__0
000

Offline

#20 2014-04-13 21:04:50

HorizonShadow
Member
Registered: 2014-04-11
Posts: 15

Re: Windows 8 won't boot through Gummiboot

4a67b082-0a4c-41cf-b6c7-440b29bb8c4f-LoaderTimeExecUSec
4a67b082-0a4c-41cf-b6c7-440b29bb8c4f-LoaderEntrySelected
4a67b082-0a4c-41cf-b6c7-440b29bb8c4f-LoaderEntriesAuto
4a67b082-0a4c-41cf-b6c7-440b29bb8c4f-LoaderImageIdentifier
4a67b082-0a4c-41cf-b6c7-440b29bb8c4f-LoaderDevicePartUUID
4a67b082-0a4c-41cf-b6c7-440b29bb8c4f-LoaderDeviceIdentifier
4a67b082-0a4c-41cf-b6c7-440b29bb8c4f-LoaderFirmwareType
4a67b082-0a4c-41cf-b6c7-440b29bb8c4f-LoaderFirmwareInfo
4a67b082-0a4c-41cf-b6c7-440b29bb8c4f-LoaderInfo
4a67b082-0a4c-41cf-b6c7-440b29bb8c4f-LoaderTimeInitUSec
ec87d643-eba4-4bb5-a1e5-3f3e36b20da9-MeEndOfPostFlag
1b838190-4625-4ead-abc9-cd5e6af18fe0-HiiDB
7b77fb8b-1e0d-4d7e-953f-3980a261e077-AfterReadyToBoot
8be4df61-93ca-11d2-aa0d-00e098032b8c-BootCurrent
ec87d643-eba4-4bb5-a1e5-3f3e36b20da9-InBiosSetupFlag
ef152fb4-7b2f-427d-bdb4-7e0a05826e64-BootFlow
8be4df61-93ca-11d2-aa0d-00e098032b8c-LangCodes
8be4df61-93ca-11d2-aa0d-00e098032b8c-PlatformLangCodes
ec87d643-eba4-4bb5-a1e5-3f3e36b20da9-AmiGopPolicySetupData
8be4df61-93ca-11d2-aa0d-00e098032b8c-ErrOutDev
8be4df61-93ca-11d2-aa0d-00e098032b8c-ConInDev
560bf58a-1e0d-4d7e-953f-2980a261e031-PNP0510_0_VV
560bf58a-1e0d-4d7e-953f-2980a261e031-PNP0501_0_VV
560bf58a-1e0d-4d7e-953f-2980a261e031-PNP0400_0_VV
8be4df61-93ca-11d2-aa0d-00e098032b8c-ConOutDev
c811fa38-42c8-4579-a9bb-60e94eddfb34-USB_POINT
ec87d643-eba4-4bb5-a1e5-3f3e36b20da9-UsbMassDevValid
ec87d643-eba4-4bb5-a1e5-3f3e36b20da9-UsbMassDevNum
8be4df61-93ca-11d2-aa0d-00e098032b8c-OsIndicationsSupported
ec87d643-eba4-4bb5-a1e5-3f3e36b20da9-NBPlatformData
ec87d643-eba4-4bb5-a1e5-3f3e36b20da9-SetupPlatformData
e6c2f70a-b604-4877-85ba-deec89e117eb-PchS3Peim
4bafc2b4-02dc-4104-b236-d6f1b98d9e84-S3SS
8be4df61-93ca-11d2-aa0d-00e098032b8c-SetupMode
8be4df61-93ca-11d2-aa0d-00e098032b8c-SecureBoot
ec87d643-eba4-4bb5-a1e5-3f3e36b20da9-BootFromUSB
8be4df61-93ca-11d2-aa0d-00e098032b8c-Boot0001
8be4df61-93ca-11d2-aa0d-00e098032b8c-Boot0003
8be4df61-93ca-11d2-aa0d-00e098032b8c-Boot0004
8be4df61-93ca-11d2-aa0d-00e098032b8c-Boot0000
ec87d643-eba4-4bb5-a1e5-3f3e36b20da9-Setup
8be4df61-93ca-11d2-aa0d-00e098032b8c-ShortCutFlag
8be4df61-93ca-11d2-aa0d-00e098032b8c-BiosShotCute
ec87d643-eba4-4bb5-a1e5-3f3e36b20da9-SetupHWMOneof
d1405d16-7afc-4695-bb12-41459d3695a2-NetworkStackVar
7b77fb8b-1e0d-4d7e-953f-3980a261e077-IccAdvancedSetupDataVar
ec87d643-eba4-4bb5-a1e5-3f3e36b20da9-UsbSupport
b544906c-ebd6-4c50-a57a-3da99586a32d-MyFavorite
93c483a1-d3fa-4e92-b437-733b2a346e23-VARSTORE_OCMR_TIMING_SETTINGS_NAME
c811fa38-42c8-4579-a9bb-60e94eddfb34-AMITSESetup
8be4df61-93ca-11d2-aa0d-00e098032b8c-Timeout
8be4df61-93ca-11d2-aa0d-00e098032b8c-PlatformLang
8be4df61-93ca-11d2-aa0d-00e098032b8c-BiosEventLog
8be4df61-93ca-11d2-aa0d-00e098032b8c-Boot0002
b540a530-6978-4da7-91cb-7207d764d262-FastBootOption
f61b2305-aac3-4c9d-8f25-3a4313f9cc0e-EPUflag
8be4df61-93ca-11d2-aa0d-00e098032b8c-FTMActiveFlag
4c19049f-4137-4dd3-9c10-8b97a83ffdfa-MemoryTypeInformation
4c19049f-4137-4dd3-9c10-8b97a83ffdfa-PreviousMemoryTypeInformation
c020489e-6db2-4ef2-9aa5-ca06fc11d36a-AcpiGlobalVariable
af9ffd67-ec10-488a-9dfc-6cbf5ee22c2e-AcpiGlobalVariable
5d6b998a-e304-4088-9087-130c917fb1ae-HiiDataSize
ec87d643-eba4-4bb5-a1e5-3f3e36b20da9-FirstBootFlag
2485da8e-ded2-42cb-acb0-3ce666c55f0c-SetupEntry
15a9dd61-e4f8-4a99-80db-353b13d76490-NVRAM_Verify
3c4ead08-45ae-4315-8d15-a60eaa8caf69-DefaultLegacyDevOrder
45cf35f6-0d6e-4d04-856a-0370a5b16f53-DefaultBootOrder
ec87d643-eba4-4bb5-a1e5-3f3e36b20da9-IccLockDefault
8be4df61-93ca-11d2-aa0d-00e098032b8c-Lang
c05fba7d-7a92-49e0-bcee-233b14dca803-VARSTORE_OCMR_SETTINGS_NAME
ec87d643-eba4-4bb5-a1e5-3f3e36b20da9-SetupHWMFeatures
8be4df61-93ca-11d2-aa0d-00e098032b8c-BootOrder
a56074db-65fe-45f7-bd21-2d2bdd8e9652-OldLegacyDevOrder
a56074db-65fe-45f7-bd21-2d2bdd8e9652-LegacyDevOrder
8be4df61-93ca-11d2-aa0d-00e098032b8c-ErrOut
8be4df61-93ca-11d2-aa0d-00e098032b8c-ConIn
8be4df61-93ca-11d2-aa0d-00e098032b8c-ConOut
560bf58a-1e0d-4d7e-953f-2980a261e031-PNP0510_0_NV
560bf58a-1e0d-4d7e-953f-2980a261e031-PNP0501_0_NV
560bf58a-1e0d-4d7e-953f-2980a261e031-PNP0400_0_NV
ec87d643-eba4-4bb5-a1e5-3f3e36b20da9-PreVgaInfo
ec87d643-eba4-4bb5-a1e5-3f3e36b20da9-SetupAPMFeatures
40312829-7891-4abd-b200-0c541b061939-MemCeil.
58cd8089-e2d9-4b84-88b8-3da497dba390-MemoryFreq
4b3082a3-80c6-4d7e-9cd0-583917265df1-WriteOnceStatus
a31b27a4-cae6-48ff-8c5a-294221e6f389-PchInitPei
981ceaee-931c-4a17-b9c8-66c7bcfd77e1-SecureBootSetup
8be4df61-93ca-11d2-aa0d-00e098032b8c-PK
8be4df61-93ca-11d2-aa0d-00e098032b8c-KEK
d719b2cb-3d3a-4596-a3bc-dad00e67656f-db
d719b2cb-3d3a-4596-a3bc-dad00e67656f-dbx
01f33c25-764d-43ea-aeea-6b5a41f3f3e8-SbAslBufferPtrVar
8be4df61-93ca-11d2-aa0d-00e098032b8c-OsIndications
87f22dcb-7304-4105-bb7c-317143ccc23b-MrcS3Resume
ec87d643-eba4-4bb5-a1e5-3f3e36b20da9-NumOfPState
1456cc6e-22ac-5289-33ba-2e13bbdabaee-CPUS3APICID
01368881-c4ad-4b1d-b631-d57a8ec8db6b-FPDT_Variable
e6c2f70a-b604-4877-85ba-deec89e117eb-PchInit
78ce2354-cfbc-4643-aeba-07a27fa892bf-WdtPersistentData
c89dc9c7-5105-472c-a743-b1621e142b41-CMOSfailflag
dde1bc72-d45e-4209-ab85-14462d2f5074-HobRomImage
9d0da369-540b-46f8-85a0-2b5f2c301e15-EfiTime
01368881-c4ad-4b1d-b631-d57a8ec8db6b-MonotonicCounter
4599d26f-1a11-49b8-b91f-858745cff824-StdDefaults

Offline

#21 2014-04-13 21:08:01

Head_on_a_Stick
Member
From: Asteroid B-612
Registered: 2014-02-20
Posts: 3,850
Website

Re: Windows 8 won't boot through Gummiboot

^ So your arch installation is successfully installed & booting up in EFI mode smile
I think you should follow @the.ridikulus.rat's suggestion, he's bang on the money...


_0_
__0
000

Offline

#22 2014-04-13 22:19:42

HorizonShadow
Member
Registered: 2014-04-11
Posts: 15

Re: Windows 8 won't boot through Gummiboot

Alright, thanks.

Edit: Everything's working! Thank you so much.

Last edited by HorizonShadow (2014-04-14 02:37:19)

Offline

#23 2014-04-14 09:00:30

Head_on_a_Stick
Member
From: Asteroid B-612
Registered: 2014-02-20
Posts: 3,850
Website

Re: Windows 8 won't boot through Gummiboot

Wonderful news smile
Mark the title of the thread as [SOLVED] to help others with this problem...


_0_
__0
000

Offline

#24 2014-04-22 02:58:12

tjfriese
Member
Registered: 2012-07-26
Posts: 5

Re: Windows 8 won't boot through Gummiboot

I have this exact same issue from an install done this evening.

Computer loads Arch by default, but if I press F11 at boot I can choose between Windows and Linux boot loaders. Gummiboot has not detected my Windows partition, I don't even see a menu of any kind when I load the Linux boot loader. I have verified that I am loading windows in UEFI mode. I did the install from a UEFI USB key with Windows 8.1 on it.

Is there a way to set up gummiboot config for Windows 8.1 such that it will be forced to display a boot menu?

Offline

#25 2014-04-22 03:54:46

ramkatral
Member
Registered: 2014-04-21
Posts: 29

Re: Windows 8 won't boot through Gummiboot

You're likely not seeing a menu or anything because the bootmanager is directly loading your kernel, which it is certainly capable of doing.  I'm still kinda new to gummiboot, being an old school LILO and Legacy GRUB guy, but I am pretty sure you will need a shared  EFI partition to use gummi to boot both operating systems.  I think I saw somewhere in the wiki that it's limited to only being able to boot systems on its own partition.

Offline

Board footer

Powered by FluxBB