You are not logged in.

#1 2006-01-17 17:23:12

From: USA
Registered: 2004-06-25
Posts: 533

Midi eawpatches timidity++ xmms-midi

I have alot of original midi's I made a long time ago when I used
windows. I know there kinda obsolete nowadays but they sound
awsome and I spent alot of time trying to get midi sound to work
on my system. Most of this was trial and error but finally everything works
great and I thought i would just offer the things I did to get it working
so it might help somone els. Also I'm running under kde if it makes any

First I installed timidity from extra with no problems.

Then I got eawpatches pkgbuild from this thread and did a makepkg
with no prblems and installed. You will need fake root installed for
making pkg's with PKGBUILDS. the wiki is pretty good explaining
that. … eawpatches

or you can get the pkg eawpatches-12-s1.pkg.tar.gz from trusted repo's

then I edited /etc/timidity++/timidity.cfg so it points to the correct location. My timidity.cfg is below.

#on my debian: /usr/local/share/timidity/timidity.cfg
dir /usr/share/timidity
source gravis.cfg
source gsdrums.cfg
source gssfx.cfg
source xgmap2.cfg
#dir /home/user/patches/
#mid -> wav: timidity input.mid -Ow1S -s 44100 -o output.wav

Then I copied timidity.cfg to  /usr/local/share/timidity but im not sure
if I needed to do this or not. I think I just did it out of desperation when
things weren't working.

Next I made sure I had all the moduals for sound loading in my rc.conf
file... I'll just post my whole modules line....

MODULES=(!usbserial uhci-hcd !ide-scsi 8139too eepro100 nvidia
snd-emu10k1 snd-pcm-oss snd-seq-oss snd-seq-midi
snd-emu10k1-synth snd-mixer-oss)

I don't think i needed to load !ide-scsi anymore but that's a different topic
that I'll tackle later.

Next I made sure that under Controle Center - Sound System - Hardware
I have Advanced Linux Sound Architecture enabled. And Under MIDI device
I enabled Timidity Timidity port 1 - ALSA Device
I'm alittle fuzzy about this choice but thats what I chose and it works.

After this I can play midi using timidity with no switches in the console just
entering # timidity /path/foo.mid
If i start timidity with the -ig switch for gtk gui i get a buffer error, but
if I start with the ik gui switch it works fine. I'm not sure what the deal
is with that. I wasn't to concerned with that since I want to use timidity
through xmms to make things easier.

Last I installed xmms-midi plugin using the package build from this
thread, but I had to edit the pkgbuild because it's a very old one. … t=xmmsmidi

Here's the edited PKGBUILD that works for me.

# $Id: $
# Contributor: forest76 <>
pkgdesc="Allow play midi by xmms with timidity"
depends=('glibc' 'xmms' 'timidity++' 'gtk')
build() {
cd $startdir/src/$pkgname-$pkgver
./configure --prefix=/usr/lib
make || return 1
make libdir=$startdir/pkg/usr/lib/xmms/Input install
find $startdir/pkg -name '*.la' -exec rm {} ;

I think thats about it. Some of what I did above may not be politically
correct so to speak, but the outcome was that it worked.

I hope at least this helps someone from doing tons of searches to
try and get midi support working on thier system.

-- archlinux 是一个极好的 linux


Board footer

Powered by FluxBB