You are not logged in.

#1 2014-04-19 03:36:40

nomasteryoda
Member
From: Georgia, USA
Registered: 2012-11-16
Posts: 7
Website

KDE 4.13 Baloo sucking system resources.

Its a feature not a bug I suppose, but not kind to any system. I followed the 'add your home' to the exclude list, but the thing still hammers away and there are multiple process going on from baloo/akonadi that I needed stopped. So I renamed the binaries - stopped them from running for now. Surely a method to completely disable this short of switching from KDE to Gnome or something else has to be available?

When trying to remove baloo, the result is this: http://pastebin.com/RvuKgYzp .

That is not something I'm willing to do as I installed this Arch Linux and use KDE as my primary desktop since Jan 2012. Over 2 years of excellent stuff IMHO, but forcing users to run software for the sake of the few who really don't mind their hard drives thrashing about, indexing all manner of files is utter nonsense. Maybe Openbox will be my fallback..

rant off...

Peace be with you all mostly.

V/R,
Nomasteryoda

Offline

#2 2014-04-19 07:34:04

Rasi
Member
From: Germany
Registered: 2007-08-14
Posts: 1,844
Website

Re: KDE 4.13 Baloo sucking system resources.

nomasteryoda wrote:

...

Ehm.. disable indexing in systemsettings and be done with it?
wtf, the kcm module has no settings at all? wow, well done kde...

Anyway, thats exactly the reason I stopped using KDE. Someday I realised the only thing I really use was Kwin and maybe dolphin. The devs spend too much energy in projects that nobody uses.

Last edited by Rasi (2014-04-19 07:39:49)


He hoped and prayed that there wasn't an afterlife. Then he realized there was a contradiction involved here and merely hoped that there wasn't an afterlife.

Douglas Adams

Offline

#3 2014-04-19 07:43:00

ilpianista
Fellow developer
From: Lecce, Italy
Registered: 2007-10-06
Posts: 567
Website

Re: KDE 4.13 Baloo sucking system resources.

To disable Baloo you just have to put your home dir in the blacklisting box in System Settings -> Desktop Search.

Baloo only indexes files in /home/$user and doesn't not index any removable device by default. So that trick says to don't index anything.

Offline

#4 2014-04-19 08:02:01

mangus
Member
From: Bologna, Italy
Registered: 2007-04-07
Posts: 288

Re: KDE 4.13 Baloo sucking system resources.

I feel you. That's unfortunate and uncalled for. Why KDE is forcing me using a useless, buggy, unpolished and unfinished file indexer,
in 2014 and SSD hard disks age is beyond my comprehension. I tried a 'fake' baloo package but didn't work as dolphin some of its libs linked to it.
New kde is laggy and I have a powerful gaming rig.
Opensource world is really in a bad state with gnome in tragic conditions, Linus Torvalds having hard time to find volunteers, and the only improvement
you see in KDE is this...If someone find a graceful way to disable this **** without downgrade, recompiling or renaming binaries please let us know.
Sorry, the more I write the more I'm getting pissed

edit:
just saw Andrea response , I'll try that but , seriously, this is a hack. How can someone release something like that? ( I mean KDE, not Andrea work obviously)

edit2:

this in baloofilerc seems to restore old dolphin behaviour

[Basic Settings]
Indexing-Enabled=false

Last edited by mangus (2014-04-19 08:36:01)

Offline

#5 2014-04-19 08:28:18

Rasi
Member
From: Germany
Registered: 2007-08-14
Posts: 1,844
Website

Re: KDE 4.13 Baloo sucking system resources.

ilpianista wrote:

To disable Baloo you just have to put your home dir in the blacklisting box in System Settings -> Desktop Search.

Baloo only indexes files in /home/$user and doesn't not index any removable device by default. So that trick says to don't index anything.

thats only half true. there will still be cleaner threads working
this is also active if you explicitly disable baloo in its settings file, afaik

Last edited by Rasi (2014-04-19 08:29:45)


He hoped and prayed that there wasn't an afterlife. Then he realized there was a contradiction involved here and merely hoped that there wasn't an afterlife.

Douglas Adams

Offline

#6 2014-04-19 09:17:46

ilpianista
Fellow developer
From: Lecce, Italy
Registered: 2007-10-06
Posts: 567
Website

Re: KDE 4.13 Baloo sucking system resources.

Rasi wrote:

thats only half true. there will still be cleaner threads working
this is also active if you explicitly disable baloo in its settings file, afaik

Please read http://vhanda.in/blog/2014/04/desktop-s … iguration/ and if there's a bug report it.

Offline

#7 2014-04-19 10:09:02

mcloaked
Member
From: Yorkshire, UK
Registered: 2012-02-02
Posts: 694

Re: KDE 4.13 Baloo sucking system resources.

mangus wrote:

I feel you. That's unfortunate and uncalled for. Why KDE is forcing me using a useless, buggy, unpolished and unfinished file indexer,
in 2014 and SSD hard disks age is beyond my comprehension. I tried a 'fake' baloo package but didn't work as dolphin some of its libs linked to it.
New kde is laggy and I have a powerful gaming rig.
Opensource world is really in a bad state with gnome in tragic conditions, Linus Torvalds having hard time to find volunteers, and the only improvement
you see in KDE is this...If someone find a graceful way to disable this **** without downgrade, recompiling or renaming binaries please let us know.
Sorry, the more I write the more I'm getting pissed

edit:
just saw Andrea response , I'll try that but , seriously, this is a hack. How can someone release something like that? ( I mean KDE, not Andrea work obviously)

edit2:

this in baloofilerc seems to restore old dolphin behaviour

[Basic Settings]
Indexing-Enabled=false

What has worked for me on several machines is to run the current pacman update, and then do the following. Then logout and back in to kde. Then go to the kde system settings and into Desktop Search, and simply add the user home directory to the list not to search.  Apply the changed setting, and then logout and back in (there will be a slight delay to the logout process at this point due to the initial baloo processes running but just wait out the half minute or so till it logs out). There will be a baloo file cleaner process running when you log back in, which on my machines seemed to run for a few minutes and then stop. At that point if you check the file:

$ cat .kde4/share/config/baloofilerc

you will see at the top that there are already the lines:

[Basic Settings]
Indexing-Enabled=false

[General]
several other lines after this.....

At that point baloo quietens down and there are no further issues with baloo but you need to have a little patience during the initial running of the processes mentioned above, so it is a short term issue only.

I have seen a gentoo thread which suggests that allowing baloo to index email does give a very efficient search even for tens of thousands of mails, but of course the initial indexing process does take a little time and CPU cycles - but once that is complete then it is suggested that it works extremely well. That would only be useful for local email - if you are connecting to remote imap then there is no point in indexing locally.  However I believe that the baloo indexing is very efficient, though it is not clear to me how detailed the search for a particular local email would be, or what parts of the email would be searchable (eg only text in the subject as usual or text across the body?), or which mail clients are set up to use the baloo index data?

Last edited by mcloaked (2014-04-19 15:33:52)


Mike C

Offline

#8 2014-04-19 12:24:41

nomasteryoda
Member
From: Georgia, USA
Registered: 2012-11-16
Posts: 7
Website

Re: KDE 4.13 Baloo sucking system resources.

Indeed. I renamed the binaries and made sure the directories I wanted un-scanned remained so after the 15 minutes of thrashing. Maybe... time will tell if this is a good thing. But for the love of KDE, can't a simple "disable" with a "do not load" button be added to all that extra dialog space below the exclusion box? Just offering an idea here. I really do appreciate the work of the developers as they've done  a superior job of improving the KDE experience through the years.

Offline

#9 2014-04-19 16:49:58

mcloaked
Member
From: Yorkshire, UK
Registered: 2012-02-02
Posts: 694

Re: KDE 4.13 Baloo sucking system resources.

I have found that it is possible to avoid even the initial start of indexing with baloo when I updated another machine a short time ago.  What I did was to run the updates whilst in kde - and then as soon as the updates were done, and before logging out, I went to the desktop search settings and added in my ~/ home area before rebooting the computer - then when I logged back in baloo did not even start doing any file cleaning at all - so no CPU spikes of any kind - so that is in fact all that was needed!

There is still a baloo process listed using ps but it is not doing any CPU work at all and seems idle.....so this way it avoids even the initial start of indexation.


Mike C

Offline

#10 2014-04-19 17:13:54

okubax
Member
From: London
Registered: 2010-04-24
Posts: 183
Website

Re: KDE 4.13 Baloo sucking system resources.

I heard/read good things about Baloo .. and I really tried to use it but no, it's on the same par as the annoying nepomuk. I added my ~home and cleaned out all the junk it created and then restarted. Peace. Finally.

Offline

#11 2014-04-19 17:19:32

mcloaked
Member
From: Yorkshire, UK
Registered: 2012-02-02
Posts: 694

Re: KDE 4.13 Baloo sucking system resources.

okubax wrote:

I heard/read good things about Baloo .. and I really tried to use it but no, it's on the same par as the annoying nepomuk. I added my ~home and cleaned out all the junk it created and then restarted. Peace. Finally.

Which files did you clean out that baloo created?


Mike C

Offline

#12 2014-04-19 17:24:59

Amarildo
Member
Registered: 2013-09-21
Posts: 251
Website

Re: KDE 4.13 Baloo sucking system resources.

Adding /home to the blacklist causes Baloo to use very to no HD resources at all, but now jbd2/dm-3-8 is using 60% of HD resources.


If it ain't broke, you haven't tweaked it enough...

Offline

#13 2014-04-19 17:29:27

okubax
Member
From: London
Registered: 2010-04-24
Posts: 183
Website

Re: KDE 4.13 Baloo sucking system resources.

mcloaked wrote:
okubax wrote:

I heard/read good things about Baloo .. and I really tried to use it but no, it's on the same par as the annoying nepomuk. I added my ~home and cleaned out all the junk it created and then restarted. Peace. Finally.

Which files did you clean out that baloo created?


meant to say akonadi/baloo folders in my ~/.local/share/

Offline

#14 2014-04-19 17:33:16

mcloaked
Member
From: Yorkshire, UK
Registered: 2012-02-02
Posts: 694

Re: KDE 4.13 Baloo sucking system resources.

Amarildo wrote:

Adding /home to the blacklist causes Baloo to use very to no HD resources at all, but now jbd2/dm-3-8 is using 60% of HD resources.

In my machines I added /home/user i.e. ~/ to the avoid list - but I don't know if the distinction is important?


Mike C

Offline

#15 2014-04-19 17:35:24

Skuggen
Member
Registered: 2011-06-14
Posts: 3

Re: KDE 4.13 Baloo sucking system resources.

From http://vhanda.in/blog/2014/04/desktop-s … iguration/

There is no explicit “Enable/Disable” button any more. We would like to promote the use of searching and feel that Baloo should never get in the users way. However, we are smart about it and IF you add your HOME directory to the list of “excluded folders”, Baloo will switch itself off since it no longer has anything to index.

I'd still like a disable button and no running processes...

Offline

#16 2014-04-19 17:41:03

Amarildo
Member
Registered: 2013-09-21
Posts: 251
Website

Re: KDE 4.13 Baloo sucking system resources.

mcloaked wrote:
Amarildo wrote:

Adding /home to the blacklist causes Baloo to use very to no HD resources at all, but now jbd2/dm-3-8 is using 60% of HD resources.

In my machines I added /home/user i.e. ~/ to the avoid list - but I don't know if the distinction is important?

Looks like there is no distinction. Both methods seem to have disabled Baloo, but even so, my HD usage is +60% all the time with the process I told above.


If it ain't broke, you haven't tweaked it enough...

Offline

#17 2014-04-19 17:53:30

Amarildo
Member
Registered: 2013-09-21
Posts: 251
Website

Re: KDE 4.13 Baloo sucking system resources.

I installed XFCE and rebooted. No problems whatsoever. I'll use it whilst KDE doesn't solve these bugs.

Last edited by Amarildo (2014-04-19 18:05:47)


If it ain't broke, you haven't tweaked it enough...

Offline

#18 2014-04-19 18:47:52

mcloaked
Member
From: Yorkshire, UK
Registered: 2012-02-02
Posts: 694

Re: KDE 4.13 Baloo sucking system resources.

Amarildo wrote:
mcloaked wrote:
Amarildo wrote:

Adding /home to the blacklist causes Baloo to use very to no HD resources at all, but now jbd2/dm-3-8 is using 60% of HD resources.

In my machines I added /home/user i.e. ~/ to the avoid list - but I don't know if the distinction is important?

Looks like there is no distinction. Both methods seem to have disabled Baloo, but even so, my HD usage is +60% all the time with the process I told above.

Is that after logging out and back in?

Also I don't know if akonadi control affects this, or is even needed, but in the kde menu under Applications -> Utilities -> Akonadi Tray Utility, if that is activated then if you go to the akonadi server settings via the System Tray, and stop the akonadi server then this also stops the baloo process. If that isn't done then doing

ps eaf|grep akonadi

shows a load of processes associated with akonadi including the baloo indexer.

However akonadi is intimately connected to the kde pim indexing services so I don't know what other impact doing this would have and whether this might impact kmail for example?  I don't use kmail so I have not explored that.


Mike C

Offline

#19 2014-04-19 20:56:09

Amarildo
Member
Registered: 2013-09-21
Posts: 251
Website

Re: KDE 4.13 Baloo sucking system resources.

mcloaked wrote:
Amarildo wrote:
mcloaked wrote:

In my machines I added /home/user i.e. ~/ to the avoid list - but I don't know if the distinction is important?

Looks like there is no distinction. Both methods seem to have disabled Baloo, but even so, my HD usage is +60% all the time with the process I told above.

Is that after logging out and back in?

Also I don't know if akonadi control affects this, or is even needed, but in the kde menu under Applications -> Utilities -> Akonadi Tray Utility, if that is activated then if you go to the akonadi server settings via the System Tray, and stop the akonadi server then this also stops the baloo process. If that isn't done then doing

ps eaf|grep akonadi

shows a load of processes associated with akonadi including the baloo indexer.

However akonadi is intimately connected to the kde pim indexing services so I don't know what other impact doing this would have and whether this might impact kmail for example?  I don't use kmail so I have not explored that.

Weird. After installing XFCE, rebooting, logging into XFCE, the problem was gone. Then I logged out of XFCE and into KDE Plasma Wokspace, and it seems to be over too.
I seriously don't know what happened. But if the problem gets back I'll take a  look into it. Thanks.


If it ain't broke, you haven't tweaked it enough...

Offline

#20 2014-04-19 20:58:14

V1del
Member
Registered: 2012-10-16
Posts: 1,128

Re: KDE 4.13 Baloo sucking system resources.

There was an initial process with 20MB RAM and 10% CPU use that ran for about twenty minutes afterwards all is fine and dandy and the search is blazing along, hardly what I would call sucking CPU resources *shrug*

Offline

#21 2014-04-19 22:05:35

luuuciano
Member
Registered: 2007-01-27
Posts: 306

Re: KDE 4.13 Baloo sucking system resources.

Thats because you have all the pr0n and stuff outside ~/


BTW, I do not want this shit neither... will try to stop it, and delete all the db created

Last edited by luuuciano (2014-04-19 23:18:31)


I arch, you arch, he arch, she arch, we arch, they arch...

Offline

#22 2014-04-21 03:43:37

m00nman
Member
Registered: 2013-01-21
Posts: 8

Re: KDE 4.13 Baloo sucking system resources.

Was fighting with this thing yesterday and today. I left my coputer overnight and then went to work and it was still paintfully slow after I came back home. What helped me was this post: https://bbs.archlinux.org/viewtopic.php … 7#p1390267

Essentially I did this:

$ cp /usr/share/autostart/baloo_file.desktop ~/.kde4/share/autostart/
$ echo "Hidden=True" >> ~/.kde4/share/autostart/baloo_file.desktop

rebooted and it stopped

Offline

#23 2014-04-23 07:24:46

Wilco
Member
Registered: 2008-11-09
Posts: 431

Re: KDE 4.13 Baloo sucking system resources.

The post from m00nman is the cleanest solution and seems to work. Still, replacing the most hated KDE part, nepomuk, with another buggy replacement is uncalled for, nobody uses desktop indexing and forcing it on users is a bad decision from the KDE devs.

Offline

#24 2014-04-23 08:24:45

Primoz
Member
From: Ljubljana-Slovena-EU
Registered: 2009-03-04
Posts: 661

Re: KDE 4.13 Baloo sucking system resources.

I really don't know  what this thread is all about. I got afraid for a second, that I'm missing some important feature.
My baloo_file is currently using 0.0% CPU and 0.4% of RAM. I reset it and then added some folders I don't need indexed, and yeah it hit 80% for like a second, and then it stopped.
It's currently again using 0% CPU and 0.4%RAM. I guess people that complain over it, didn't have nepomuk running before, so now baloo has to index everything.
I on other hand decided to allow nepomuk to use loads of RAM and CPU (in some settings, that were then disabled, don't know why). And it indexed things fast and since then I had pretty much no problem with it.

So yeah, not really a buggy feature, it's more user specific problem.

EDIT: Maybe the reason I have no problem with baloo is, that all of my videos and stuff are on a external drive, which isn't indexed by baloo. Is there a way to get it to index it? I doubt I'll be using file search for films and stuff, but I kind of want to still have them indexed...

Last edited by Primoz (2014-04-23 08:33:42)


Arch x86_64 ATI AMD APU KDE frameworks 5
---------------------------------
Whatever I do, I always end up with something horribly mis-configured.

Offline

#25 2014-04-23 11:22:04

V1del
Member
Registered: 2012-10-16
Posts: 1,128

Re: KDE 4.13 Baloo sucking system resources.

Yeah I find all the fuzz incredibly weird as well, seems like most people complaining didn't use nepomuk anyway, and now have a huge problem with disabling the new engine for some reason, despite the myriad of possibilities mentioned practically everywhere (except for a dedicated button), and decide the best course of action would be ranting all over the place instead of using one of the ways to disable it and go on with their lives,  but whatever.

To enable indexing of external drives, you have to remove them from the blacklist in the Desktop Search KCM

Last edited by V1del (2014-04-23 16:35:51)

Offline

Board footer

Powered by FluxBB