You are not logged in.

#1 2014-04-21 17:49:44

theCed7
Member
Registered: 2014-04-20
Posts: 7

[SOLVED] VirtualBox: Cinnamon running in "software rendering"-Mode

Hi there,

I've installed Arch in Virtualbox. Also all the guest-additions are up and running, sadly Cinnamon still complains about running in "software rendering"-mode, although I clearly selected the hardware-accelerated version.

Do you know how to fix that problem? Host is Windows7.

Last edited by theCed7 (2014-04-26 00:11:04)

Offline

#2 2014-04-21 19:10:42

Stevearch
Member
From: North Wales
Registered: 2014-04-21
Posts: 79

Re: [SOLVED] VirtualBox: Cinnamon running in "software rendering"-Mode

Hi guys!

Hopefully you can shine some light on this one!

I've done a new install of Arch in VirtualBox following the beginners guide to the T. Everything smooth as butter. Got xorg installed and tested with 'startx' then proceeding to install Cinnamon.
Configured my .xinitrc file which works fine and starts cinnamon as it should. The only problem i have is Cinnamon will ONLY run in software rendering mode! I have enabled 3D rendering in VB and allocated 128MB of ram for this.

I've also got my Ubuntu Unity VM working with 3D acceleration fine using the same settings.

And yes Guest additions are installed smile

[stephen@Archey ~]$ lsmod | grep v
joydev                  9631  0
mousedev               10464  0
ppdev                   7118  0
evdev                  10629  8
parport                30517  2 ppdev,parport_pc
vboxvideo               1933  0
drm                   237667  1 vboxvideo
vboxsf                 34614  0
vboxguest             186778  2 vboxsf

Any idea's?

Offline

#3 2014-04-21 19:23:21

Stevearch
Member
From: North Wales
Registered: 2014-04-21
Posts: 79

Re: [SOLVED] VirtualBox: Cinnamon running in "software rendering"-Mode

Same problem here my friend! All other distro's running with 3D fine.

Offline

#4 2014-04-21 19:24:03

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 12,749

Re: [SOLVED] VirtualBox: Cinnamon running in "software rendering"-Mode

What is the host OS?

Edit:  Grrr.. I missed that bit about it working with Ubuntu

Last edited by ewaller (2014-04-21 19:24:57)


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Like you, I have no idea what you are doing, but I am pretty sure it is wrong...Jasonwryan
----
How to Ask Questions the Smart Way

Offline

#5 2014-04-21 19:24:24

Stevearch
Member
From: North Wales
Registered: 2014-04-21
Posts: 79

Re: [SOLVED] VirtualBox: Cinnamon running in "software rendering"-Mode

Windows 8.1

Offline

#6 2014-04-21 19:26:54

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 12,749

Re: [SOLVED] VirtualBox: Cinnamon running in "software rendering"-Mode

I saw Windows 8.1 once.  I know some of the other OSes from them did not support 3D rendering inside of VB.  I missed that you had it working with a Ubuntu.  Dang, you replied to my first post fast!


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Like you, I have no idea what you are doing, but I am pretty sure it is wrong...Jasonwryan
----
How to Ask Questions the Smart Way

Offline

#7 2014-04-21 19:29:08

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 12,749

Re: [SOLVED] VirtualBox: Cinnamon running in "software rendering"-Mode

Moderator:  Merged threads.


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Like you, I have no idea what you are doing, but I am pretty sure it is wrong...Jasonwryan
----
How to Ask Questions the Smart Way

Offline

#8 2014-04-21 19:29:49

Stevearch
Member
From: North Wales
Registered: 2014-04-21
Posts: 79

Re: [SOLVED] VirtualBox: Cinnamon running in "software rendering"-Mode

Haha sorry im sat here spamming F5 waiting for someone to point out something obvious I've missed!
I've noticed another person today has posted the same issue im having sad

Possible bug? I cant think of anything else i could of done to get this working.

Offline

#9 2014-04-24 13:31:18

itisalist
Member
Registered: 2014-04-24
Posts: 2

Re: [SOLVED] VirtualBox: Cinnamon running in "software rendering"-Mode

I have the same problem, even after a fresh install of arch, and I think it is not really cinnamon-related:

$ export LIBGL_DEBUG=verbose
$ glxinfo | grep render
libGL: screen 0 does not appear to be DRI3 capable
libGL error: failed to authenticate magic 3
libGL error: failed to load driver: vboxvideo
libGL: OpenDriver: trying /usr/lib/xorg/modules/dri/tls/swrast_dri.so
libGL: OpenDriver: trying /usr/lib/xorg/modules/dri/swrast_dri.so
libGL: driver does not expose __driDriverGetExtensions_swrast(): /usr/lib/xorg/modules/dri/swrast_dri.so: undefined symbol: __driDriverGetExtensions_swrast
libGL: Can't open configuration file /home/markus/.drirc: No such file or directory.
libGL: Can't open configuration file /home/markus/.drirc: No such file or directory.
direct rendering: Yes
    GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer, 
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.4, 128 bits)
    GL_MESA_ycbcr_texture, GL_NV_blend_square, GL_NV_conditional_render, 

This indicates that the driver can't be loaded by libGL:

[     2.653] (==) VBoxVideo(0): DPMS enabled
[     2.653] (--) RandR disabled
[     2.666] (II) Next line is added to allow vboxvideo_drv.so to appear as whitelisted driver
[     2.666] (II) The file referenced, is *NOT* loaded
[     2.666] (II) Loading /usr/lib/xorg/modules/drivers//ati_drv.so
[     2.666] (EE) AIGLX error: vboxvideo does not export required DRI extension
[     2.667] (EE) AIGLX: reverting to software rendering
[     2.736] (II) AIGLX: Loaded and initialized swrast
[     2.737] (II) GLX: Initialized DRISWRAST GL provider for screen 0

Any ideas anyone?

Offline

#10 2014-04-24 18:51:25

lassekongo83
Member
From: Sweden
Registered: 2011-12-10
Posts: 19
Website

Re: [SOLVED] VirtualBox: Cinnamon running in "software rendering"-Mode

Same problem in gnome-shell on my vbox machine host Win 7. Also user-theme extension seem to crash gnome-shell with some weird blinking when activated. (Not sure if that's related though, but it started to happen at the same time as this.)
Seems to have happened after the mesa 10.1.1-1 update on 2014-04-19. If I'm not mistaken that is the only related update I can think of as the other updated packages had nothing to do with graphics.

Edit: Confirmed - mesa 10.1.1-1 was the problem both for the software rendering and the user-theme extension crash. Downgrading to mesa and mesa-libgl 10.1.0-5 fixed it for me.

Last edited by lassekongo83 (2014-04-25 05:03:05)

Offline

#11 2014-04-25 07:38:55

itisalist
Member
Registered: 2014-04-24
Posts: 2

Re: [SOLVED] VirtualBox: Cinnamon running in "software rendering"-Mode

This solved the problem for me as well. Cinnamon is now using 3D acceleration after downgrade:

sudo pacman -U mesa-libgl-10.1.0-5-x86_64.pkg.tar.xz  mesa-10.1.0-5-x86_64.pkg.tar.xz 

I filed a bug report here: https://bugs.archlinux.org/task/40082

Offline

#12 2014-04-25 08:13:09

Stevearch
Member
From: North Wales
Registered: 2014-04-21
Posts: 79

Re: [SOLVED] VirtualBox: Cinnamon running in "software rendering"-Mode

Cheers guys. I will mark this one as solved smile

Just out of curiosity.... How did you figure out what was causing the issue?
Just so i can do some digging of my own in the future tongue!

Offline

#13 2014-04-25 08:24:23

Stevearch
Member
From: North Wales
Registered: 2014-04-21
Posts: 79

Re: [SOLVED] VirtualBox: Cinnamon running in "software rendering"-Mode

Looks like Ced will need to mark this one as resolved tongue

Offline

#14 2014-04-25 08:39:09

develop
Member
Registered: 2014-04-25
Posts: 14

Re: [SOLVED] VirtualBox: Cinnamon running in "software rendering"-Mode

Same problem here.....

No 3d both in Arch and Ubuntu

Offline

#15 2014-04-26 00:10:26

theCed7
Member
Registered: 2014-04-20
Posts: 7

Re: [SOLVED] VirtualBox: Cinnamon running in "software rendering"-Mode

Stevearch wrote:

Looks like Ced will need to mark this one as resolved tongue

Of course. Thanks a lot there guys, downgrading solved my problem too. smile

Offline

Board footer

Powered by FluxBB