You are not logged in.

#1 2014-04-22 01:23:19

zanny
Member
Registered: 2012-10-05
Posts: 71

[SOLVED] Baloo polkit prompting after upgrading to KDE 4.13

I encountered a strange behavior after my KDE 4.13 upgrade, where whenever I'd start a new session Baloo would do a KAuth against the folder watch limit. If you get this bug, the solution is to go to /etc/sysctl.d and delete any kde-nepomuk entries in there, because what happens is the baloo entry is parsed first, and then the value is reset by the old nepomuk one. The files aren't cleaned up after the upgrade.

This isn't really a package bug, though, because the watch limit files in /etc/sysctl from the semantic desktop searchers are generated after the first elevated kauth prompt.

Just wanted to let anyone else that encountered this know the fix.

Last edited by zanny (2014-04-22 01:24:32)

Offline

#2 2014-04-22 13:26:57

karol
Archivist
Registered: 2009-05-06
Posts: 25,424

Re: [SOLVED] Baloo polkit prompting after upgrading to KDE 4.13

zanny wrote:

his isn't really a package bug, though, because the watch limit files in /etc/sysctl

Remember about https://www.archlinux.org/news/deprecat … ysctlconf/


Maybe this advice should go to the wiki rather than the forum?

Offline

#3 2014-04-24 22:25:42

MW
Member
Registered: 2007-07-27
Posts: 127

Re: [SOLVED] Baloo polkit prompting after upgrading to KDE 4.13

Just posting this here in case other come across this as well.

This is not the solution. The error you see is not an error, it is part of the new "Desktop Search" policy in KDE 4.13 and will show itself until you give it user permission.

You can read all about here:
http://userbase.kde.org/Nepomuk

How can I disable the semantic desktop?

    File indexing can be disabled by adding the users' home folder to the System Settings -> Desktop Search -> Do not search in these locations list. The other functionality is part of the applications that use it and thus can't be disabled without crippling these applications. For example, to not have any search in KMail you'll have to simply remove KMail...

Note the part in bold...
As of yet I cannot seem to find a way to disable Strigi/Nepomuk entirely without wrecking KDE, and it seems in future KDE users will be forced to use this "search and indexing tech" from KDE whether you want to or not.

Offline

#4 2014-04-28 17:45:58

Zancarius
Member
From: NM, USA
Registered: 2012-05-06
Posts: 203

Re: [SOLVED] Baloo polkit prompting after upgrading to KDE 4.13

zanny wrote:

I encountered a strange behavior after my KDE 4.13 upgrade, where whenever I'd start a new session Baloo would do a KAuth against the folder watch limit. If you get this bug, the solution is to go to /etc/sysctl.d and delete any kde-nepomuk entries in there, because what happens is the baloo entry is parsed first, and then the value is reset by the old nepomuk one. The files aren't cleaned up after the upgrade.

This is a big help, although I ran into something curious (but related).

I already had a prior entry in /etc/sysctl.d to bump fs.inotify.max_user_watches because of related failures with Grunt watch on a large-ish project. Unfortunately, the number apparently was't sufficient to appease Baloo, so I had to remove the entry. Either way, it appears fixed for now.

MW wrote:

As of yet I cannot seem to find a way to disable Strigi/Nepomuk entirely without wrecking KDE, and it seems in future KDE users will be forced to use this "search and indexing tech" from KDE whether you want to or not.

Curiously, I've not had any luck so far with stopping Baloo from attempting to index everything it shouldn't, even when adding my home dir to its exclude list. I'm not entirely sure if this is a bug in Baloo or whether I misunderstand the intent of the exclusion list, but it appears that regardless of what directory I add, if there are child directories present, it'll happily index each of those regardless of the presence (or absence) of the parent directory. For instance, if I have a /misc, under which exists a number of NFS mounts, it'll happily attempt to index each of those in spite of adding /misc to the exclusion list. (Though I also found it indexing everything in /var, including my pacman cache in spite of attempting to add /var/cache/pacman/pkg to the exclude, so it appears that it's consistently indiscriminate.)

I'm very displeased with the direction KDE has taken in giving us no choice insofar as disabling desktop search (time to submit a patch?). I've never used it to begin with, because the subset of files I generally need to search is small enough that I 1) know roughly which files whose contents I'm interested in and 2) find/grep have always worked well enough for me. Background indexing processes, particularly misbehaving ones, are infuriating to me. This is especially true when I have no need (and probably never will have any need) to search probably 98%+ of the contents on my drive but are nevertheless kept for historical and/or legal purposes.

Of interest, one the KDE developers working on Baloo (according to a link to the individual's blog post from Ask Ubuntu) explicitly stated that indexing cannot be turned off. Period. Quote:

There is no explicit “Enable/Disable” button any more. We would like to promote the use of searching and feel that Baloo should never get in the users way. However, we are smart about it and IF you add your HOME directory to the list of “excluded folders”, Baloo will switch itself off since it no longer has anything to index.

These seems unnecessarily user hostile. I also disagree with the author's assertion that Baloo is "smart enough" to switch itself off. Empirical testing and an strace of the misbehaving process suggests otherwise, so I wonder if stray entries from Nepomuk may interfere with Baloo's understanding of what constitutes excluded directories.


He who has no .plan has small finger.
~Confucius on UNIX.

Offline

#5 2014-04-30 17:44:21

Zancarius
Member
From: NM, USA
Registered: 2012-05-06
Posts: 203

Re: [SOLVED] Baloo polkit prompting after upgrading to KDE 4.13

Ah hah!

After some repeat irritation, I found this series of instructions from Arch's very own Andrea Scarpino which appears to disable Baloo quite nicely. It wasn't immediately obvious that the link itself was the first result from Google (serves me right for not examining that more closely, huh?), so I'd actually found it linked from this discussion.

Hopefully anyone who stumbles across this will realize they made the same mistake I did and probably mistook the KDE announcement post as extraneous noise, discounting its applicability to Baloo.


He who has no .plan has small finger.
~Confucius on UNIX.

Offline

Board footer

Powered by FluxBB