You are not logged in.

#1 2014-04-22 09:36:12

donny
Member
Registered: 2013-07-03
Posts: 4

[fixed] Empathy and Gnome Contacts crashing with zeitgeist-0.9.14-2

Hello,
if you are using Empathy or gnome-contacts, you could notice that GUI crashes after openning.

Error:

gnome-contacts:

** (gnome-contacts:2254): WARNING **: sql.vala:350: db-reader.vala:307: SQL error: 1, near ")": syntax error

empathy:

** (empathy:2621): WARNING **: sql.vala:350: db-reader.vala:307: SQL error: 1, near ")": syntax error
g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.                                                                                                                         

You can "fix it" temporarily by downgrading the package zeitgeist to 0.9.14-1

Last edited by donny (2014-04-22 11:31:39)

Offline

#2 2014-04-22 09:54:16

fredbezies
Member
Registered: 2011-07-28
Posts: 343

Re: [fixed] Empathy and Gnome Contacts crashing with zeitgeist-0.9.14-2

Did you report it ? It will be a great way to get a real bug fix, not a workaround smile

Offline

#3 2014-04-22 10:10:56

donny
Member
Registered: 2013-07-03
Posts: 4

Re: [fixed] Empathy and Gnome Contacts crashing with zeitgeist-0.9.14-2

It already has been reported by Artem Hluvchynskyi - https://bugs.archlinux.org/task/40003 , I wanted to write down working hotfix for other users.

Offline

#4 2014-04-22 10:54:34

fredbezies
Member
Registered: 2011-07-28
Posts: 343

Re: [fixed] Empathy and Gnome Contacts crashing with zeitgeist-0.9.14-2

donny wrote:

It already has been reported by Artem Hluvchynskyi - https://bugs.archlinux.org/task/40003 , I wanted to write down working hotfix for other users.

Ok. It would have been better to post bug report url in your first post smile

Offline

#5 2014-04-22 11:31:13

donny
Member
Registered: 2013-07-03
Posts: 4

Re: [fixed] Empathy and Gnome Contacts crashing with zeitgeist-0.9.14-2

The bug report didn't exist by the time I was writing the post.

zeitgeist 0.9.14-3 is out and fixes the problem.

Offline

#6 2014-04-22 13:44:03

SilverOne
Member
From: Portugal
Registered: 2013-08-22
Posts: 69

Re: [fixed] Empathy and Gnome Contacts crashing with zeitgeist-0.9.14-2

It is still crashing for me after updating zeitgeist:

[silverone@silver-arch ~]$ pacman -Q zeitgeist
zeitgeist 0.9.14-3
[silverone@silver-arch ~]$ empathy

(empathy:1159): GLib-CRITICAL **: g_variant_ref: assertion 'value->ref_count > 0' failed

(empathy:1159): GLib-CRITICAL **: g_variant_unref: assertion 'value->ref_count > 0' failed
g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.
Terminated
[silverone@silver-arch ~]$ 

i also deleted
~/.config/Empathy
and
~/.cache/telepathy

Downgrading zeitgeist did it for me.

Last edited by SilverOne (2014-04-22 13:51:05)


Best Regards,
SilverOne

Offline

#7 2014-04-22 15:20:16

SilverOne
Member
From: Portugal
Registered: 2013-08-22
Posts: 69

Re: [fixed] Empathy and Gnome Contacts crashing with zeitgeist-0.9.14-2

zeitgeist 0.9.15-1 did it for me.


Best Regards,
SilverOne

Offline

Board footer

Powered by FluxBB