You are not logged in.

#1 2014-04-23 07:43:31

kungfoo
Member
Registered: 2006-09-09
Posts: 43

[Solved] After kernel upgrade to 3.14.x USB audio is no longer working

I upgraded my system yesterday after being away from it for about a week.

I have a Schiit Modi DAC that is connected via USB and works (or rather used to work) as a generic USB audio device just fine.
Today I find that it has stopped working. Relevant lines of dmesg seem to be:

[    1.290380] usb 1-2: new high-speed USB device number 2 using ehci-pci
[    1.425845] hidraw: raw HID events driver (C) Jiri Kosina
[    1.427357] usbcore: registered new interface driver usbhid
[    1.427358] usbhid: USB HID core driver
[    1.428445] input: Schiit Schiit USB Audio Device as /devices/pci0000:00/0000:00:1a.7/usb1/1-2/1-2:1.2/0003:0D8C:1319.0001/input/input0
[    1.428634] hid-generic 0003:0D8C:1319.0001: input,hidraw0: USB HID v1.00 Device [Schiit Schiit USB Audio Device] on usb-0000:00:1a.7-2/input2

Yet later on:

[    1.916818] cannot find the slot for index 0 (range 0-1), error: -16
[    1.916823] cannot create card instance 0
[    1.916828] snd-usb-audio: probe of 1-2:1.0 failed with error -5
[    1.916845] usbcore: registered new interface driver snd-usb-audio

If I disconnect and reconnect the device from USB:

[ 2302.865443] usb 1-2: USB disconnect, device number 4
[ 2326.517954] usb 1-2: new high-speed USB device number 5 using ehci-pci
[ 2326.654468] cannot find the slot for index 0 (range 0-1), error: -16
[ 2326.654472] cannot create card instance 0
[ 2326.654479] snd-usb-audio: probe of 1-2:1.0 failed with error -5
[ 2326.657977] input: Schiit Schiit USB Audio Device as /devices/pci0000:00/0000:00:1a.7/usb1/1-2/1-2:1.2/0003:0D8C:1319.0007/input/input13
[ 2326.658360] hid-generic 0003:0D8C:1319.0007: input,hidraw0: USB HID v1.00 Device [Schiit Schiit USB Audio Device] on usb-0000:00:1a.7-2/input2

Any ideas, why it would suddenly stop working?

Last edited by kungfoo (2014-06-24 14:35:47)

Offline

#2 2014-04-23 12:02:36

karol
Archivist
Registered: 2009-05-06
Posts: 25,437

Re: [Solved] After kernel upgrade to 3.14.x USB audio is no longer working

What's the output of

pacman -Q linux
uname -r

Offline

#3 2014-04-23 13:53:06

kungfoo
Member
Registered: 2006-09-09
Posts: 43

Re: [Solved] After kernel upgrade to 3.14.x USB audio is no longer working

➜  ~  pacman -Q linux                                                                   
linux 3.14.1-1
➜  ~  archey 

               +                
               #                
              ###               
             #####              
             ######             
            ; #####;            User: kungfoo
           +##.#####            Hostname: random_host_name
          +##########           Distro: Arch Linux
         #############;         Kernel: 3.14.1-1-ARCH
        ###############+        Uptime: 6:49
       #######   #######        Window Manager: Awesome
     .######;     ;###;`".      Desktop Environment: 
    .#######;     ;#####.       Shell: /bin/zsh
    #########.   .########`     Terminal: xterm
   ######'           '######    Packages: 817
  ;####                 ####;   CPU: Intel(R) Xeon(R) CPU W3530 @ 2.80GHz
  ##'                     '##   RAM: 5808 MB / 16041 MB 
 #'                         `#  Disk: 275G / 1.2T

Offline

#4 2014-04-24 11:35:22

kungfoo
Member
Registered: 2006-09-09
Posts: 43

Re: [Solved] After kernel upgrade to 3.14.x USB audio is no longer working

Downgrading to 3.13.8-1-ARCH fixes the problem and the card is recognized properly again and works.
This still means that something in 3.14 is broken...

Offline

#5 2014-05-13 13:15:15

kungfoo
Member
Registered: 2006-09-09
Posts: 43

Re: [Solved] After kernel upgrade to 3.14.x USB audio is no longer working

This is also not working with 3.14.3 which, according to the changelog, fixes several issues with USB...

Offline

#6 2014-06-23 07:33:01

kungfoo
Member
Registered: 2006-09-09
Posts: 43

Re: [Solved] After kernel upgrade to 3.14.x USB audio is no longer working

So, I've taken the steps today to upgrade to the newest kernel and this still isn't working. I don't want to be stuck on 3.13.8.

Current system:

➜  ~  pacman -Q linux
linux 3.15.1-1
➜  ~  archey 

               +                
               #                
              ###               
             #####              
             ######             
            ; #####;            User: kungfoo
           +##.#####            Hostname: random_host_name
          +##########           Distro: Arch Linux
         #############;         Kernel: 3.15.1-1-ARCH
        ###############+        Uptime: 0:01
       #######   #######        Window Manager: Awesome
     .######;     ;###;`".      Desktop Environment: 
    .#######;     ;#####.       Shell: /bin/zsh
    #########.   .########`     Terminal: xterm
   ######'           '######    Packages: 826
  ;####                 ####;   CPU: Intel(R) Xeon(R) CPU W3530 @ 2.80GHz
  ##'                     '##   RAM: 682 MB / 16041 MB 
 #'                         `#  Disk: 296G / 1.2T

When I unplug, then replug the device I still get this output in dmesg:

[   45.047113] usb 1-2: USB disconnect, device number 2
[   50.302089] usb 1-2: new high-speed USB device number 4 using ehci-pci
[   50.435408] snd-usb-audio 1-2:1.0: cannot find the slot for index 0 (range 0-1), error: -16
[   50.435414] usb 1-2: cannot create card instance 0
[   50.435421] snd-usb-audio: probe of 1-2:1.0 failed with error -5
[   50.438980] input: Schiit Schiit USB Audio Device as /devices/pci0000:00/0000:00:1a.7/usb1/1-2/1-2:1.2/0003:0D8C:1319.0005/input/input11
[   50.439133] hid-generic 0003:0D8C:1319.0005: input,hidraw0: USB HID v1.00 Device [Schiit Schiit USB Audio Device] on usb-0000:00:1a.7-2/input2

Is there anyone using the same or a similar device, where this works?

Offline

#7 2014-06-23 07:52:33

kungfoo
Member
Registered: 2006-09-09
Posts: 43

Re: [Solved] After kernel upgrade to 3.14.x USB audio is no longer working

This can also be fixed by blacklisting the module 'snd_hda_intel'.

Offline

Board footer

Powered by FluxBB