You are not logged in.

#1 2014-04-25 06:41:21

Gooler
Member
Registered: 2009-11-01
Posts: 14

Kate's Python utils pluging not working

Hi, I've recently updated my system and noticed Kate 3.13.0 with Pate 2.0 no longer highlighting syntax or pep8 errors while editing python scripts.
Other Pathe plugins are working ok.

I've checked kate's settings and noticed that there were no python utils among the available plugins.
So I started researching and went to /usr/share/apps/kate/pate the folder where the plugins are, and noticed that python_utils module doesn't have an __init__.py file in it. I created one, restarted Kate and now Python Utils show up on the list of available plugins, but still, checking it and accepting the changes in the settings dialog doesn't seem to activate the plugin as analysis and highlighting is still not working.

Any idea?

Last edited by Gooler (2014-04-25 06:43:32)

Offline

#2 2014-04-25 06:58:59

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 1,120

Re: Kate's Python utils pluging not working

Do you have kdebindings-python installed?

> LANG=C pacman -Qi kdesdk-kate
...
Optional Deps  : kdebase-konsole: open a terminal in Kate [installed]
                 kdebindings-python: python bindings [installed]

Online

#3 2014-04-25 07:46:09

Gooler
Member
Registered: 2009-11-01
Posts: 14

Re: Kate's Python utils pluging not working

Yeah, the dependencies are already installed

Optional Deps  : kdebase-konsole: open a terminal in Kate [installed]
                 kdebindings-python: python bindings [installed]

Offline

Board footer

Powered by FluxBB